
 

 

Microsoft Excel XP 
Manual - Intermediate Level 
 

  C
h

e
lte

n
h

a
m

 C
o

u
rse

w
a
re

 –
 w

w
w

.cctg
lo

b
a
l.co

m
 

SAMPLE



Page 2 – Microsoft Excel Xp - Intermediate Level Manual 

FOR USE AT THE LICENSED SITE(S) ONLY 
 Cheltenham Courseware Ltd. 1995-2010 www.cheltenhamcourseware.com 

© 1995-2010 Cheltenham Courseware Pty. Ltd.  
 
All trademarks acknowledged. E&OE. 
 
No part of this document may be copied without written permission from Cheltenham Courseware unless 
produced under the terms of a courseware site license agreement with Cheltenham Courseware. 
 
All reasonable precautions have been taken in the preparation of this document, including both technical and 
non-technical proof ing. Cheltenham Courseware and all staff assume no responsibility f or any errors or 
omissions. No warranties are made, expressed or implied with regard to these notes. Cheltenham Courseware 
shall not be responsible f or any direct, incidental or consequential damages arising from the use of any material 
contained in this document. If you find any errors in these training modules, please inform Cheltenham 
Courseware. Whilst every effort is made to eradicate ty ping or technical mistakes, we apologise f or any errors 
y ou may detect. All courses are updated on a regular basis, so your feedback is both valued by us and will help 
us to maintain the highest possible standards. 
 
Sample versions of courseware from Cheltenham Courseware 
(Normally supplied in Adobe Acrobat format): If the version of courseware that you are v iewing is marked as NOT 
FOR TRAINING, SAMPLE, or similar, then it cannot be used as part of a training course, and is made available 
purely f or content and style review. This is to giv e y ou the opportunity to prev iew our courseware, prior to making 
a purchasing decision. Sample v ersions may not be re-sold to a third party. 
 
For current license information 
This document may only be used under the terms of the license agreement f rom Cheltenham Courseware. 
Cheltenham Courseware reserves the right to alter the licensing conditions at any time, without prior notice. 
Please see the site license agreement available at:  www.cheltenhamcourseware.com.au/agreement 
 
Contact Information 
 
Australia / Asia Pacific / Europe (ex. UK) / Rest of the World 
Email: info@cheltenhamcourseware.com.au 
Web: www.cheltenhamcourseware.com.au 
 
USA / Canada 
Email: info@cheltenhamcourseware.com 
Web: www.cheltenhamcourseware.com 
 

UK  
Email: info@cctglobal.com 
Web: www.cctglobal.com 
 

 

SAMPLE



Page 3 – Microsoft Excel Xp - Intermediate Level Manual 

FOR USE AT THE LICENSED SITE(S) ONLY 
 Cheltenham Courseware Ltd. 1995-2010 www.cheltenhamcourseware.com 

 

VIEWING WORKSHEETS ........................................................................................................ 7 

CUSTOMIZING VIEW OPTIONS................................................................................................... 7 
Customizing the Excel window display .............................................................................. 7 
Customizing the Comments View options ......................................................................... 8 
Customizing the Objects View options............................................................................... 8 
Customizing the Worksheet View options.......................................................................... 8 

DISPLAYING AND CUSTOMIZING TOOLBARS .............................................................................. 9 
Choosing a Toolbar ............................................................................................................ 9 
Displaying Toolbars...........................................................................................................10 
Customizing Toolbar Options............................................................................................10 
Adding Commands to a Toolbar........................................................................................11 

HIDING WORKBOOKS AND WORKSHEETS.................................................................................11 
Hiding a Workbook ............................................................................................................11 
Hiding Worksheets.............................................................................................................11 
Displaying hidden Workbooks...........................................................................................11 
Displaying hidden Worksheets..........................................................................................12 

FREEZING PANES ....................................................................................................................12 
Freezing a horizontal pane................................................................................................12 
Freezing a vertical pane ....................................................................................................13 
Freezing horizontal and vertical panes .............................................................................13 
Unfreezing panes...............................................................................................................13 

GROUPING AND UNGROUPING WORKSHEETS ..........................................................................13 
Grouping Worksheets........................................................................................................13 
To select all Worksheets ...................................................................................................14 
To select several Worksheets ...........................................................................................14 
Ungrouping Worksheets....................................................................................................14 

REVIEW QUESTIONS................................................................................................................14 

MORE FORMATTING TECHNIQUES .....................................................................................16 

USING STYLES ........................................................................................................................16 
Creating a new style ..........................................................................................................16 
Applying a style..................................................................................................................17 
Changing the formatting of a style.....................................................................................17 
Removing a style from cells...............................................................................................17 
Deleting a style ..................................................................................................................18 

CONDITIONAL FORMATTING .....................................................................................................18 
Using conditional formatting..............................................................................................18 
Changing conditional formatting........................................................................................19 
Deleting conditional formatting..........................................................................................19 
Finding cells with conditional formatting............................................................................19 

USING THE FORMAT PAINTER ..................................................................................................20 
Copying and applying cell formatting with the Format Painter .........................................20 
Copying and applying column width or row height with the Format Painter.....................20 
Copying and applying cell formatting with the Format Painter .........................................21 
Copying and applying the Format Painter in multiple locations........................................21 

USING GUIDELINES .................................................................................................................21 
Changing the color of the Gridlines...................................................................................21 
Turning off the onscreen Gridlines....................................................................................22 
Printing Gridlines ...............................................................................................................22 

HIDING AND DISPLAYING CELLS...............................................................................................22 
Hiding Columns .................................................................................................................22 
Hiding Rows.......................................................................................................................23 
Using the mouse to hide Columns ....................................................................................23 

SAMPLE



Page 4 – Microsoft Excel Xp - Intermediate Level Manual 

FOR USE AT THE LICENSED SITE(S) ONLY 
 Cheltenham Courseware Ltd. 1995-2010 www.cheltenhamcourseware.com 

Using the mouse to hide Rows..........................................................................................23 
Displaying hidden Columns...............................................................................................23 
Displaying hidden Rows ....................................................................................................24 
Using the mouse to display hidden Columns....................................................................24 
Using the mouse to display hidden Rows .........................................................................24 

REVIEW QUESTIONS................................................................................................................25 

MORE FORMULAS AND FUNCTIONS...................................................................................26 

USING THE SERIES COMMAND.................................................................................................27 
Using the Series Command ..............................................................................................27 
Applying a list series..........................................................................................................27 
Applying a numeric series .................................................................................................27 
Applying a basic numeric series........................................................................................28 
Creating a custom list series .............................................................................................28 

USING THE INSERT FUNCTION WIZARD....................................................................................29 
Displaying the Insert Function wizard ...............................................................................29 
Choosing a function from the Insert Function wizard........................................................30 
Entering Function Arguments in the Insert Function wizard.............................................30 

USING THE EXCEL FUNCTION CATEGORIES .............................................................................31 
Using the Most Recently Used function category .............................................................31 
Using the Financial function category...............................................................................32 
Using the Date & Time function category..........................................................................33 
Using the Math & Trig function category...........................................................................34 
Using the Statistical function category..............................................................................37 
Using the Lookup & Reference function category ............................................................39 
Using the Database function category..............................................................................41 
Using the Text function category.......................................................................................41 
Using the Logical function category..................................................................................43 
Using the Information function category............................................................................44 

CORRECTING FORMULAS ........................................................................................................45 
Finding and correcting errors in Formulas ........................................................................45 
Finding error values...........................................................................................................45 
Correcting error values......................................................................................................45 

USING THE FORMULA ERROR CHECKER ..................................................................................46 
Using the Formula error checker.......................................................................................46 
Rechecking ignored errors ................................................................................................47 
Customizing the Formula error checker............................................................................47 

USING THE FORMULA AUDITING TOOLBAR...............................................................................48 
Displaying the Formula Auditing toolbar ...........................................................................48 
Using the Formula Auditing toolbar...................................................................................48 
Tracing Precedents............................................................................................................49 
Removing Precedent Arrows.............................................................................................49 
Tracing Dependents ..........................................................................................................49 
Removing Dependent Arrows ...........................................................................................50 
Adding a new comment .....................................................................................................50 
Evaluating Formulas one step at a time............................................................................50 

USING THE WATCH WINDOW...................................................................................................51 
Using the Watch Window ..................................................................................................51 
Adding a Watch to a cell....................................................................................................52 
Adding a Watch to all the cells with Formulas ..................................................................52 
Displaying a cell in the Watch Window .............................................................................52 
Deleting a Watch ...............................................................................................................53 
Hiding the Watch Window .................................................................................................53 

REVIEW QUESTIONS................................................................................................................53 

SAMPLE



Page 5 – Microsoft Excel Xp - Intermediate Level Manual 

FOR USE AT THE LICENSED SITE(S) ONLY 
 Cheltenham Courseware Ltd. 1995-2010 www.cheltenhamcourseware.com 

DATABASE AND LIST MANAGEM ENT .................................................................................55 

USING DATABASES ..................................................................................................................55 
Using the Excel database features ...................................................................................55 
Using database terminology..............................................................................................56 

CREATING AND EDITING A DATABASE ......................................................................................56 
Creating an Excel database ..............................................................................................56 
Working with an Excel database .......................................................................................56 

SORTING A DATABASE .............................................................................................................56 
Sorting data within a database ..........................................................................................56 
Adding other sorting criteria ..............................................................................................57 

USING AUTOFILTERS...............................................................................................................57 
Filtering data ......................................................................................................................57 
Filtering data with AutoFilter..............................................................................................58 
Specifying a conditional filter with AutoFilter.....................................................................58 
Using the Top 10 AutoFilter...............................................................................................59 
Removing all AutoFilters....................................................................................................59 

ADVANCED FILTERS ................................................................................................................60 
Using Advanced Filters......................................................................................................60 
Removing all Advanced Filters..........................................................................................61 

WORKING WITH FILTERED DATA ..............................................................................................61 
Manipulating Filtered Data.................................................................................................61 
Totaling fields within a filtered database list......................................................................61 
Creating Subtotals .............................................................................................................62 
Remove Subtotals .............................................................................................................63 

USING DATA FORMS ................................................................................................................63 
Using a Data Form.............................................................................................................63 
Adding a new record..........................................................................................................64 
Moving between records ...................................................................................................64 
Finding records..................................................................................................................64 
Editing a record..................................................................................................................65 
Deleting a record ...............................................................................................................65 
Closing a Data Form..........................................................................................................65 

REVIEW QUESTIONS................................................................................................................65 

CHARTS ...................................................................................................................................67 

CHART WIZARD.......................................................................................................................67 
Using the Chart Wizard .....................................................................................................67 
Selecting the Chart Type ...................................................................................................68 
Specifying the Data Source ...............................................................................................68 
Customizing the Chart .......................................................................................................69 
Defining the Chart Location...............................................................................................72 

CHART TOOLBAR.....................................................................................................................72 
Displaying the Chart toolbar..............................................................................................72 
Using the Chart toolbar......................................................................................................73 
Selecting a Chart ...............................................................................................................73 
Selecting Chart objects......................................................................................................73 

WORKING WITH CHARTS..........................................................................................................74 
Changing the Chart Type ..................................................................................................74 
Adding data to a Chart .......................................................................................................74 
Removing data from a Chart .............................................................................................75 
Moving a Chart ..................................................................................................................75 
Resizing a Chart ................................................................................................................75 
Deleting a Chart.................................................................................................................75 

FORMATTING THE CHART........................................................................................................75 

SAMPLE



Page 6 – Microsoft Excel Xp - Intermediate Level Manual 

FOR USE AT THE LICENSED SITE(S) ONLY 
 Cheltenham Courseware Ltd. 1995-2010 www.cheltenhamcourseware.com 

Formatting the Chart Area .................................................................................................75 
Formatting the Chart Title..................................................................................................76 
Formatting the Plot Area....................................................................................................76 
Formatting the Axis............................................................................................................77 
Formatting the Axis Title....................................................................................................77 
Formatting the Legend ......................................................................................................77 
Formatting the Gridlines ....................................................................................................78 
Formatting the Data Series................................................................................................78 

REVIEW QUESTIONS................................................................................................................79 

DRAWING AND PICTURE OBJECTS ....................................................................................80 

DRAWING TOOLBAR ................................................................................................................80 
Displaying the Drawing toolbar..........................................................................................80 
Using the Drawing toolbar .................................................................................................80 

WORKING WITH AUTOSHAPES.................................................................................................82 
Inserting an AutoShape object ..........................................................................................82 
Drawing common objects ..................................................................................................82 
Formatting AutoShape objects..........................................................................................83 
Selecting an object ............................................................................................................83 
Changing the look of AutoShape lines ..............................................................................83 
Changing the look of AutoShape arrows...........................................................................84 
Adding a shadow ...............................................................................................................85 
Applying the 3-D option .....................................................................................................85 
Moving an object................................................................................................................86 
Copying objects .................................................................................................................86 
Resizing an object .............................................................................................................86 

CREATING TEXT BOXES ..........................................................................................................86 
Creating a text box.............................................................................................................86 
Editing text in a text box ....................................................................................................87 
Resizing a text box ............................................................................................................87 
Deleting a text box.............................................................................................................87 

ADDING PICTURES ..................................................................................................................87 
Inserting Clip Art ................................................................................................................87 
Inserting a picture ..............................................................................................................88 
Using the Picture toolbar ...................................................................................................88 
Moving a clip art or picture ................................................................................................88 
Copying a clip art or picture...............................................................................................89 
Resizing an object .............................................................................................................89 

LAYERING OBJECTS ................................................................................................................89 
Changing the layer order of objects ..................................................................................89 

GROUPING AND UNGROUPING OBJECTS..................................................................................90 
Grouping objects................................................................................................................90 
Ungrouping objects............................................................................................................90 

REVIEW QUESTIONS................................................................................................................90 

EXCEL 2002 AND OTHER APPLICATIONS ..........................................................................92 

CONVERTING FILES FROM OTHER APPLICATIONS ....................................................................92 
Converting spreadsheets from other applications ............................................................92 

COPYING DATA FROM ANOTHER APPLICATION.........................................................................92 
Using the Office Clipboard.................................................................................................93 
Using Paste Special...........................................................................................................93 
Using Paste Special with content from Excel....................................................................93 
Using Paste Special with content from other application..................................................94 
Changing data to graphic objects......................................................................................94 

EMBEDDING AND LINKING OBJECTS.........................................................................................95 

SAMPLE



Page 7 – Microsoft Excel Xp - Intermediate Level Manual 

FOR USE AT THE LICENSED SITE(S) ONLY 
 Cheltenham Courseware Ltd. 1995-2010 www.cheltenhamcourseware.com 

Embedding data.................................................................................................................95 
Embedding an existing document .....................................................................................96 
Linking data........................................................................................................................96 
Creating a link to an existing file........................................................................................96 
Linking data from Microsoft Word......................................................................................97 

HYPERLINKS............................................................................................................................98 
Using Hyperlinks................................................................................................................98 
Creating a Hyperlink..........................................................................................................98 

MANAGING LINKS ....................................................................................................................98 
Updating Links ...................................................................................................................99 
Editing Links.......................................................................................................................99 
Checking the status of a Link ............................................................................................99 
Breaking Links ................................................................................................................. 100 

REVIEW QUESTIONS.............................................................................................................. 100 
 
 
 

SAMPLE



Page 8 – Microsoft Excel Xp - Intermediate Level Manual 

FOR USE AT THE LICENSED SITE(S) ONLY 
 Cheltenham Courseware Ltd. 1995-2010 www.cheltenhamcourseware.com 

Viewing Worksheets 
 
When you have completed this learning module you will have seen how to: 

 Customize the Excel window display 
 Customize the Comments View options 
 Customize the Objects View options 
 Customize the Worksheet View options 
 Choose a Toolbar 
 Display Toolbars 
 Customize Toolbar Options 
 Add Commands to a Toolbar 
 Hide a Workbook 
 Hide Worksheets 
 Display hidden Workbooks 
 Display hidden Worksheets 
 Freeze a horizontal pane 
 Freeze a vertical pane 
 Freeze horizontal and vertical panes 
 Unfreeze panes 
 Group Worksheets 
 Ungroup Worksheets 
 
 

Customizing View Options 
 

Customizing the Excel window display 
 From the main menu, choose Tools > Options to display the Options dialog 

box, click on the View tab, and select the following options from the Show 
area: 
 

 
 
Startup Task Pane - Select to show the Startup Task Pane. 
 
Formula bar - Select to show the Formula bar. 
 
Status bar - Select to show the Status bar. 
 
Windows in Taskbar - Select to list each open Workbook on the Taskbar. 
 

 Click OK to change and save the settings. 
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Customizing the Comments View options 
 From the main menu, choose Tools > Options to display the Options dialog 

box, click on the View tab, and select the following options from the 
Comments area: 
 

 
 
None - Select to hide all comments. 
 
Comment indicator only - Select to indicate comments with red triangles. 
 
Comment & indicator - Select to show the comments and its indicator. 
 

 Click OK to change and save the settings. 
 

Customizing the Objects View options 
 From the main menu, choose Tools > Options to display the Options dialog 

box, click on the View tab, and select from the following options from the 
Objects area: 
 

 
 
Show all - Select to show all objects. 
 
Show placeholder - Select to show a grey box in place of an object. 
 
Hide all - Select to hide all objects. 
 

 Click OK to change and save the settings. 
 
 

Customizing the Worksheet View options 
 From the main menu, choose Tools > Options to display the Options dialog 

box, click on the View tab, and select from the following options from the 
Window options area: 
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Page breaks - Select to display page breaks. 
 
Formulas - Select to display formulas instead of results in Worksheet cells. 
 
Gridlines - Select to display gridlines. 
 
Gridline color - Change the gridline color by clicking on the down arrow and 
selecting a new color. 
 
Row & column headers - Select to show the row and column headers. 
 
Outline symbols - Select to show any outline symbols. 
 
Zero values - Select to show cells containing 0. 
 
Horizontal scroll bar - Select to show the horizontal scroll bars. 
 
Vertical scroll bar - Select to show the vertical scroll bars. 
 
Sheet tabs - Select to show the sheet tabs. 
 

 Click OK to change and save the settings. 
 
 

Displaying and Customizing Toolbars 
 

Choosing a Toolbar 
 Excel has 19 Toolbars for you to choose from.  Each Toolbar contains a 

group of icons that are relevant to specific functions in Excel.  You can use 
the following list to help you choose the toolbar to display: 
 
Standard - Icons for basic Excel 2002 functions. 
Formatting - Icons for cell formatting. 
Border - Icons for drawing and customizing border lines. 
Chart - Icons to create and format Charts. 
Control Toolbox - Icons to customize and control form elements. 
Drawing - Icons to draw shapes. 
External Data - Icons for querying external data. 
Forms - Icons to create form elements. 
Formula Auditing - Icons to troubleshoot formulas. 
Picture - Icons to create and manipulate pictures. 
PivotTable - Icons for working with Pivot Tables. 
Protection - Icons to lock and protect Worksheets. 
Reviewing - Icons to create and manipulate comments. 
Task Pane - Links to the some of the most common tasks in Excel. 
Text to Speech - Icons to control how Excel read cell contents. 
Visual Basic - Icons for working with Visual Basic. 
Watch Window - Window to track the formula results of different cells. 
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Web - Icons to create, manipulate, and interact with the Web. 
WordArt - Icons for creating and manipulating WordArt objects. 

 

Displaying Toolbars 
 From the main menu, choose View > Toolbars and select the Toolbar you 

want to display (you will see a check mark beside visible Toolbars). 
 
OR right-click on any visible toolbar and choose the toolbar you want to 
display from the popup menu (you will see a check mark beside visible 
Toolbars). 

 

Customizing Toolbar Options 
 Right-click on any visible toolbar and choose Customize from the popup 

menu, click on the Options tab, and select from the following options: 
 
Show Standard and Formatting toolbars on two rows 
By default, Excel displays the Standard and Formatting toolbars on one row 
to increase the Worksheet window display.  Select this option to display the 
toolbars on the two different rows. 
 
Always show full menus 
By default, Excel shows a condensed version of the main menus, containing 
the most recently used commands menu items.  Select this option to show 
full menus. 
 
Show full menus after a short delay 
By default, Excel displays the full menus after it has been open for a few 
seconds.  Deselect this option to prevent the full menus from appearing. 
 
Reset my usage data 
Click on this button to restore the dropdown menus to their default settings. 
 
Large icons 
Select this option to display large icons on all toolbars. 
 
List font names in their font 
Select this option to display the actual font in the Formatting toolbar Font 
dropdown menu. 
 
Show ScreenTips on toolbars 
Select this option to display the descriptive name of the icon when the mouse 
pointer is placed over it. 
 
Menu animations 
Select how menus appear on screen; choose from None, Random, Unfold, or 
Slide. 
 

 Click Close to save the settings. 
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Adding Commands to a Toolbar 
 Begin by displaying the toolbar you want to customize. 
 From the main menu, choose Tools > Customize, click on the Commands 

tab, and select a Category from the Categories scrolling box. 
 From the Commands scrolling box, find the command you want to add, and 

drag the command onto the toolbar you want to affect: 
 

 
 
 

Hiding Workbooks and Worksheets  
 

Hiding a Workbook 
 Begin by displaying the Workbook you want to hide. 
 From the main menu, choose Window > Hide. 

 
Note: If there are unsaved changes in your hidden Workbook, Excel will 
prompt you to save the Workbook when you exit. 

 

Hiding Worksheets 
 Begin by selecting the Worksheet(s) you want to hide. 
 From the main menu, choose Format > Sheet > Hide. 
 

Displaying hidden Workbooks 
 From the main menu, choose Window > Unhide to display the Unhide 

dialog box, select the hidden Workbook you want to display, and click OK: SAMPLE
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Displaying hidden Worksheets 
 From the main menu, choose Format > Sheet > Unhide to display the 

Unhide dialog box, select the hidden Worksheet you want to display, and 
click OK: 
 

 
 
 

Freezing Panes 
 

Freezing a horizontal pane 
 Begin by placing the mouse pointer over the rectangle above the right 

scrollbar (your mouse cursor should change to the drag cursor ). 
 Drag the rectangle down to below the row you want to freeze.  From the 

main menu, choose Window > Freeze Panes: 

 
 
Note: The frozen pane is marked by a horizontal black line. 
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Freezing a vertical pane 
 Begin by placing the mouse pointer over the rectangle to the right of the 

bottom scrollbar (your mouse cursor should change to the drag cursor ). 
 Drag the rectangle left to the right of the column you want to freeze.  From 

the main menu, choose Window > Freeze Panes: 
 

 
 
Note: The frozen pane is marked by a vertical black line. 

 
 

Freezing horizontal and vertical panes 
 Begin by selecting the top-left cell that will not be part of the frozen panes. 
 From the main menu, choose Window > Freeze Panes. 

 
For example, to freeze the top two rows and the left column, select cell B3: 
 

 
 

Unfreezing panes 
 From the main menu, choose Window > Unfreeze Panes. 

 
Note: This menu selection is available only if there are panes to unfreeze. 

 
 

Grouping and Ungrouping Worksheets 
 

Grouping Worksheets 
 You can group Worksheets together to edit and format the sheets at the 

same time.  Every change made to the active Worksheet will be reflected in 
all Worksheets in the Group.  Worksheets can be grouped simply by selecting 
the Worksheets you want. 
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To select all Worksheets 
 Right-click on a sheet tab, and choose Select All Sheets from the popup 

menu: 
 

 
 

To select several Worksheets 
 Click on the first sheet tab of the Worksheet you want to select, hold down 

the Ctrl key, and click on the other sheet tabs of the Worksheets you want to 
select: 
 

 
 
 

Ungrouping Worksheets 
 Right-click on one of the grouped Worksheet tabs, and choose Ungroup 

Sheets from the popup menu 
 
OR hold down the Shift key and click on the active sheet tab. 

 
 

Review Questions 
 
How would you: 

 Customize the Excel window display? 
 Customize the Comments View options? 
 Customize the Objects View options? 
 Customize the Worksheet View options? 
 Choose a Toolbar? 
 Display Toolbars? 
 Customize Toolbar Options? 
 Add Commands to a Toolbar? 
 Hide a Workbook? 
 Hide Worksheets? 
 Display hidden Workbooks? 
 Display hidden Worksheets? 
 Freeze a horizontal pane? 
 Freeze a vertical pane? 
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 Freeze horizontal and vertical panes? 
 Unfreeze panes? 
 Group Worksheets? 
 Ungroup Worksheets? 
 
 

SAMPLE



Page 17 – Microsoft Excel Xp - Intermediate Level Manual 

FOR USE AT THE LICENSED SITE(S) ONLY 
 Cheltenham Courseware Ltd. 1995-2010 www.cheltenhamcourseware.com 

More Formatting Techniques 
 
When you have completed this learning module you will have seen how to: 

 Create a new style 
 Apply a style 
 Change the formatting of a style 
 Remove a style form cells 
 Delete a style 
 Use conditional formatting 
 Change conditional formatting 
 Delete conditional formatting 
 Find cells with conditional formatting 
 Copy and apply cell formatting with the Format Painter 
 Copy and apply column width or row height with the Format Painter 
 Copy and apply cell formatting with the Format Painter 
 Copy and apply the Format Painter in multiple locations 
 Change the color of the Gridlines 
 Turn off the onscreen Gridlines 
 Print Gridlines 
 Hide Columns 
 Hide Rows 
 Use the mouse to hide Columns 
 Use the mouse to hide Rows 
 Display hidden Columns 
 Display hidden Rows 
 Use the mouse to display hidden Columns 
 Use the mouse to display hidden Rows 
 
 

Using Styles 
 

Creating a new style  
 You can create a new style based on the formatting of an existing cell.  Once 

a style is created, you can use it repeatedly. 
 Begin by selecting the cell containing the formatting you want. 
 From the main menu, choose Format > Style to display the Style dialog 

box. 
 Type a name into the Style name dropdown list box, and click on the Add 

button. 
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 Click OK: 
 

 
 

Applying a style  
 Begin by selecting the cell(s) you want to affect. 
 From the main menu, choose Format > Style to display the Style dialog 

box. 
 Click on the Style name down arrow, and select the style you want. 
 Click OK: 

 

 
 

Changing the formatting of a style 
 From the main menu, choose Format > Style to display the Style dialog 

box. 
 Click on the Style name down arrow, select the style you want to change, 

and click on the Modify button to display the Format Cells dialog box. 
 Specify the formatting you want, and click OK to return to the Style dialog 

box. 
 Click OK. 

 
Note: You can also create a new style by typing a name for your style and 
clicking on the Modify button to specify the formatting of the new style. 

 

Removing a style from cells 
 Begin by selecting the cell(s) you want to affect. 
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 From the main menu, choose Format > Style to display the Style dialog 
box. 

 Click on the Style name down arrow, and select the Normal style. 
 Click OK. 
 

Deleting a style 
 From the main menu, choose Format > Style to display the Style dialog 

box. 
 Click on the Style name down arrow, select the style you want to delete, 

and click on the Delete button. 
 Click OK. 

 
Note: Excel has pre-defined styles associated to the Currency Style, 
Percent Style, and Comma Style icons on the Formatting toolbar.  Deleting 
these styles will disable the icons. 

 
 

Conditional Formatting 
 

Using conditional formatting 
 Conditional formatting allows you to change the formatting of a cell 

depending on the value in the cell.  You can set up conditional formatting to 
highlight data based on conditions you define. 

 Begin by selecting the cell or range you want to affect. 
 From the main menu, choose Format > Conditional Formatting to display 

the Conditional Formatting dialog box. 
 Enter the condition in the Condition area (conditions can be defined based 

on the cell value or formula). 
 Click on the Format button to display the Format Cells dialog box.  Specify 

the formatting you want, and click OK to return to the Conditional 
Formatting dialog box.  (A sample of the formatting appears in the preview 
box.) 

 Click OK to apply conditional formatting: 
 

 
 
Note: To define another condition, click Add instead of OK.  You can have up 
to three conditions; when finished, click OK.  Excel will evaluate the 
conditions in the order they are entered, and will stop evaluating once a 
condition is met and the associated format is applied. 
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Changing conditional formatting  
 Begin by selecting the cell or range containing the conditional formatting you 

want to change. 
 From the main menu, choose Format > Conditional Formatting to display 

the Conditional Formatting dialog box. 
 Edit the condition(s) and formatting as needed. 
 Click OK. 
 

Deleting conditional formatting  
 Begin by selecting the cell or range containing the conditional formatting you 

want to delete. 
 From the main menu, choose Format > Conditional Formatting to display 

the Conditional Formatting dialog box. 
 Click the Delete button to display the Delete Conditional Format dialog 

box, select the condition(s) you want to delete, and click OK to return to the 
Conditional Formatting dialog box. 

 Click OK: 
 

 
 
 

Finding cells with conditional formatting 
 To find cells with specific conditional formatting, begin by selecting the cell 

with the conditional formatting you want to find. 
 From the main menu, choose Edit > Go To to display the Go To dialog box. 
 Click on the Special button to display the Go To Special dialog box. 
 Select the Conditional formats radio button, and select the Same radio 

button below Data validation. 
 Click OK to highlight the cells with the specified conditional formatting: 
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Note: To find cells with any conditional formatting, you can begin by 
selecting any cell, and follow the same instructions as above, but select the 
All instead of the Same radio button. 

 
 

Using the Format Painter 
 

Copying and applying cell formatting with the Format Painter 
 You can use the Format Painter to copy the formatting (including 

conditional formatting) of an existing cell to other cells within Excel. 
 Begin by selecting the cell or range containing the formatting you want to 

copy. 
 Click on the Format Painter icon on the Formatting toolbar (your mouse 

cursor change to the painter cursor ). 
 Click on the cell you want the formatting to be applied 

 
OR select the range you want the formatting to be applied. 
 
Note: If you are copying the formatting of a range, after copying with the 
Format Painter, click on the top-left cell to apply the formatting to a range of 
the same size. 

 
 

Copying and applying column width or row height with the Format 
Painter 
 Begin by selecting the column (row) containing the width (height) you want 

to copy. 
 Click on the Format Painter icon on the Formatting toolbar (your mouse 

cursor change to the painter cursor ). 
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 Click on the column (row) header you want the formatting to be applied 
 
OR select the range of columns (rows) you want the formatting to be 
applied: 
 

 
 

Copying and applying cell formatting with the Format Painter 
 Begin by selecting the object containing the formatting you want to copy. 
 Click on the Format Painter icon on the Formatting toolbar (your mouse 

cursor change to the painter cursor ). 
 Click on the object you want the formatting to be applied. 
 

Copying and applying the Format Painter in multiple locations 
 Begin by selecting the cell or range containing the formatting you want to 

copy. 
 Double-click on the Format Painter icon on the Formatting toolbar (your 

mouse cursor changes to the painter cursor ). 
 Click on the cell or select the range you want the formatting to be applied 

(your mouse cursor stays as the painter cursor).  Continue applying the 
copied formatting. 

 When finished, click on the Format Painter icon to end the painter 
formatting. 
 
Note: You can also use this method on column widths, row heights,objects, 
and conditional formatting. 

 
 

Using Guidelines 
 

Changing the color of the Gridlines 
 Begin by selecting the Worksheets you want to affect. 
 From the main menu, choose Tools > Options to display the Options dialog 

box, and click on the View tab. 
 Click on the Gridlines color down arrow in the Window options area. 
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 Click OK: 
 

 
 

Turning off the onscreen Gridlines  
 From the main menu, choose Tools > Options to display the Options dialog 

box, and click on the View tab. 
 Deselect the Gridlines checkbox in the Window options area. 
 Click OK. 
 

Printing Gridlines  
 From the main menu, choose File > Page Setup to display the Page Setup 

dialog box, and click on the Sheet tab. 
 Select the Gridlines checkbox in the Print area. 
 Click OK to exit Page Setup 

 
OR click Print to print: 
 

 
 
 

Hiding and Displaying Cells 
 

Hiding Columns 
 Begin by selecting the column(s) you want to hide. 
 From the main menu, choose Format > Column > Hide. 

 
Note: You can identify hidden column(s) by the missing header letters. 
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Hiding Rows 
 Begin by selecting the row(s) you want to hide. 
 From the main menu, choose Format > Row > Hide. 

 
Note: You can identify hidden row(s) by the missing header number. 

 

Using the mouse to hide Columns  
 Begin by placing the mouse pointer on the right most header border of the 

column(s) you want to hide. 
 Drag the border past the left most header border of the column(s) you want 

to hide. 
 
For example, if you want to hide column B and C, place your mouse pointer 
over the right header border of column C, and drag the border past the left 
header border of column B: 
 

 
 

Using the mouse to hide Rows 
 Begin by placing the mouse pointer on the bottom most header border of the 

row(s) you want to hide. 
 Drag the border past the top most header border of the row(s) you want to 

hide. 
 
For example, if you want to hide row 2 to 4, place your mouse pointer over 
the bottom header border of row 4, and drag the border past the top header 
border of row 2: 
 

 
 

Displaying hidden Columns 
 Begin by selecting the columns on either side of the hidden column(s). 
 From the main menu, choose Format > Column > Unhide. 

 
Note: If column A is hidden, you will need to navigate to cell A1 instead of 
selecting the columns on either side of column A. 
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To navigate to cell A1: 

 From the main menu, choose Edit > Go To, type A1 in the Reference text 
box, and click OK: 
 

 
 

Displaying hidden Rows 
 Begin by selecting the rows on either side of the hidden row(s). 
 From the main menu, choose Format > Row > Unhide. 

 
Note: If row 1 is hidden, you will need to navigate to cell A1 instead of 
selecting the rows on either side of row 1. 

 
To navigate to cell A1: 

 From the main menu, choose Edit > Go To, type A1 in the Reference text 
box, and click OK. 

 

Using the mouse to display hidden Columns 
 Begin by placing the mouse pointer between the two column headers where 

column(s) are hidden. 
 Move the mouse pointer slightly to the right until it changes from a single-

lined drag cursor to a double-lined drag cursor . 
 Drag the column border to the right to display the hidden column: 

 

 
 
Note: You can only display one hidden column at a time. 

 

Using the mouse to display hidden Rows 
 Begin by placing the mouse pointer between the two row headers where 

row(s) are hidden. 
 Move the mouse pointer down slightly until it changes from a single-lined 

drag cursor to a double-lined drag cursor . 
 Drag the row border to down to display the hidden row: 
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Note: You can only display one hidden row at a time. 

 
 

Review Questions 
 
How would you: 

 Create a new style? 
 Apply a style? 
 Change the formatting of a style? 
 Remove a style form cells? 
 Delete a style? 
 Use conditional formatting? 
 Change conditional formatting? 
 Delete conditional formatting? 
 Find cells with conditional formatting? 
 Copy and apply cell formatting with the Format Painter? 
 Copy and apply column width or row height with the Format Painter? 
 Copy and apply cell formatting with the Format Painter? 
 Copy and apply the Format Painter in multiple locations? 
 Change the color of the Gridlines? 
 Turn off the onscreen Gridlines? 
 Print Gridlines? 
 Hide Columns? 
 Hide Rows? 
 Use the mouse to hide Columns? 
 Use the mouse to hide Rows? 
 Display hidden Columns? 
 Display hidden Rows? 
 Use the mouse to display hidden Columns? 
 Use the mouse to display hidden Rows? 
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More Formulas and Functions 
 
When you have completed this learning module you will have seen how to: 

 Use the Series Command 
 Apply a list series 
 Apply a numeric series 
 Apply a basic numeric series 
 Create a custom list series 
 Display the Insert Function wizard 
 Choose a function from the Insert Function wizard 
 Enter Function Arguments in the Insert Function wizard 
 Use the Most Recently Used function category 
 Use the Financial function category 
 Use the Date & Time function category 
 Use the Math & Trig function category 
 Use the Statistical function category 
 Use the Lookup & Reference function category 
 Use the Database function category 
 Use the Text function category 
 Use the Logical function category 
 Use the Information function category 
 Find and correct errors in Formulas 
 Find error values 
 Correct error values 
 Use the Formula error checker 
 Recheck ignored errors 
 Customize the Formula error checker 
 Display the Formula Auditing toolbar 
 Use the Formula Auditing toolbar 
 Trace Precedents 
 Remove Precedent Arrows 
 Trace Dependents 
 Remove Dependent Arrows 
 Add a new comment 
 Evaluate Formulas one step at a time 
 Use the Watch Window 
 Add a Watch to a cell 
 Add a Watch to all cells with Formulas 
 Display a cell in the Watch Window 
 Delete a Watch 
 Hide the Watch Window 
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Using the Series Command 
 

Using the Series Command 
 Excel 2002 recognizes three different types of series: 

 
Linear: series increases or decreases by a constant value. 
 
Growth: series increases or decrease by a constant multiple. 
 
AutoFill: Excel 2002 can extend various types of data by predicting the next 
items in the series.  For example, Q1, Q2, Q3, and Q4. 

 

Applying a list series 
 Type the first item of the list series into the cell you want. 
 Place the mouse over the small square at the bottom-right corner of the 

selected cell (your mouse pointer will appear as a bold plus (+) sign). 
 Drag in any direction and release the mouse button when you have reached 

the last cell in your list series: 
 

 
 
Note: As you drag the mouse, a screen tip displays the last item in your 
series.  When you release the mouse button, the selected cells will be filled 
with the list series: 
 

 
 

Applying a numeric series 
 Excel can create a linear or growth numeric series based on two starting 

numbers. 
 Type the first number of the series into the cell you want, and type the 

second number of the series into the cell adjacent to the first number. 
 Select both cells. 
 Place the mouse over the small square at the bottom-right corner of the 

selected cells (your mouse pointer will appear as a bold plus (+) sign). 
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 Drag in any direction and release the mouse button when you have reached 
the last cell in your numeric series.  When you release the mouse button, the 
selected cells will be filled with the numeric series: 
 

 
 
Note: As you drag the mouse, a screen tip displays the last item in your 
series.  To increment a series, drag the mouse down or to the right.  To 
decrement a series, drag the mouse up or to the left.   

 

Applying a basic numeric series 
 Excel can create a basic numeric series by incrementing or decrementing the 

starting number by one. 
 Type the starting number of the basic numeric series into the cell you want. 
 Place the mouse over the small square at the bottom-right corner of the 

selected cell (your mouse pointer will appear as a bold plus (+) sign). 
 Hold down the Ctrl key, drag in any direction, and release the mouse button 

when you have reached the last cell in your basic numeric series.  When you 
release the mouse button, the selected cells will be filled with the numeric 
series: 
 

 
 
Note: To increment a series, drag the mouse down or to the right.  To 
decrement a series, drag the mouse up or to the left. 

 
 

Creating a custom list series  
 With Excel, you can create a custom list series for future use. 
 From the main menu, choose Tools > Options to display the Options dialog 

box, and click on the Custom Lists tab. 
 Select NEW LIST from the Custom lists text area, enter the list entries into 

the List entries text area, and click Add to add the series 
OR enter a range in the Import list from cells text box, and click Import 
to import an existing series. 
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 Click OK: 
 

 
 
 

Using the Insert Function Wizard 
 

Displaying the Insert Function wizard 
 A function can be inserted into a formula using the Insert Function wizard. 
 To access the Insert Function wizard, begin by selecting the cell you want. 
 From the main menu, choose Insert > Function to display the Insert 

Function wizard 
 

OR click on the Insert Function icon  on the Formula bar 
 
OR click on the AutoSum down arrow on the Standard toolbar, and choose 
More Functions: 
 

 
 
OR type the equal (=) sign into the cell, click on the Functions down arrow, 
and choose More Functions: 
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Choosing a function from the Insert Function wizard 
 From the Insert Function wizard, locate the function you want, and click OK 

to display the Function Arguments dialog box. 
 
Note: You can use the following features of the Insert Function wizard to 
help you find the function you want. 

 

 Type in a brief description of the function in the Search for a function text 
box, and click on the Go button: 
 

 
 

 Click on the Select a category down arrow and choose a category to display 
the functions in a category or choose All to display all functions: 
 

 
 

 Click on a function in the Select a function text area to display a brief 
description of the function and its arguments.  Click on Help on this 
function to see the detailed description of the function and its arguments: 
 

 
 

Entering Function Arguments in the Insert Function wizard  
 After selecting a function to insert, the Insert Function wizard will prompt 

you for arguments with the Function Arguments dialog box.  Each 
argument in the function will be listed with its own text box.  Arguments that 
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are in bold typeface are required for the function; arguments in normal 
typeface are optional. 

 Click in an argument text box to display a brief description of the argument. 
 Enter a value, cell reference, or range reference into the argument text box. 
 Check the Formula result area to see the results, and adjust the arguments 

as needed. 
 Click OK to insert the function into the selected cell: 

 

 
 
Note: You can click on the Minimize Dialog icon  to the right of the 
argument text boxes to minimize the Function Arguments dialog box, and 
select the cell or range you want to use from the Workbook window.  Press 
the Enter key to return to the Function Arguments dialog box. 

 
 

Using the Excel Function Categories 
 

Using the Most Recently Used function category 
 Excel organizes its database of Functions into categories, and keeps track of 

your most recently used functions so that you can access them quickly.  You 
can display the functions in this category by using the following methods. 

 Type the equal (=) sign into the cell, click on the Functions down arrow, and 
choose the most recently used function you want: 
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OR you can access this category from the Insert Function wizard. 
 
Note: The Insert Function wizard defaults to display the Most Recently 
Used function. 

 
 

Using the Financial function category 
 The Financial function category has the most common financial calculations 

including the following: 
 
db Calculates the fixed-declining depreciation of an asset. 
 
ddb Calculates the double-declining depreciation of an asset. 
 
fv Calculates the future value of an investment. 
 
ipmt Calculates the interest payment of an investment. 
 
irr Calculates the internal rate of return for a series of cash flows. 
 
ispmt Calculates the interest paid of an investment. 
 
mirr Calculates the internal rate of return for a series of cash flows, including 
cost of investment and interest on reinvestment. 
 
nper Calculates the number of period for an investment. 
 
Npv Calculates the new present value of an investment. 
 
pmt Calculates the payment for a loan. 
 
ppmt Calculates the payment on the principal for an investment. 
 
pv Calculates the present value of an investment. 
 
rate Calculates the interest rate per period of a loan or an investment. 
 
sln Calculates the straight-line depreciation of an asset. 
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syd Calculates the sum-of-year’ digits depreciation of an asset. 
 
vdb Calculates the depreciation of an asset for any period you specify using 
the double-declining balance method or some other method. 

 
 

Using the Date & Time function category 
 The Date & Time category has functions for working with date and time.  

Excel uses serial numbers to store dates, giving each day of each year a 
unique number.  The serial numbers then can be manipulated 
mathematically.   

 For example, to find out a date that is 45 days from December 12, 2001, you 
would use the DATE function to convert the date into a serial number then 
add 45.  In this example, the formula would be: =DATE(2001,12,3)-45 

 

 The following lists the Date & Time functions in Excel: 
 
DATE Returns the serial number of a particular date. 
 
DATEVALUE Converts a date in the form of text to a serial number. 
 
DAY Converts a serial number to a day of the month. 
 
DAYS360 Calculates the number of days between two dates based on a 360-
day year. 
 
HOUR Converts a serial number to an hour. 
 
MINUTE Converts a serial number to a minute. 
 
MONTH Converts a serial number to a month. 
 
NOW Returns the serial number of the current date and time. 
 
SECOND Converts a serial number to a second. 
 
TIME Returns the serial number of a particular time. 
 
TIMEVALUE Converts a time in the form of text to a serial number. 
 
TODAY Returns the serial number of the current date. 
 
WEEKDAY Converts a serial number to a day of the week. 
 
YEAR Converts a serial number to a year. 
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Using the Math & Trig function category 
 The Math & Trig function category has the most common mathematical and 

trigonometry calculations including the following: 
 
ABS 
Returns the absolute value of a number. 
 
ACOS 
Returns the arccosine of a number in radians. 
 
ACOSH 
Returns the inverse hyperbolic cosine of a number. 
 
ASIN 
Returns the arcsine of a number in radians. 
 
ASINH 
Returns the inverse hyperbolic sine of a number. 
 
ATAN 
Returns the arctangent of a number in radians. 
 
ATAN2 
Returns the arctangent of the specified x- and x- coordinates in radians. 
 
ATANH 
Returns the inverse hyperbolic tangent of a number. 
 
CEILING 
Rounds a number up, to the nearest integer or to the nearest multiple of 
significance. 
 
COMBIN 
Returns the number of combinations for a given number of items. 
 
COS 
Returns the cosine of an angle. 
 
COSH 
Returns the hyperbolic cosine of a number. 
 
DEGREES 
Converts radians to degrees. 
 
EVEN 
Rounds a number to the nearest even integer. 
 
EXP 
Returns e raised to the power of a given number. 
 
FACT 
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Returns the factorial of a number. 
 
FLOOR 
Rounds a number down, toward zero, to the nearest multiple of significance. 
 
INT 
Rounds a number down to the nearest integer. 
 
LN 
Returns the natural logarithm of a number. 
 
LOG 
Returns the logarithm of a number to the base you specify. 
 
LOG10 
Returns the base-10 logarithm of a number. 
 
MDETERM 
Returns the matrix determinant of an array. 
 
MINVERSE 
Returns the inverse matrix for the matrix stored in an array. 
 
MMULT 
Returns the matrix product of two arrays. 
 
MOD 
Returns the remainder of a division. 
 
ODD 
Rounds a number to the nearest odd integer. 
 
PI 
Returns the value of Pi. 
 
POWER 
Returns the result of a number raised to a power. 
 
PRODUCT 
Multiples all the arguments. 
 
RADIANS 
Converts degrees to radians. 
 
RAND 
Returns a random number between 0 and 1. 
 
ROMAN 
Converts an Arabic numeral to Roman. 
 
ROUND 
Rounds a number to a specified number of digits. 
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ROUNDDOWN 
Rounds a number down, toward zero. 
 
ROUNDUP 
Rounds a number up. 
 
SIGN 
Returns the sign of a number. 
 
SIN 
Returns the sine of an angel. 
 
SINH 
Returns the hyperbolic sine of a number. 
 
SQRT 
Returns the square root of a number. 
 
SUBTOTAL 
Returns a subtotal in a list or database. 
 
SUM 
Adds all the numbers in a range of cells. 
 
SUMIF 
Adds the cells specified by a given condition or criteria. 
 
SUMPRODUCT 
Returns the sum of the products of corresponding ranges or arrays. 
 
SUMSQ 
Returns the sum of squares of the arguments. 
 
SUMX2MY2 
Sums the difference between the squares of two corresponding ranges or 
arrays. 
 
SUMX2PY2 
Returns the sum total of the sums of squares of numbers in two 
corresponding ranges or arrays. 
 
SUMXMY2 
Sums the squares of the differences in two corresponding ranges or arrays. 
 
TAN 
Returns the tangent of an angle. 
 
TANH 
Returns the hyperbolic tangent of a number. 
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TRUNC 
Truncates a number to an integer. 

 
 

Using the Statistical function category 
 The Statistical function category has a wide range of statistical calculations.   
 

 The following provides a sample of the calculations available: 
 
AVERAGE 
Calculates the average of the arguments. 
 
BETADIST 
Calculates the cumulative beta probability density function. 
 
BINOMDIST 
Calculates the individual term binomial distribution probability. 
 
CHIDIST 
Calculates the one-tailed probability of the chi-squared distribution. 
 
CHITEST 
Returns the test for independence. 
 
CONFIDENCE 
Returns the confidence interval for a population mean. 
 
COUNT 
Counts the number of cells containing data. 
 
COUNTA 
Counts the number of cells that are not empty. 
 
COUNTBLANK 
Counts the number of empty cells in a range. 
 
COUNTIF 
Counts the number of cells that meet the given condition. 
 
COVAR 
Returns the covariance of two data sets. 
 
DEVSQ 
Returns the sum of squares of deviations of data points from the mean. 
 
EXPONDIST 
Returns the exponential distribution. 
 
FDIST 
Returns the F probability distribution for two data sets. 
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FORECAST 
Predicts a future value using existing values. 
 
FREQUENCY 
Calculates how often values occur. 
 
FTEST 
Returns the result of an F-test. 
 
GEOMEAN 
Returns the geometric mean of an array. 
 
GROWTH 
Returns numbers in an exponential growth trend matching know data points. 
 
INTERCEPT 
Calculates the point at which a line will intersect the y-axis using best-fit 
regression. 
 
LARGE 
Returns the n-th largest value, where n is the level. 
 
MAX 
Returns the largest value in a range. 
 
MEDIAN 
Returns the median. 
 
MIN 
Returns the smallest value in a range. 
 
MODE 
Returns the most frequently occurring value in a range. 
 
NORMDIST 
Returns the normal cumulative distribution for a specified mean and standard 
deviation. 
 
PERCENTILE 
Returns the n-th percentile of values in a range. 
 
PERMUT 
Returns the number of permutations for a given number of objects that can 
be selected from the total number of objects. 
 
POISSON 
Returns the Poisson distribution. 
 
PROB 
Returns the probability that values in a range are between two limits or equal 
to a lower limit. 
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QUARTILE 
Returns the quartile of a data set. 
 
SKEW 
Returns the skewness of a distribution. 
 
SLOPE 
Returns the slope of a linear regression line. 
 
SMALL 
Returns the n-th smallest value, where n is the level. 
 
STANDARDIZE 
Returns a normalized value from a distribution. 
 
STDEV 
Estimates standard deviation based on a sample. 
 
STEYX 
Returns the standard error of the predicted y-value for each x in a 
regression. 
 
TDIST 
Returns the Student’s t-distribution. 
 
TREND 
Returns numbers in a linear trend using the least squares method. 
 
TTEST 
Returns the probability associated with a Student’s t-Test. 
 
VAR 
Estimates variance based on a sample. 
 
ZTEST 
Returns the two-tailed P-value of a z-test. 

 
 

Using the Lookup & Reference function category 
 The Lookup & Reference category has the functions to access information.  

For example, the HLOOKUP and VLOOKUP functions can be used to look up 
values in a table, or use the CHOOSE function to select a value from a list 
based on an index number. 

 

 The following is a list of the Lookup & Reference functions: 
 
ADDRESS 
Creates a cell reference as text. 
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AREAS 
Returns the number of areas in a reference. 
 
CHOOSE 
Chooses a value or action to perform from a list of values. 
 
COLUMN 
Returns the column number of a reference. 
 
COLUMNS 
Returns the number columns in an array or reference. 
 
GETPIVOTDATA 
Extracts data stored in a Pivot Table. 
 
HLOOKUP 
Returns the value of the specified row in a particular column heading. 
 
HYPERLINK 
Creates a link that opens a document locally or from the Internet. 
 
INDEX 
Returns the value of a particular row and column. 
 
INDIRECT 
Returns the reference specified by a text string. 
 
LOOKUP 
Looks up a value from a one-row or one-column range or from an array. 
 
MATCH 
Returns the relative position of an array item that matches a specified value 
and order. 
 
OFFSET 
Returns a reference that is off a given number of rows and columns from the 
starting reference. 
 
ROW 
Returns the row number of a reference. 
 
ROWS 
Returns the number of rows in an array or reference. 
 
RTD 
Retrieves real-time data from an application with COM automation support. 
 
TRANSPOSE 
Converts a vertical range to a horizontal range, or vice versa. 
 
VLOOKUP 
Returns the value of the specified column in a particular row heading. 
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Using the Database function category 
 The Database category has database manipulation functions, including the 

following: 
 
DAVERAGE 
Averages the record values that match specific conditions. 
 
DCOUNT 
Counts the cells containing numbers in the record values that match specific 
conditions. 
 
DCOUNTA 
Counts non-empty cells in the record values that match specific conditions. 
 
DGET 
Extracts a record that matches specific conditions. 
 
DMAX 
Returns the largest number in the record values that matches specific 
conditions. 
 
DMIN 
Returns the smallest number in the record values that matches specific 
conditions. 
 
DPRODUCT 
Multiples the record values that matches specific conditions. 
 
DSTDEV 
Estimates the standard deviation based on a sample of records. 
 
DSTDEVP 
Calculates the standard deviation based on all the records. 
 
DSUM 
Adds the numbers in the record values that match specific conditions. 
 
DVAR 
Estimates variance based on a sample of records. 
 
DVARP 
Estimates variance based on all the records. 

 

Using the Text function category 
 The Text category has the text manipulation functions, including the 

following: 
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BAHTTEXT 
Converts a number to text. 
 
CHAR 
Returns the character specified by the code number. 
 
CLEAN 
Removes all nonprintable characters form text. 
 
CODE 
Returns a numeric code for the first character in a text string. 
 
CONCATENATE 
Joins several text items into one text item. 
 
DOLLAR 
Converts a number to text, using currency format. 
 
EXACT 
Checks to see if two text values are identical. 
 
FIND 
Finds one text value within another (case-sensitive). 
 
FIXED 
Formats a number as text with a fixed number of decimals. 
 
LEFT 
Returns the left-most characters from a text string. 
 
LEN 
Returns the number of characters in a text string. 
 
LOWER 
Converts text to lowercase. 
 
MID 
Returns a specific number of characters from a text string starting at the 
position you specify. 
 
PROPER 
Capitalizes the first letter in each word of a text string. 
 
REPLACE 
Replaces characters within a text string. 
 
REPT 
Repeats text a given number of times. 
 
RIGHT 
Returns the right-most characters from a text string. 
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SEARCH 
Finds one text string within another (not case-sensitive). 
 
SUBSTITUTE 
Replaces new text for old text in a text string. 
 
T 
Converts its arguments to text. 
 
TEXT 
Formats a number and converts it to text. 
 
TRIM 
Removes spaces from text. 
 
UPPER 
Converts text to uppercase. 
 
VALUE 
Converts a text string to a number. 

 
 

Using the Logical function category 
 When carrying out calculation, you may need to make decisions based on the 

results.  The Logical category has a number of functions that allow you to 
evaluate logical tests and make decisions based on the result of the 
evaluation.  Logical operators, equal to (=), greater than (>), less than 
(<), greater than or equal to (>=), and less than or equal to (<=), are used 
to evaluate logical tests. 

 

 The following is a list of the Logical functions: 
 
AND 
Returns TRUE if all arguments are TRUE. 
 
FALSE 
Returns the logical value FALSE. 
 
IF 
Checks condition and returns the specified value for TRUE or FALSE. 
 
NOT 
Changes FALSE to TRUE, and vise versa. 
 
OR 
Returns TRUE if any one of the arguments are TRUE. 
 
TRUE 
Returns the logical value TRUE. 
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Using the Information function category 
 The Information function category has the functions to validate data and to 

provide information on values.  These functions are especially useful when 
designing templates or forms for other users. 

 

 The following is a list of the Information functions: 
 
CELL  
Returns information about the formatting, location, or contents of the upper-
left cell in a reference. 
 
ERROR,TYPE  
Returns a number matching an error value. 
 
INFO 
Returns information about the current operating environment. 
 
ISBLANK 
Returns TRUE if the value is blank. 
 
ISERR 
Returns TRUE if the value is an error value (except #N/A). 
 
ISERROR 
Returns TRUE if the value is any error value. 
 
ISLOGICAL 
Returns TRUE if the value is a logical.   
 
ISNA 
Returns TRUE if the value is a #N/A value. 
 
ISNONTEXT 
Returns TRUE if the value is not text. 
 
ISNUMBER 
Returns TRUE if the value is a number. 
 
ISREF 
Returns TRUE if the value is a reference. 
 
ISTEXT 
Returns TRUE if the value is text. 
 
N 
Converts non-numeric values to a number. 
 
NA 
Returns the error value #N/A. 
 

SAMPLE



Page 46 – Microsoft Excel Xp - Intermediate Level Manual 

FOR USE AT THE LICENSED SITE(S) ONLY 
 Cheltenham Courseware Ltd. 1995-2010 www.cheltenhamcourseware.com 

TYPE 
Returns information on the data type of a value. 

 

Correcting Formulas 
 

Finding and correcting errors in Formulas 
 Excel provides the following tools to help you find and correct errors in 

formulas. 
 Error values identify formulas that cannot be evaluated, for example 

#NAME?. 
 Formula error checker identifies formulas with common problems using 

predefined rules. 
 Use the Formula Auditing toolbar to calculate your formula one step at a 

time and to trace relationships between cells as defined by formulas. 
 Watch Window watches the formula and results of cells you identify. 
 

Finding error values  
 When Excel cannot evaluate a formula result, an error value is displayed.  

The error value displayed depends on the type of error.  Cells with error 
values are marked at the top-left corner with a triangle (usually green). 

 To see the reason for the error value, begin by selecting the cell with the 
error value you want to correct. 

 Place your mouse over the warning icon  to display the screen tip 
description: 
 

 
 
OR click on the warning icon to display the reason at the top of the popup 
menu: 
 

 
 
 

Correcting error values  
 You can correct an error value by selecting an option from the warning icon 

popup menu.  For some error values, the popup menu will include corrective 
actions to correct the error. 
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 To correct an error value, begin by selecting the cell with the error value you 
want to correct.  Click on the warning icon, and select a corrective action or 
one of the following options. 

 Help on this error: get a detailed explanation of the error. 
 Show Calculation Steps: calculate your formula one step at a time to 

identify the location of the error. 
 Ignore Error: ignore the error and remove the top-left triangle. 
 Edit in Formula Bar: place the mouse cursor in the Formula Bar to edit the 

formula. 
 Error Checking Options: display the Error Checking Options dialog box. 
 Show Formula Auditing Toolbar: display the Formula Auditing toolbar: 

 

 
 
 

Using the Formula Error Checker 
 

Using the Formula error checker 
 The Formula error checker identifies formulas with common problems 

using predefined rules.  Begin by selecting the Worksheet you want to check. 
 From the main menu, choose Tools > Error Checking 

 
OR from the Formula Auditing toolbar, click on the Error Checking icon 

.  If an error is found, the Error Checking dialog box appears: 
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 Resolve the error by selecting a corrective action (Update Formula to 
Include Cells is the corrective action in the above example), or by ignoring 
the error. 

 Click Next.  
 Continue until the error check is complete message appears: 

 

 
 
Note: Once a problem is ignored, it will not appear in future error checks. 

 

Rechecking ignored errors 
 From the main menu, choose Tools > Options, and click the Error 

Checking tab. 
 Click on the Reset Ignored Errors button. 
 Click OK: 

 

 
 

Customizing the Formula error checker 
 You can determine which common formula problems Excel checks for. 
 From the main menu, choose Tools > Options, and click the Error 

Checking tab. 
 Select the checkbox for the rules you want. 
 Click OK: 
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Using the Formula Auditing Toolbar 
 

Displaying the Formula Auditing toolbar 
 From the main menu, choose View > Toolbars > Formula Auditing 

 
OR from the main menu, choose Tools > Formula Auditing > Show 
Formula Auditing Toolbar. 

 

Using the Formula Auditing toolbar 
 The Formula Auditing toolbar provides quick access to actions that can 

help you troubleshoot formula errors.  Each action is represented by an icon.  
When you put your mouse pointer over an icon, it is highlighted in blue and a 
descriptive tool tip appears.   

 Locate the icon for the action you want to use and click on the icon. 
 

 The following are icons on the Formula Auditing toolbar: 
 

 Error Checking – start Error Checker. 
 

 Trace Precedents – identify the cells that are used in the formula. 
 

 Remove Precedent Arrows – remove the precedent arrows. 
 

 Trace Dependents – identify the cells that use the active cell in their 
formulas. 
 

 Remove Dependent Arrows – remove the dependent arrows. 
 

 Remove All Arrows – remove both precedent and dependent arrows. 
 

 Trace Error – trace errors of the active cell. 
 

 New Comment – add a comment. 
 

 Circle Invalid Data – data that do not meet their data validation 
criteria. 
 

 Clear Validation Circles – remove validation circles. 
 

 Show Watch Window – display Watch Window. 
 

 Evaluate Formula – evaluate formula step by step. 
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Tracing Precedents 
 To help you track errors, Excel provides a graphical view of the cells used in 

the calculation of the results in the active cell.  Excel uses blue arrows to 
identify relationships and red arrows to identify cells that errors. 

 From the Formula Auditing toolbar, click on the Trace Precedents icon  

: 
 

 
 
Note: You can click on the Trace Precedents icon again to identify the next 
level of precedents (the cells used in the calculation of the precedents of the 
active cell). 

 

Removing Precedent Arrows 
 Precedent arrows can be remove one level at a time. 
 From the Formula Auditing toolbar, click on the Remove Precedent 

Arrows icon  

. 
 
Note: You can click on the Remove Precedent Arrows icon again to remove 
the next level of precedent arrows. 

 

Tracing Dependents 
 Excel also provides a graphical view of the cells that use the active cell in 

their calculation.  Excel uses blue arrows to identify the relationship. 
 From the Formula Auditing toolbar, click on the Trace Dependents icon  

: 
 

 
 

SAMPLE



Page 51 – Microsoft Excel Xp - Intermediate Level Manual 

FOR USE AT THE LICENSED SITE(S) ONLY 
 Cheltenham Courseware Ltd. 1995-2010 www.cheltenhamcourseware.com 

Note: You can click on the Trace Dependents icon again to identify the next 
level of dependents (the cells that use the dependents of the active cell in 
their formulas). 

 

Removing Dependent Arrows 
 Precedent arrows can be remove one level at a time. 
 From the Formula Auditing toolbar, click on the Remove Dependent 

Arrows icon  

. 
 
Note: You can click on the Remove Dependent Arrows icon again to remove 
the next level of dependent arrows. 

 

Adding a new comment 
 From the Formula Auditing toolbar, click on the New Comment icon  

. 
 Enter your comment; when finished, click outside of the comment box: 

 

 
 
Note: You can change how comments are displayed in the View tab of the 
Options dialog box. 

 

Evaluating Formulas one step at a time 
 To troubleshoot a formula, you can calculate your formula one step at a time.  

Begin by selecting the cell you want to evaluate. 
 From the Formula Auditing toolbar, click Evaluate Formula. 
 Click the Evaluate button to see the results (in italics) of the underlined part 

of the formula: 
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(If the underlined part of the formula is a reference to another formula, you 
can click the Step In button to step through other formula in a new 
Evaluation box.  Click the Step Out button to go back to the previous 
formula): 
 

 
 

 Continue stepping through the formula until the entire formula has been 
evaluated. 

 Click Close to end the evaluation. 
 
Note: The Evaluate Formula feature evaluates some formulas slightly 
differently than in the Worksheet.  Please refer to the Microsoft Excel Help for 
details on the differences. 
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End of the preview sample 
 
 

 
 
This sample is approximately half of the full course.  Please see the table of contents at the 
beginning of this document to see the full list of topics covered in the full course. 
 
To purchase the rights to use the full training manuals at your training centre please see our 
web site at:  
 

http://www.cctglobal.com 
 
A courseware licence allows you to make unlimited copies for use at your training centre. 
 

 
 
In addit ion you get HTML formatted versions of each 
course, included w ith our printable coursew are. 
 
Invest in a complete Computer Courseware Library, 
including Windows 7 & Office 2010 
The most cost effective courseware solution for your IT 
training needs. Get ALL our courses, and all new  courses 
released w ithin 12 months. 
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