
 

 

Microsoft Excel XP 
Workbook - Intermediate Level 
 

  W
O

R
K

B
O

O
K

 –
 w

w
w

.cctg
lo

b
a
l.co

m
 

SAMPLE



Page 2 – Microsoft Excel XP - Intermediate Level Workbook 

FOR USE AT THE LICENSED SITE(S) ONLY  
 Cheltenham Courseware Ltd. 1995-2010 www.cheltenhamcourseware.com 

© 1995-2010 Cheltenham Courseware Pty. Ltd.  
 
All trademarks acknowledged. E&OE. 
 
No part of this document may be copied without written permission from Cheltenham Courseware unless 
produced under the terms of a courseware site license agreement with Cheltenham Courseware. 
 
All reasonable precautions have been taken in the preparation of this document, including both technical and 
non-technical proof ing. Cheltenham Courseware and all staff assume no responsibility f or any errors or 
omissions. No warranties are made, expressed or implied with regard to these notes. Cheltenham Courseware 
shall not be responsible f or any direct, incidental or consequential damages arising from the use of any material 
contained in this document. If you find any errors in these training modules, please inform Cheltenham 
Courseware. Whilst every effort is made to eradicate ty ping or technical mistakes, we apologise f or any errors 
y ou may detect. All courses are updated on a regular basis, so your feedback is both valued by us and will help 
us to maintain the highest possible standards. 
 
Sample versions of courseware from Cheltenham Courseware 
(Normally supplied in Adobe Acrobat format): If the version of courseware that you are v iewing is marked as NOT 
FOR TRAINING, SAMPLE, or similar, then it cannot be used as part of a training course, and is made available 
purely f or content and style review. This is to giv e y ou the opportunity to prev iew our courseware, prior to making 
a purchasing decision. Sample v ersions may not be re-sold to a third party. 
 
For current license information 
This document may only be used under the terms of the license agreement f rom Cheltenham Courseware. 
Cheltenham Courseware reserves the right to alter the licensing conditions at any time, without prior notice. 
Please see the site license agreement available at:  www.cheltenhamcourseware.com.au/agreement 
 
Contact Information 
 
Australia / Asia Pacific / Europe (ex. UK) / Rest of the World 
Email: info@cheltenhamcourseware.com.au 
Web: www.cheltenhamcourseware.com.au 
 
USA / Canada 
Email: info@cheltenhamcourseware.com 
Web: www.cheltenhamcourseware.com 
 

UK  
Email: info@cctglobal.com 
Web: www.cctglobal.com 
 

 

SAMPLE



Page 3 – Microsoft Excel XP - Intermediate Level Workbook 

FOR USE AT THE LICENSED SITE(S) ONLY  
 Cheltenham Courseware Ltd. 1995-2010 www.cheltenhamcourseware.com 

 

INSTALLING THE SAMPLE FILES INTO THE HARD DISK ........................................................... 4 
INSTALLING THE SAMPLE FILES ...................................................................................................... 4 

VIEWING WORKSHEETS ............................................................................................................ 5 
CUSTOMIZING A TOOLBAR ............................................................................................................ 5 
HIDING WORKBOOKS AND WORKSHEETS ........................................................................................ 5 
FREEZING PANES ........................................................................................................................ 5 
GROUPING AND UNGROUPING WORKSHEETS................................................................................... 6 

MORE FORMATTING TECHNIQUES............................................................................................ 8 

CREATING AND APPLYING A FORMATTING STYLE .............................................................................. 8 
USING CONDITIONAL FORMATTING ................................................................................................. 8 
HIDING AND DISPLAYING CELLS ..................................................................................................... 9 

MORE FORMULAS AND FUNCTIONS ........................................................................................11 
USING THE SERIES COMMAND......................................................................................................11 
USING INSERT FUNCTION WIZARD.................................................................................................11 
CORRECTING FORMULAS.............................................................................................................12 
USING THE WATCH WINDOW........................................................................................................13 

DATABASE AND LIST MANAGEMENT.......................................................................................15 

SORTING A DATABASE ................................................................................................................15 
USING AUTOFILT ERS ..................................................................................................................16 
USING ADVANCED FILTER ............................................................................................................17 
ADDING A NEW RECORD USING A DATA FORM .................................................................................18 

CHARTS .....................................................................................................................................19 

CREATING A CHART ....................................................................................................................19 

DRAWING AND PICTURE OBJECTS ..........................................................................................21 

DRAWING AUTOSHAPES..............................................................................................................21 

EXCEL 2002 AND OTHER APPLICATIONS .................................................................................23 

CONVERTING A LOTUS 1-2-3 FILE .................................................................................................23 
USING PASTE SPECIAL................................................................................................................23 
EMBEDDING OBJECTS.................................................................................................................23 
LINKING OBJECTS ......................................................................................................................24 
INSERTING A HYPERLINK .............................................................................................................24 
MANAGING LINKS .......................................................................................................................24 

 
 SAMPLE



Page 4 – Microsoft Excel XP - Intermediate Level Workbook 

FOR USE AT THE LICENSED SITE(S) ONLY  
 Cheltenham Courseware Ltd. 1995-2010 www.cheltenhamcourseware.com 

Installing the Sample Files into the Hard Disk 
 
 

Installing the sample files 
 

 Use Windows Explorer to create a folder called Excel XP Intermediate 
Samples, in the My Documents folder. 

 Copy the sample files for this course to the My Documents\Excel XP 
Intermediate Samples folder.  If these files have been copied to your 
network server, then ask your trainer/supervisor for more information about 
how to copy these files to your PC’s hard disk. 
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Viewing Worksheets 
 
 

Customizing a Toolbar 
 

 Start Excel 2002. 
 Choose View > Toolbars > Drawing. 
 Right-click on the Drawing toolbar, and choose Customize from the popup 

menu. 
 Click on the Commands tab. 
 Select Insert from the Categories list box, and locate the Object command 

in the Commands list box. 
 Click and drag the Object command onto the Drawing toolbar: 

 

 
 
 

Hiding Workbooks and Worksheets 
 

 Open the inventory.xls file from the Excel XP Intermediate Samples folder. 
 Click on the Inventory sheet tab. 
 Choose Format > Sheet > Hide to hide the Worksheet. 
 Choose Window > Hide to hide the Workbook. 
 Choose Window > Unhide. 
 Select inventory.xls, and click OK to display the Workbook. 
 Choose Format > Sheet > Unhide. 
 Select Inventory, and click OK to display the Worksheet. 
 Close the inventory.xls file without saving. 
 
 

Freezing Panes 
 

 Open the inventory.xls file from the Excel XP Intermediate Samples folder. 
 Select cell B2. 
 Choose Window > Freeze Panes to freeze the panes. 
 Press and hold the Down Arrow key to see the effect of the frozen panes: 
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 Choose Edit > Go To, and enter B2 in the Reference text box, and click 
OK. 

 Press and hold the Right Arrow key to see the effect of the frozen panes: 
 

 
 

 Choose Window > Unfreeze Panes. 
 Close the inventory.xls file without saving. 
 
 

Grouping and Ungrouping Worksheets 
 

 Open the Format.xls file from the Excel XP Intermediate Samples folder. 
 Click on the Quarter 3 sheet tab.  (Notice that there is no formatting on this 

sheet.) 
 Click on the Quarter 1 sheet tab.  (Notice that there is no formatting on this 

sheet.) 
 Hold the Ctrl key, and click on the Quarter 3 sheet tab.   
 Select cell A1. 
 Click on the Bold icon on the Formatting toolbar. 
 Click on the Font Color down arrow on the Formatting toolbar, and select a 

red color: 
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 Right-click on the Quarter 1 sheet tab, and choose Ungroup Sheets from 
the popup menu. 

 Click on the Quarter 3 sheet tab to see that cell A1 has the same formatting 
as the Quarter 1 sheet: 
 

 
 

 Close the Format.xls file without saving. 
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More Formatting Techniques 
 
 

Creating and Applying a Formatting Style 
 

 Open the Format.xls file from the Excel XP Intermediate Samples folder. 
 Click on the Quarter 4 sheet tab. 
 Select cell B4. 
 Choose Format > Style. 
 Type ColumnLabel into the Style name dropdown list box, and click Add. 
 Click OK. 
 Click on the Quarter 1 sheet tab. 
 Select range B4:H4. 
 Choose Format > Style. 
 Click on the Style name down arrow, and select ColumnLabel. 

 
Note: If you do not see the above style, choose the Normal style. 
 

 Click OK: 
 

 
 

 Select cell B4. 
 Click on the Format Painter icon on the Formatting toolbar. 
 Click on cell A4 to apply the format: 

 

 
 

 Close the Format.xls file without saving. 
 
 

Using Conditional Formatting 
 

 Open the Format.xls file from the Excel XP Intermediate Samples folder. 
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 Click on the Quarter 2 sheet tab. 
 Select range B5:F10. 
 Choose Format > Conditional Formatting. 
 In Condition 1, enter the following criteria: 

Cell Value is between 25 and 50 
 Click on the Format button. 
 Click on the Font tab, select Bold in the Font style list box, and select blue 

from the Color popup menu.   
 Click on the Patterns tab, and select light turquoise from the Cell shading 

color. 
 Click OK to close the Format Cells dialog box.  (An example of a 

Conditional Formatting dialog box is below): 
 

 
 

 Click OK. 
 Deselect the range to see the conditional formatting: 

 

 
 

 Close the Format.xls file without saving. 
 
 

Hiding and Displaying Cells 
 

 Open the Format.xls file from the Excel XP Intermediate Samples folder. 
 Click on the Quarter 3 sheet tab. 
 Click and drag the right border of column F to the right border of column A to 

hide the columns: 
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 Select column A and column G. 
 Choose Format > Column > Unhide to display the columns. 
 Close the Format.xls file without saving. 
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More Formulas and Functions 
 
 

Using the Series Command 
 

 Click on the New icon on the Standard toolbar to create a new Workbook. 
 Type the number 3 into cell A1, and press the Enter key. 
 Type the number 6 into cell A2, and press the Enter key. 
 Select range A1:A2. 
 Drag the bottom-right corner to cell A8. 
 Type January into cell C1. 
 Drag the bottom-right corner of cell C1 to cell C12: 

 

 
 

 Close the file without saving. 
 
 

Using Insert Function Wizard 
 

 The objective of this exercise is to calculate the Bonus for the sales staff.  All 
sales staff will receive a bonus of $100.  In addition, those who have 
exceeded their targets will receive a bonus of 5%.  Our bonus calculation will 
say that if Actual Sales exceeds Forecast Sales, the salesperson will receive 
$100 plus 5% of the excess; otherwise, the salesperson will receive just 
$100. 

 

 Open the Bonus.xls file from the Excel XP Intermediate Samples folder. 
 Select cell D4. 
 From the main menu, choose Insert > Function. 
 Choose the Logical category. 
 Select the IF function. 
 Click OK to display the Function Arguments dialog box. 
 Enter the following arguments: 
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 Click OK. 
 Copy the contents of cell D4 to range D5:D7: 

 

 
 

 Close the Bonus.xls file without saving. 
 
 

Correcting Formulas 
 

 Open the CorrectFormula.xls file from the Excel XP Intermediate Samples 
folder. 

 Choose Tools > Error Checking. 
 Click on the Help on this error, and read the detailed explanation of the 

error. 
 From the Error Checking dialog box, click Resume. 
 Click on the Edit in Formula Bar to see the formula.  Notice that the 

highlighted range does not include cell B7. 
 From the Error Checking dialog box, click Resume. 
 Click on the Update Formula to Include Cells button. 
 Click OK. 
 Choose View > Toolbars > Formula Auditing. 
 Select cell G9. 
 Click on the Trace Precedents icon on the Formula Auditing toolbar. 
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 Click on the Trace Precedents icon again.   
 Click on the Trace Dependents icon on the Formula Auditing toolbar: 

 

 
 

 Click on the Remove All Arrows icon. 
 With cell G9 selected, click on the Evaluate Formula icon on the Formula 

Auditing toolbar. 
 Click Step In, and click Evaluate to evaluate the secondary formula. 
 Click Step Out, and click Evaluate to evaluate one step of the primary 

formula. 
 Continue clicking the Evaluate button until you have step through the 

formula. 
 Click Close. 
 Close the CorrectFormula.xls file without saving. 
 
 

Using the Watch Window 
 

 Open the CorrectFormula.xls file from the Excel XP Intermediate Samples 
folder. 

 Select cell G9. 
 Choose Tools > Formula Auditing > Show Watch Window. 
 Click on the Add Watch icon. 
 Click Add. 
 Select cell C2. 
 Enter the number 25, and press the Enter key.  Notice that the value in the 

Watch Window changes. 
 Experiment with changing other values, and see the effect in the Watch 

Window: 
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 Close the Watch Window. 
 Close the CorrectFormula.xls file without saving. 
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Database and List Management 
 
 

Sorting a Database 
 

 Open the inventory.xls file from the Excel XP Intermediate Samples folder. 
 Select cell A1. 
 Choose Data > Sort. 
 Click on the Sort by down arrow, and select Type.  Click on the Descending 

radio button. 
 Click on the They by down arrow, and select Item.  Click on the Ascending 

radio button. 
 Click the Header row radio button. 
 Click OK to sort: 

 

 
 

 Choose Data > Subtotals. 
 Select Type from the At each change in dropdown list. 
 Select Sum from the Use function dropdown list. 
 Select only the On Hand check in the Add subtotal to list box.  (Deselect 

the other items if needed.) 
 Select the Replace current subtotals and the Summary below data 

checkboxes. 
 Click OK to create subtotals: 

 SAMPLE
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 Close the inventory.xls file without saving. 
 
 

Using AutoFilters 
 

 Open the sales.xls file from the Excel XP Intermediate Samples folder. 
 Choose Data > Filter > AutoFilter to turn on AutoFilter. 
 Select Top 10 from the Desktop dropdown list. 
 Enter the following criteria: 

Top 5 Items 
 

 
 

 Select All from the Desktop dropdown list. 
 Select Custom from the Notebook dropdown list. 
 Enter the following criteria: Show rows where Notebooks 

Is greater than or equal to 50 
Or 
Is less than or equal to 10 

 Click OK: 
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 Choose Data > Filter > AutoFilter to turn off AutoFilter. 
 Close the sales.xls file without saving. 
 
 

Using Advanced Filter 
 

 Open the sales.xls file from the Excel XP Intermediate Samples folder. 
 Select range A1:A5. 
 Choose Insert > Rows. 
 Select range A6:F6. 
 Click on the Copy icon on the Standard toolbar. 
 Select cell A1. 
 Click on the Paste icon on the Standard toolbar. 
 Select cell B2, and enter the following 

>80 
 Select cell C3, and enter the following 

>50 
 Select cell D4, and enter the following 

>75 
 

 
 

 Select cell A6. 
 Choose Data > Filter > Advanced Filter.   
 Select the Copy to another location radio button. 
 In the List range text box, check to see that the range, $A$6:$F$30 is 

entered. 
 In the Criteria range text box, click on the Minimize Dialog icon, and 

select range A1:F4. 
 Press the Enter key. 
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 In the Copy to text box, click on the Minimize Dialog icon, and select cell 
H6. 

 Press the Enter key. 
 Click OK: 

 

 
 

 Close the sales.xls file without saving. 
 
 

Adding a new Record using a Data Form 
 

 Open the inventory.xls file from the Excel XP Intermediate Samples folder. 
 Select cell A1. 
 Choose Data > Form to display the Data Form for the list. 
 Click on the New button. 
 Enter the following record: 

 

 
 

 Press the Enter key. 
 Click Close to close the Data Form. 
 Close the inventory.xls file without saving. 
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Charts 
 
 

Creating a Chart 
 

 Open the Format.xls file from the Excel XP Intermediate Samples folder. 
 Click on the Quarter 4 sheet tab. 
 Select range A4:F10. 
 Click on the Chart Wizard icon on the Standard toolbar. 
 Select Column from the Chart Type list box. 
 Select Clustered Column (the first sub-type) from the Chart sub-type.   
 Click and hold on the Press and Hold to View Sample button to preview 

the chart. 
 Click Next. 
 Select the Rows radio button to display the series in rows. 
 Click Next. 
 Click on the Titles tab, and enter the following titles: 

 

 
 

 Click on the Legend tab, and deselect the Show legend checkbox. 
 Click on the Data Labels tab, and select the Value checkbox. 
 Click on the Data Table tab, select the Show data table checkbox, and 

select the Show legend keys. 
 Click Next. 
 Select the As new sheet radio button, and enter Q4 Graph in the text box. 
 Click Finish: 
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 Click on the chart, and display the Chart toolbar.   
 Select Chart Area from the Chart Objects dropdown list. 
 Click on the Format Chart Area icon to format the Chart Area. 
 Select the Shadow checkbox. 
 Click OK to apply the format. 
 Select other chart object, and click the Format Chart Object icon to see the 

format options for that chart object. 
 
Note: Open the Chart.xls file in the Excel XP Intermediate Samples 
folder, and click on the Q4 Graph sheet tab to see an example. 
 

 Close the Format.xls file without saving. 
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Drawing and Picture Objects 
 
 

Drawing AutoShapes 
 

 Click on the New icon on the Standard toolbar to create a new Workbook. 
 Click on the Drawing icon on the Standard toolbar to display the Drawing 

toolbar (if it is not already displayed). 
 From the Drawing toolbar, click on the AutoShape icon, select Basic 

Shapes, and choose Smiley Face. 
 From the Worksheet, click and drag the mouse to draw the object. 
 Select the Smiley Face object. 
 From the Drawing toolbar, click on the Fill Color, and select Yellow.  Click 

on the Line Style icon, and select 3 pt.  Click on the Shadow Style icon, 
and select Shadow Style 4: 
 

 
 

 Click on the Rectangle icon on the Drawing toolbar. 
 From the Worksheet, click and drag the mouse to draw a Rectangle such 

that it completely covers the Smiley Face. 
 Select the Rectangle object. 
 From the Drawing toolbar, click on the Fill Color, and select Pale Blue. 
 Right-click on the Rectangle object, choose Order > Send to Back: 

 

 
 

 With the Rectangle object selected, hold down the Shift key, and click on 
the Smiley Face object to select both objects. 

 Right-click on over the selection, and choose Grouping > Group. 
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 Click on the Text Box icon on the Drawing toolbar. 
 From the Worksheet, click and drag the mouse to draw a Text Box in 

another area of the Worksheet. 
 Type This is a Smiley Face. 
 Click on the Text Box border, and resize the text box so that the text fits. 
 Select the Rectangle object, and drag to move the object so that it overlaps 

the Text Box.  (Notice that the Smiley Face and the Rectangle objects move 
together): 
 

 
 
Note: Open the Drawing.xls file in the Excel XP Intermediate Samples 
folder to see an example. 
 

 Close the file without saving. 
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Excel 2002 and Other Applications 
 
 

Converting a Lotus 1-2-3 File 
 

 Open the LOTUS.wk4 file from the Excel XP Intermediate Samples 
folder.  You should be able to open this Lotus 1-2-3 formatted file without 
problems. 

 Choose File > Save As, and save the file in Excel (.xls) format. 
 Close the file. 
 
 

Using Paste Special 
 

 Open the Format.xls file from the Excel XP Intermediate Samples folder. 
 Click on the Quarter 4 sheet tab. 
 Select cell G12. 
 Click on the Copy icon on the Standard toolbar. 
 Select cell A14. 
 Choose Edit > Paste Special. 
 Select the Values and number formats radio button. 
 Click OK.  (Notice that the formula in cell G12 was changed into a value, and 

only the number formatting was copied.) 
 Experiment with the other paste options. 
 Close the Format.xls file without saving. 
 
 

Embedding Objects 
 

 Click on the New icon on the Standard toolbar to create a new Workbook. 
 Select cell A1. 
 Choose Insert > Object, and click on the Create from File tab. 
 Click on the Browse button, and select the Sample.doc file from the Excel 

XP Intermediate Samples folder. 
 Click Insert. 
 Deselect the Link to file and Display as icon checkboxes. 
 Click OK. 
 Double-click on the embedded Word document to edit it in Excel. 
 Select and delete the address or make other significant changes. 
 Open the Sample.doc file in Microsoft Word to see that your changes did not 

affect to the original document. 
 Close the files without saving. 
 
 

SAMPLE



Page 24 – Microsoft Excel XP - Intermediate Level Workbook 

FOR USE AT THE LICENSED SITE(S) ONLY  
 Cheltenham Courseware Ltd. 1995-2010 www.cheltenhamcourseware.com 

Linking Objects 
 

 Open the Chart.xls file from the Excel XP Intermediate Samples folder. 
 Click on the Q4 Graph sheet tab, and select the chart. 
 Click on the Copy icon on the Standard toolbar. 
 Start Microsoft Word. 
 In a new document, choose Edit > Paste Special. 
 Select the Paste link radio button. 
 Select Microsoft Excel Chart Object from the As list box. 
 Click OK. 
 Save the Word document as ChartLinkdoc.doc in the Excel XP Intermediate 

Samples folder. 
 Switch to the Chart.xls file in Microsoft Excel. 
 From the Chart toolbar, click on the Data Table icon to hide it. 
 From the Chart toolbar, click on the Legend icon to display it. 
 Switch back to Microsoft Word. 
 Right-click on the chart, and select Update Link.  Notice that the changes 

made in Excel is reflected in the Word document. 
 
Note: Using Word, open the ChartLink.doc file in the Excel XP 
Intermediate Samples folder to see an example. 
 

 Close the files without saving. 
 
 

Inserting a Hyperlink 
 

 Click on the New icon on the Standard toolbar to create a new Workbook. 
 Select cell A1. 
 Choose Insert > Hyperlink. 
 From the Link to area, select Existing File or Web Page. 
 In the Text to display text box, enter Test Link. 
 In the Look in area, select the Sample.doc file from the Excel XP 

Intermediate Samples folder. 
 Click OK. 
 From the Worksheet, click on the cell A1 to display the Sample.doc file in 

Microsoft Word. 
 Close the file without saving. 
 
 

Managing Links 
 

 Click on the New icon on the Standard toolbar to create a new Workbook. 
 Select cell A1. 
 Choose Insert > Object, and click on the Create from File tab. 
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 Click on the Browse button, and select the Sample.doc file from the Excel 
XP Intermediate Samples folder. 

 Click Insert. 
 Select the Link to file checkbox. 
 Click OK. 
 Double-click on the linked document to display it in Microsoft Word. 
 Switch back to Microsoft Excel, and choose Edit > Links. 
 Click on the Change source button. 
 Look at the link syntax, and click Cancel. 
 Click on the Break Link button. 
 Click Break Links to remove the link. 
 Click Close to close the Edit Links dialog box. 
 Double-click on the document.  Notice that the Format Picture dialog box 

appears instead of displaying the document in Microsoft Word. 
 Close the files without saving. 
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