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Installing the Sample Files

e Use Windows Explorer to create a folder called FrontPage 2003
Foundation Samples, in the My Documents folder.

e Copy the sample files for this course to the My Documents\FrontPage
2003 Foundation Samples folder. If these files have been copied to your
network server, then ask your trainer/supervisor for more information about
how to copy these files to your PC’s hard disk.

SAMPLE
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The FrontPage 2003 Interface

The FrontPage 2003 Workspace

o Use Windows Explorer to create a folder called FrontPage 2003
Foundation Work in the My Documents folder.

o Copy the Images folder from the FrontPage 2003 Foundation Samples
folder to the FrontPage 2003 Foundation Work folder.
e Launch FrontPage 2003.

Note: If the new_page_1.htm page, the New Page or Web task pane, or
a Web is opened, close them down before you begin the exercises.

¢ Click the X button at the top right corner to close any web pages or task
panes that may be open.

¢ From the main menu, choose File = Open Site to open the Open Site dialog
box, and locate the ViewExerciseWeb folder in your FrontPage 2003
Foundation Samples folder:

Open Site
Loak in: I@ FrontPage 2003 Foundation Sa... j @-3Q X [y - Tools~

Images
| I"-’Iy_F‘ersnnaI_'-.-'-.-'eI:u
My Recent iewExerciseteb
Dacurments
Deskkop

o

3

My Documents

ET1

k5

e Click Open. The Web Site will open in FrontPage.

e Place your cursor on the far left of a toolbar, and when it changes to a 4-
arrowed cross, drag the toolbar to another location in the workspace.

¢ In the Folder list pane, click on the New Page icon and the New Folder

icon at the top of the pane and observe the results.

In the Folder list pane, doubleclick on aboutme.htm.
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¢ In the main view window, click on the Web Site tab and the aboutme.htm
tab and observe the changes.

¢ Note the download time displayed at the bottom of the main view window
when the aboutme.htm file is selected.

¢ From the main menu, choose File= Close Site to close the sample website.

Creating New Pages

e From the main menu, choose File = New. The New task pane opens on the
right side of the screen

¢ From the New task pane, choose Blank page to create a new individual
page:

New r X
@ =) 0
New page
_] Blank page
=] Text file % ]
[3}] From existing page. ..
More page templates. ..

¢ From the main menu, choose File > Save.

e Name the page MyFile.htm, and navigate to your FrontPage 2003
Foundation Work folder.

e Select Web Pages from the Save as type drop-down menu:

File name: IMyFiIelhtm =l

Save as bype: I'u'u'el:u Pages l{*.htm;*.html;*.shtml;*.shtm;*.stm;*.asp;*.ej

e Click Save.

e From the main menu, choose File > Close to close the file.

egNow, we will create a pagesfrom a templatessFromythe main menu, choose
File = New.

e The New task pane opens on the right side of the screen.

o Choose Mare page templates, and the Page Templates dialog box
appears.

o L0 the Page Templates dialog box, click on each template and.ebserve the
"thumbnail” of each template style in the Preview area at the bottom right
of the dialog box.

o Select Bibliography and click OK:
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Page Templates Ed |

zeneral |Frames Pages I Style Sheets I

9] 5 g ==

Mormal Page  [seeeg==ayd Confirmation  Feedback Opicns
Faorm Form ™ Just addihet task
o - - - ™| Gpenin curtent frame
S =] [ =] i
Descripkion
Farri Page Frequenthy Guesk Book  Photo Gallery Create a bibliography page that makes
Wizard Asked Q... references o printed or electronic
wiorks,
Previ
Search Page Table of Iser reiE

Conkents Reqistration

Ik I Zancel

¢ When the template opens in the main view window, observe the details of
your selection.
¢ From the main menu, choose File = Close, to close the file unsaved.

Page Properties

e From the main menu, choose File= Open, and navigate to your FrontPage
2003 Foundation Work folder.

e Locate the file you just created, MyFile .htm.

o Click Open,

o “Withythe file open, from|/the'main menu, chooeseFile > Properties to open
the Page /Properties dialog'box:
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Page Properties |

General I Formatking Advanced |Cust|:|m I Language: I
Margins

Top Margin: || = Pixels Margin Width: I ﬁ Pixels
Left Margin: I = Pixels Margin Height: I ﬁ Pixels

Eotkarn Margin: I
Right Margin: I

Skyles

Body styvle. .. | Follover stvle... | [ Enable hypetlink rallover effects

Design-time control scripting

FlatForm:

ICIient {IE 4.0 DHTML) |
Server!

I'-.-'EiSu:ript |
Clienkt:

IJavaScript j

()4 I Cancel

e Select each of the following tabs and observe the various options available:

General tab
Formatting tab
Advanced tab
Custom tab
Language tab

¢ When you have finished observing the content of each Page Properties
dialog box tab, click Cancel.
e Close the file.

€reating aNewAwebiFile FF B & B | -

o We will now create a Web site using a FrontPage template.
e _From the main menu, choose File > New.
e The New Task pane opens on the right side of the screen.

e Choose More Web site templates, and the Web Site Templates dialog
box appears:

FOR USE AT THE LICENSED SITE(S) ONLY
© Cheltenham Courseware Ltd. 1995-2010 www.cheltenhamcourseware.com



PAGE 9 - FRONTPAGE 2003 - FOUNDATION LEV EL WORKBOOK

Mew Web site
@ Cne page Web site. .,
|§|_;J SharePoint keam site. .
@H Wb package solutions., .,
More Web site bemplates. ,@

¢ In the Web Site Templates dialog box, click on each template icon and
observe the description noted at the bottom right of the dialog box:

Web Site Templates Ed |

zeneral |F‘au:kages I SharePoint Services I

BN

Cne Page Corporate Customer Database Options

Web Sike Presen... Support YWy, Interfa... Specify the location of the new Web site:
@EJ IC:'l,Du:u:uments and SettingsiMy Doc j

Discussion Empty Web  Import Web [EEEEg= R0 Browse. .. |

W'eb Sik, ., Site Site Wizard Site

Pm]?i:ttEWEb iﬁiﬁ?ﬁg’: Create a personal Web site with pages

an your inkerests, phatas, and
Favorite web sites,

[~ &dd to current 'Web site
I | Encrypted conmection required (S50

Descripkion

Ik I Zancel

e Click on the Browse button, and navigate to your FrontPage 2003
Foundatiom Wark folder.

¢ “Click,on the Create New Folder/icon at thestopsof the New Web Site
Location/dialog box :

| Hew Web Site Location E3
Laok in: IJ FrontPage 2003 Foundation Wark j @ -4 & = Tools =

% sy
g Create Mew Falder|

M Rerenk

o Name the folder My_Personal_Web and click OK to return to the New
Web Site Location dialog box.
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Hew Folder [ x|

Mame: IMy_F‘ersunaI_‘-.-'-.-'el:u Cancel

e Click Open.

e Select Personal Web Site and click OK.

e Observe the files and folders created in the Folder List.

e Close the Web Site by choosing File > Close Site. Do not save any changes.

SAMPLE
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Views

Moving Around the Workspace

e Choose File = Open Site from the main menu.

o Locate the ViewExerciseWeb subfolder inside your FrontPage 2003
Foundation Samples folder, and click Open.
¢ In the Folder List, double-click on index.htm to open it.

¢ From the main menu, choose View, and select each option in the drop-down
menu in turn:

=<
fi]
=

Page

Folders

Reporks 3
Mavigation

Hyvperlinks

Tasks

Folder List  Alc+F1

(<]l & g & 3 U=

Task Pane  Crrl+F1

Toolbars 3

»
W

e Observe the changes in the main view window when each option is selected.
e Choose each item on the Menu Bar and observe the options in the drop-
down menus for each:

File Edt iew Insert Format  Tools  Table Data  Frames  Window  Help

File
Edit
Insert
FEormat
Tools
Table
Data
Frames
Window

Note: (Some menu options will be "greyed out” as they are specific to
certain actions.)

e |In the Folder List window, double-click aboutme.htm.
e In the main view window, select the About Me text:
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[Iﬁ YWeb Site H indez. hkm \[ahuutme.htm
| [<body>| [<table>| [<tr>| [<td>|[<h3z]

About Me

e Click on each item on the Formatting toolbar and makes changes to the
selected text:

Formatking *
Marmnal ~  Times Mew Roman - 3f{lzpt) - | B T U

¢ In the Folder List, double click Feedback. Observe the changes in the tabs
at the top of the main view window:

A A |iSis == m- A

[ Weh Sike ” index:, htm \kabuutme.htm* \[feedhack.htm

e Close the Web Site by choosing File > Close Site. Do not save any changes.

Changing the Page Window

e Choose File = Open Site from the main menu.

e Locate the ViewExerciseWeb subfolder inside your FrontPage 2003
Foundation Samples folder, and click Open.

e Double—<click aboutme.htm in the Folder List.
¢ From the main menu, choose View = Page.
At the bottom of the main view window, select in turn Design, Code, Split

PL
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aboutme.htm

18 <htmlx

L3 [

<heads>
<meta http-emqmuiv="Content-Type™ content="text/htunl; charset=windows-1252">
<meta http-equiv="Content-Lanmage” content="en-us">

«rtitlexdbout Mes/titles

<meta name="Microsoft Theme" content="sky 1011, default™:

< ihead-

L= R 0

o a1

o

<hodys

¥ < table border="0" cellpadding="0" cellspacing="0" widcth=""100%">
“Erx
<td width="150" colspan="2" align="center"=&nhsp;<;/od-
<td align="center':
<! =—webbot bot="Navigation” s-type="banner"” s-rendering="graphics™ s-orie:
it
LS tER
) < /table>
<table border="0" cellpadding="0" cellspacing="0" width="100%">

<LE:
<td style="horder-botton-style: so0lid; border-bottom-width: 17 alig‘n="rﬁ|

¢ When you have finished observing the changes, close the site by choosing
File > Close Site from the main menu.

SAMPLE
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The Standard Toolbar

¢ On the Standard toolbar, click the small down-arrow beside the New button
and choose Page from the drop-down list:

0 -|es- 3 &

Page...

I,

[
(@] ‘Web Site,.. l’\é
B
=l

Blank Page  Crrl4+M

Texk File

o In the Page Templates dialog box, select Normal Page. Click OK:

Page Templates E3 |

General |Frames Pages I Skyle Sheets I

%o

EBibliography  Confirmation  Feedback Options
Farm Form ™| Just add ek bask:
e - - - r EEen in current frame
. ] | ] Description
Form Page Frequently Guest Book  Photo Gallery Create a blank web page.

Wizard Asked Q...

. . . Presview

- Search Page Table of User . mm
Cankents Reqgistration

iy
L

Ik g Cancel

e Hover your mouse over each item on the Standard toolbar and note the
button labels.

e The majority of these buttons and their actions will be used in future
exercises.
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Choose the Design view, if it is not already selected.
Place your cursor in the main view window and type your name.
Select the text and click on the Copy button on the Standard toolbar.

Place the cursor in another part of the window and click the Paste button on
the Standard toolbar. Your name will be copied to the new location.

Click the Undo button on the Standard toolbar and observe what happens to
the text.

Now click the Redo button on the Standard toolbar.

Place your cursor in another part of the main view window and click the
Insert Table button on the Standard toolbar.

In the displayed grid, highlight four columns by three rows and click on it:

3|01 & 45 | 6

11 [ [
HEEN

NEEF
EEENE

3 by 4 Table

Place the cursor in a new location in the main window and click the Insert
Layer button. This will insert a “floating” box, within which text or images
can be placed.

Click on the edge of the "box" to select it, and holding down the left mouse
button, move the "box" around the screen.

Click inside the "floating™ Layer and then click the Insert Picture from File
button on the Standard toolbar to open the Picture dialog box.

Locate the image file parrotl_small.jpg in the ViewExerciseWeb folder,
and click Insert.

The image of the parrot will be place in the Layer box and can be moved
around the page:

Click on the Drawing button to display the Drawing toolbar.
Move the cursor over each of the buttons on the toolbar and note the labels:
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Draw~ [t |&gtoshapes> N\ " O MH 4 8 &E | &-L-A-=== 0 @

Click the small down-arrow at the end of the Standard toolbar to open the
drop-down menu:

A0 98] @ -

Shows Buktons on One Fow

Add or Remove Buttons

Choose Add or Remove Buttons > Standard and display all the options to
customise the Standard toolbar.

Check and uncheck various options and observe the results on the toolbar.
Click on Close to close the Customize toolbar.

Select the text on the page, and click the down arrow beside the Font box on
the Formatting toolbar.

From the displayed dropdown list of fonts, select Arial. Note the new font
has been applied to the text on the page:

irial] [lsuzp - B 7

(default font) A
H fgency B =
t ALGERIAN

% Arial Black l!

T Arial Marraw

T Arial Rounded MT Bold

B Arial Unicode MS

i Baskerville Old Face

T Batang

% Bavhaus 93

% Bell BT =l

With the text still selected, click the Bold button on the Formatting toolbar
topbold the/text:

B

et

Place your cursor on another place on the page and click the Bullets button
on the Formatting toolbar.

Type two or three words and press the Return button on your keyboard, and
type another word. Press Return again.

Click the Bullets button on the toolbar again and this will finish the list.
Now we will highlight the bulleted text.
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Select the bulleted text, and click the small down arrow beside the Highlight
button on the Formatting toolbar. Select the colour Yellowv:

| | | Autamatic |

Standard Colors

H(EEEENEN
ONEECONEEN

Theme Caolors

EEEEREC

Mare Colars, .,

e Select your name text on the page.

Click the small down arrow beside the Font Color button on the toolbar and
select your preferred colour.

Observe that the selected text in now displayed in your chosen colour.
¢ From the main menu, choose File > Close, without saving.

SAMPLE
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Working with Text

¢ From the main menu, select File = New.

¢ In the New task pane, click on More page templates.

e In the Page Templates dialog box, click on the General tab.
¢ Select the Guest Book template, and click OK:

Page Templates Ed |

zeneral |Frames Pages I Style Sheets I

o & & O] B

Mormal Page  Bibliography  Confirmation  Feedback Options
Faorm Form ™ Just addihet task
JEE r DEen in current frarme
N <] I Q= [x]
@ D 1= D Descripkion
Farm Page Frequently SIENENA  Photo Gallery Create & page where visitors to wour
Wizard Asked Q... Web site can leave their comments in
a public guest log.
Previ
Search Page Table of Iser reiE

Conkents Reqistration

Ik [_: I Zancel

e nSelect the following sentence:

We'd like to know what you think about our web site.

we'd e to know what you think about cur web sitejiNEEES
leave your comments m thiz public guest book so we can share
your thoughts with other wisitors.

éAdd Your Comments

e Type over the selected text:
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Thank you for visiting my Web Site.

e Place the cursor in the same paragraph and from the main menu, choose
Format = Paragraph:

Format | Tools Table Data F

A Fort...

|ﬁ Paragraph... {
‘= Bullets and Mumbering. ..

L Theme...
A4 style...

£

¢ In the opened Paragraph dialog box, choose Justify from the Alignment
drop-down list and click OK:

Paragraph |

Indents and Spacing |

Inderk first line:

T

After text:

Spacing
Before: Line spacing:
Afker: ISingIe j
Word:
Presview
, | u-“u. x " ia.gq_.. o " P‘B‘-"' el m.m.hlm.a
] ol AR N o e i
A \BFu kU AR - el

b Fr P

Cancel

e Observe the changes to the selected paragraph.
e Close the file without saving it.
o EXit FrontPage 2003.
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Colours

Working with colours

e Launch FrontPage 2003.

¢ From the main menu, choose File = Open Site, and open
My Personal_Web in the FrontPage 2003 Foundation Work folder.

o Click on the New Page button on the Folder List to create a new page.
¢ In the Folder Pane, double-click new_page_1.htm to open it.
e From the main menu, select Format = Theme.

e From the Theme task pane, click on No Theme from the All available
themes list to ensure there is no theme attached to the site:

Select a theme

All available themes

Mo theme

~ Matheme

AEENENLEAE
EETNEHLELE

LLETELRTEE]
AREELLLARS

Afternoon

e Close the Theme task pane.
¢ From the main menu, choose File = Properties.
e Click on the Formatting tab, and select the following colours:

Background - Automatic
Text - Navy

Hyperlink - Green

Visited hyperlink - Gray
Active hyperink + Maroont
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Page Properties

r

™ Make it awatermatk

Froperbies.. .

e Click More Colors at the bottom of any colour-related drop-down list:

1 More Colors... k

¢ In the opened More Colors dialog box, click on various colours and observe

SAMPLE
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More Colors Ed |

Yalue: |Hex={33J99JFF}

Mane: |

Cuskarn, .. |

cf* Select. .. |

ey

Current:

0

O I Cancel

¢ In the More Colors dialog box, click the Custom button to open the Color
dialog box:

Color |
Bazic colors:

|
I

Custom colors:

[ T
Frm
T
HEE
HEn
i
-

¢ Choose a colour from Basic colors.

e Using both the “cursor’ in the main colour window and the slider on the right
side of the dialog box, create a customised colour.

e Click the Add to Custom Colors button.

e The new colour sample will appear in Custom colors.
e Click OK.

e Click OK again.
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¢ In the Formatting tab of the Page Properties dialog box, click on the same
colour menu and you will see your new colour in Custom Colors.

e Click OK.
¢ From the main menu, choose File > Save As, and name the file
formatting.htm. Click Save.

¢ From the main menu, choose File > Close Site.

SAMPLE
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Images

Working with Images

¢ From the main menu, choose File = Open Site, and open

My _Personal_Web in the FrontPage 2003 Foundation Work folder.
Create a new page, and double-click on it to openit.

From the main menu, choose Insert > Picture > From File.

Locate Sunflower.jpg in the Images folder in your FrontPage 2003
Foundation Work folder.

Click Insert:

1 "

o

e From the main menu, choose Insert > Picture > Clip Art.
e The Clip Art task pane opens on the right side of the screen:

SAMPLE
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' Clip Art > x

Search for:

|Flnwer | | a0

Search in:

|Sele-:ted collections | v|

Results should be:

|Sele-:l:e-:| media file bypes | v|

e Enter the word "flower" in the Search for box. Click the Go button.
o Click on the roses image and it will be displayed on the page:

o Close the Clip Art task pane.
e Move the cursor down five rows below the roses image by pressing the
Return button.

ew PBrawing.
X, and using the

e e e e e s

?

3

o

S

SRR
SRR

N\

s
\

o

¢ From the main menu, choose Insert > Picture > AutoShapes.
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A

aﬂ@[}o

Select the "Sun" from the Basic Shapes drop-down menu. Drag the cursor
to your preferred size below the sunflower and roses images just above the

rectangle and oval drawings you just created:

gxﬁﬂ%gn%%lﬁ

Place the cursor on the page above the "Sun" drawing and below the flower
images, and type the word "Flowers".

Select the text, and from the main menu, choose Insert > Picture >
WordArt to display the WordArt Gallery dialog box:

WordArt Gallery |
Select 2 Wordit syl
Wﬂﬂ‘w‘ Qorda,, Ill-rml WordArt _: W
! (WordArt [Wordaet o722 - ordin _' w
Wordhen WordAr | woann | Wordhrt [WordA W
wordaet[T0Art |Horido\ (Wl oo w
Tesda |l I% (T — e
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EdtWodArtTet [
Fank: 2lze:

I H Arial Black j I ¥ j il il

Texk:

Ik Cancel

¢ Click OK:

= Ty~

OWErS

Select the Wordart text and, using the sizing handles, reduce its size:
[ =

Click en the Reetangle, Circle and Sun, and drag them under the Wordart,
as illustrated:

OWErs

[ | A

Y
D

7
=
T
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e Select the sunflower image, and use the resizing handles to make the
image larger or smaller:

"u |

¢ From the main menu, choose File = Save As and name the file
images.htm.

¢ Click Save
¢ In the Save Embedded Files dialog box, click OK:

Save Embedded Files B

Embedded files to save: Picture presdew:

Mame I Folder | Ackion

L Jiozz:904 o | Save

¢ From the main menu, select File > Close Site.
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Using Hyperlinks

e Using File = Open Site from the main menu, open My-Personal Web.

e Choose View = Folders from the main menu if the folder list is not already
displayed.

e Create a new page and name it SunflowerBee.htm. Open the page.

o Place the cursor at the top of the page, and press the Return button.

¢ From the main menu, choose Insert > Picture > From File and locate the

image SunflowerBee.jpg in the Images subfolder, located in your
FrontPage 2003 Foundation Work folder.

e Click Insert.

e Return to the Folder List view.

e Double<lick images.htm to open the file.

e Place the cursor anywhere below the sunflower image and from the main

menu, choose Insert = Hyperlink to open the Insert Hyperlink dialog
box.

e From the Link to bar, choose Existing File or Web Page.
¢ In the Text to display box, type SunflowerBee.htm.

e In the Look in area, select My__Personal_Web.

e Select the SunflowerBee.htm file:

Insert Hyperlink HE |
Link ko: Texk bo display: ISunFIDwerBee.htm acreenTip. .. |
=] Look in: I My_Personal_Web j | @l |j."-|
Existing File or
web Page :éj Images.htm {open) o Bookmark. .. |
CFHrlrjent 2 sunflowerBee.htm (open)
CIEr [ _derived Target Frame. .. |
I fpclass
Il _oeerlay
Il _Private
I _themes
Il Ltilenf
Il LRk
Irages a7
-_— - - _I
Address: SurflowerBes htm !
E-mail Address
oK I Cancel

¢ Click OK:
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SunflowerBee htin

e Ctrl + Click on the hyperlink text to check the link.

¢ Return to the images.htm file.

e To remove a link, highlight it and then choose Insert > Hyperlink and click
Remove Link in the resulting Edit Hy perlink dialog box.

e Click on the Undo button on the Standard toolbar to insert the hyperlink
again.

e Close the Web Site, saving all the changes.

Using E-mail Links

e Select File = Open Site from the main menu, and My-Personal_Web.

e Open the images.htm page.
o Place the cursor below the previous hyperlink, and from the main menu,
choose Insert > Hyperlink

e From the Link to bar, click E-mail Address:

L
Existing File or
\Web Page

%]
Place in This
Docurment

i

Creake Mew
Docurnent

E-mail &ddress

e In the Text/to display field, type /Mail Me.
o Impthe Emalil address field; type flower s@XxxxXx<-c0m
¢ In the Subjectfield, type Flowers:
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Inzert Hyperlink [ 7] |
Link ko: Text ba display: IMaiI Me ScreenTip. .. |
E E-mail address:
Existing File: or Imailtn:FInwers@xxxx.cnm
web Page
Subject:
= Flowers
61 |

Place in This  Recently used e-mail addresses:

Documnenkt IE[ Parameters. .. |
& Skyle. .. |

Creake Mew
Docurnent

d
K I Cancel

E-mail Address

e Click OK.
e Click on the Save button on the Standard toolbar.

e To view the results of the email hyperlink, click the Preview in Microsoft
Internet Explorer button on the Standard toolbar:

- v 9 -

Presity in Microsoft Internet Explorer 6.D|

¢ Close the Web Site.

Using Other Links

e Using File = Open Site from the main menu, open My-Personal _Web.
e "Open the file/SunflowerBee.htm in the Folder List.
e Select the small bee image and click Hy perlink from the Insert menu:

¢ From the Link to bar, choose Existing File or Web Page.
e In the Look in area, select My_Personal_Web.

o Select the index.htm file.

e Click OK.
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Now we will create a hyperlink using only a small portion of an image.
Place your cursor next to the bee image, and press the Return button.

From the main menu, choose Insert > Picture > From File and locate the
image Butterfly_small.jpg the Images subfolder, located in your
FrontPage 2003 Foundation Work folder. Click Insert.

Select the butterfly image to display the Pictures toolbar. If the toolbar is
not displayed, from the main menu, select View > Toolbars > Pictures.

Click the Circular Hotspot button on the toolbar:

ok | = Ch O | 42 Sh dh S | T Q@ osat el
&% & O @ @D%E‘a *3

Circular H-:utspu:ut

Select an area within the image and when you release the mouse button, the
Insert Hyperlink dialog box will automatically be displayed:

F..‘__.._. ™
Insert Hyperlink

Link ko Texk to display: F

Look in: IE

Fizkinn Fil= mr

Link to the file index.htm in the Folder List.

Click OK.

Close\ the Pictures toolbar.

To check your link, move the cursor over the "hotspot" and press Cril +
Click. The'linked file will open.

Save the file:

Switch back to the SunflowerBee.htm file.

Place the cursor a couple of rows below the butterfly image, and from the
main menu, choose Insert > Picture = From File.

From the main menu, choose Insert > Picture > From File and locate the
image Roses.jpg in the Images subfolder, located in your FrontPage 2003
Foundation Work folder.

Click Insert.

Place the cursor just above the bee image and type "Roses":
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Eozes

¢ Now place the cursor a line above the Roses,jpg, and from the main menu,
choose Insert = Bookmark.

¢ Name the bookmark "Roses" and click OK:

Bookmark EHE3 |

Bookmark name:

IFU:uses

Cther bookmarks on this page:

0]
e IAS
elect the "Roses" > page.

e From the main menu, select Insert > Hyperlink.

e Click the Place in This Document tab, and select the Roses bookmark from
the list displayed in the dialog box:

Zlear

il

(e o]

Cancel |
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Edit Hyperlink

iC]

= Bu_:u:ukmarks

Roses

e Click OK.
e To view the result, Ctrl + Click the "Roses" text.
e Save and close the Site.

SAMPLE
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Tables and Cells

Working with Tables

Open My_Personal_Web.
Create a new page and name it tables.htm, and open it.
From the Table menu, choose Insert > Table:

Table | Data  Frames  window

}:Z Layouk Tables and Cells. ..
iZell Formatting...
Erﬁ Draw Table
[ ween ] q
B Delete Cells Fows of Columns. ..
Select 3 Zell
B rerge Cells Zaption

¢ In the Insert Table dialog box, observe the default options, and create a
table with 5 rows and 2 columns.
e Click OK:

SAMPLE
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Inzert Table

CE—-

ookt
I

E0 I piels:

(1 In percent

I e
(L] B L= (LR | =

mn and row lines;
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1
-

Place the cursor in the table and from the Table menu, choose Insert >
Rows or Columns.

Observe the default options in the displayed Insert Rows or Columns
dialog box and click OK:

Inzert Rows or Columns |
{* Rows " Columns
Murmber af rows: |1 =

=l
Location:

" above selection

e Below selection

Ik I Cancel

Note an additional row has been added to the table.
Select the table, and from the Table menu, choose Table Properties >
Table:

Tahle

Insert 3

In the Table Properties dialog box, select "'yellow" as the background
colour for the table:

Background

Calor: ||I /] _v*
[™ Use background picture
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e Click Apply, and OK:

e Save the file.
¢ From the main menu, choose File > Close Site.

Working with Cells

e Open My_Personal_Web.

e Open tables.htm in the Folder List.

e Place the cursor in the top left cell of the table.

e From the Table menu, choose Split Cells to open the Split Cells dialog box:

S plit Cells B

&+ Split inte columns l_l_

" sSplit inta rows

Mumnber of columns: IZ j

| Ik I Zancel |

e “Inthe Split Cells dialog box, split the cell into"2'columns.
o Click"OK.
e The top left cell of the table is now split into_two separate cells:

e Select the two cells in the second row of the table.
e From the Table menu, choose Merge Cells.
e The cell now spans across the table:
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e Select the second row in the table.
e From the Table menu, choose Table Properties = Cell.
¢ Change the Background Color to "Green':

Cell Properties E |
Layauk

Hotizontal alignment: m [ specify width:
Wertical alignment IDeFauIt vI IU € In pixels

In pErzEnk:

Rows spanned; |1 ﬁ [ Specify height:
Columns spanned: |3 ﬁ IIZI € I pixels

= I percent
[ Header cell

[ Mowrap

Borders

Color: I j Light border: ||:| Bukorakic j
Dark border: ||:| Bkarakic j

Background
Color: | — |
[ Use background picture

I Erowse, .. | F'ru:-perties...l

Skwle, .. | (0] 4 I Cancel | apply |

e Click Apply, and then click OK.
o __Observe the colour change, in the table cell:

e Save the file.
¢ From the main menu, choose File = Close Site.
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Productivity

Working with Web Pages

¢ Open My_Personal_ Web.
o Open the SunflowerBee.htm file in the Folder List.
e Place the cursor to the right of the roses image.

¢ Open the Word document Text.doc in your FrontPage 2003 Foundation
Samples folder.

e Copy and Paste the text into the SunflowerBee.htm page at the cursor
position.

e Select the roses image, and right-click and select Picture Properties to
open the Picture Properties dialog box.

e Click on the Appearance tab. Choose the Left Wrapping style, and
change the Horizontal and Vertical spacing to 10:

Picture Properties |

Appearance | General | video |

Wrapping stwvle
Mone Left Right
Lawauk

Alignment: ILEHI - I Horizonkal spacing: |1EI j
Border thickness: IIII j Wertical spacing: |1IZI j

Size
W Specify size width: [57 :I Height: [23 :I
% in pixels % in pixels
in percent in percent

e Click OK.

o Observe the text now wraps to the right and below the image.

e Click Save

¢ Open the index.htm file from the Folder List.

e In Design view, choose Insert > Navigation from the main menu to open
the Insert Web Component dialog box.

e Select Link Bars in the Component type list, and in the Choose a bar
type, select Bar with custom links:
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Inzert Web Component [ 7]

Compaonent bype: Choose a bar bype:

fgﬁa Dwvnamic Effects P B o] Bar with custom links
lﬁ Web Search s Bar with back and next links

% Spreadsheets and charts Bar based on nawvigation skruckure
Hit Counker

Phata Gallersy:

% Included Content
[E=q]

Table of Contents
Top 10 List

List: Wiew x| d

Inserk a bar of hyperlinks that point to pages within this web site a5 well as outside it, A separate
button will be displaved For each hyperlink,

Find components

an the web Cancel | = Back I Mext = I Firish

A

e Click Next. The Choose a bar style window opens:

Inzert Web Component H

Choose a bar style:

Use Page's Theme

Hone R

SAMPL

Find components
Einish |

an khe weh Cancel < Back
P

o Scroll through the samples, choose Afternoon, and click Next:
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Inzert Web Component
Choose a bar style:
OSEFage s e J
s
=
L o
MK mEEE %
Afternoon ;I
& graphical stvle based on the 'Afternoon’ theme.
Find components
e i wrls Cancel | < Back. I Mext = I Einish
P

e Choose the horizontal orientation and click Finish.
¢ In the Create New Link Bar dialog box, type New Link Bar for a name.
Click OK:

Create New Link Bar |

] ﬂ Cancel

e The Link Bar Properties dialog box will now be displayed:
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Link Bar Properties |

General | Skyle I

hoose existing:

EECTCE I |  creotenew... |

Links:

bukkerFly, hkm add link. .. | Additional links:
Fu:urn;iatting.htmh ™ Home page
= Bee, bt )
t:&;mﬁ:ﬂ =e Remnove link | [ Parent page
Maodify link. .. |
[Mave ug |

Mave down |

Ik I Cancel

¢ Click Add Link, and click on the Existing File or Web Page tab in the Add
to Link Bar dialog box.
e Select the aboutme.htm file in the Folder List, and click OK:

Add to Link Bar EE|
Link ko: Texk ko display: Ial:n:-utme.htm
=] Look in: IEI My_Personal_Web j | @l ﬁrl
Exisking File ar _
Weh Page | _private -
Current ) Images

Folder

g | gimnages_files

wﬁﬂ_‘is 4 photogallery
D ] #&=1 aboutme.htm
: 2 Favarite. hkm

4 Feedback. htm
4 Formatking Ak

2 images.htm
“)indes:. hkm

=
Address; Ial:u:uutme.htm ;I

(0] 4 I Cancel

o Repeat the above steps to select all of the .htm files in the Web Site.
e Click OK.
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e The Link Bar in your selected colour and style will be displayed on the page.
e Move the cursor two or three rows below the Link Bar.
e Drag the image Sunflower.jpg from the Folder List onto the page.

e Select the image, and from the main menu, choose Tools > Auto
Thumbnail.

o The selected image will now be resized to a thumbnail.
e Save, saving imbedded files, and close Site.

SAMPLE
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Publishing

Publishing a Site

¢ Open My_Personal_ Web.
e Open index.htm.
¢ From the File menu, choose Preview in Browser:

 Eie |
1 Tew..

ChrlH-D

W
=

N
=
]
i
T

Save Chrl+3
Save As...

Save Al

Ew L

File Search. ..
F‘gi:nlish Site, . ..
Import...
Export...

Prewview in Browser  k

Page Setup...

1 Microsoft Inkernet Explorer 6.0 F1z

-
i

gl & Microsoft Inkernet Explorer 6.0 (640 x 4500

p k Preview Q 3 Microsoft Inkernet Explorer 6.0 (300 x 6000
= Lo’

4 Microsoft Internet Explorer 6,0 (1024 x 76&)
= Send... Edit Browser List,,,

o__ln the Preview,in Browser sub-menu, selectyour preferred browset.

e Your web browser will open and display the page as it would appear on the
Web.

¢ “Close the browser window.

¢ From the Miew 'menu, choose Reports =|Site Summany.

o ThesSite/Summary window opens, listing the types of reports available:

FOR USE AT THE LICENSED SITE(S) ONLY
© Cheltenham Courseware Ltd. 1995-2010 www.cheltenhamcourseware.com



PAGE 46 - FRONTPAGE 2003 - FOUNDATION LEV EL WORKBOOK

1
Pictures 0 OKE  Picture files in the current \Web site (GIF, JPG, BMP, etc,)
g}, Unlirked Files 1] OKB  Files in the current Web site that cannot be reached by s,
% Linked files 1 7KB  Files in the current Web site that can be reached by start,
EE—} Sloww pages 0 OKE Pages in the current Web site exceeding an estimated do,
% Clder files 1] OKE  Files in the current Web site that have not been modified |
% Recently added f... 1 7KB  Files in the current Web site that have been created in th,

7

% Hypeslinks All byperlinks in the current Web site
? Unvg jed bvperl. .. 4 Hyperlinks pointing ko unconfirmed targek files

&% BrokgClick on this item ko see the "Hyperlinks” report brlinks pointing to unavailable target files

@ External hyperlinks 4 Hyperlinks pointing ko files outside of the current Web site
% Inkernal bypetlinks Hypetlinks poinking to other files within the current Web sit
{D Component errors Files in the current Wweb site with components reporting a,
ﬁ Uncormpleted basks Tasks in the current Web sike that are not yet marked co.,
" Unused themes Themes in the current Web site that are not applied to an.
% Skyvle Sheet Links All Style Sheet Links in the current web site,

Crynamic Web Te, .. Al Files that are associaked with a Dynamic Web Template,

Lo Y e Y o Y s Y e 3

e Click on each file in the left column to explore the reports.

e A zero (“0”) in the Count column next to a report indicates that there is no
report available.

¢ From the main menu, choose File = Publish Site:

[ Eie |
] Hew...

]

L Dpen... ChrlO

:: QOpen Site...

Close Site

L Publish Site. ..
Properties. ..
Recent Sites 3
Exit

£

o The Remote Web Site Properties dialog box opens.
¢ Select the Remote Web Site tab, and specify the Remote Web site
location (check with your instructor):
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Remote Web Site Properties EHE |

Remote et Site | optimize HTML | Publishing |

Remote Web server bype:
+ FrontPage or SharePoinkt Services
The Remoke ‘Web server supports FrontPage Server Extensions or SharePoink Services.
" wehDAY
The Remote \Web server supports Distributed Authoring and Yersioning.
" FTP
The Remoke ‘Web server supports File Transfer Protocal, [,\}
" File System
se a folder on wour computer or on a network as the Remote Web site,
Remote \Web site location;

I j Browse, .. |

[ Encrypted connection required {551

If wou dao nok have a Web hosting service, find one that supports the FrontPage Server
Extensions or SharePoint Services by using the \Web Presence Provider search page.

Click here to learn mare.

(04 I Cancel |

o Select the Publishing tab, and choose the type of items to be published to
the remote server:

Remote Web Site Properties HE |

e Click OK.

o Specify the pages to be published and then click OK.
e Save and close the Web Site.

Remote Web Site | Optimize HTML  Publishing |

Genetal
Publish:
i Changed pages only

{~ Al pages, overwriting pages already on destination

Wiew log File |
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