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Working with the Northwind Sample Database 
 
When you have completed this learning module you will have seen how to: 

 Check for Northwind 
 Install Northwind 
 
 

Installing the Northwind Database 
 

About Northwind 
 Northwind is a sample database that is supplied with Access 2002.  It contains 

product and sales data for the fictitious company Northwind Traders. 
 
It is recommended that Northwind be installed in order to follow the 
lessons in this manual. 

 

Checking for Northwind 
 Click the Search button on the database toolbar: 

 

 
 

 In the Search text box, type Northwind. 
 Click Search. 
 If Northwind.mdb appears in the Search Results, click on the file to open it 

and proceed to the next chapter. 
 If Northwind is not found in the Search Results it will need to be installed. 
 

Installing Northwind 
 Insert the Microsoft Office XP CD-ROM in the CD-ROM drive. 
 Double-click Setup. 

 
Note:  If your computer has autorun enabled, you will be presented directly 
with the Microsoft Office XP setup screen. 
 

 Select Add or Remove Features. 
 Click Next. 
 Under Features to Install, select the Microsoft Access for Windows subtree. 
 Under Sample Databases, select Run all from My Computer: 
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 Click Update. 
 Once the installer completes, click OK to finish. 

 
Note:  Once the Northwind database is installed, search for it again and open 
it. 

 
 

Review Questions 
 
How would you: 

 Check for Northwind? 
 Install Northwind? 
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Introducing Structured Query Language 
 
When you have completed this learning module you will have seen how to: 

 Understand SQL Statements 
 Understand SQL Conventions 
 Understand SQL Syntax 
 Use SELECT Statement 
 Select All Data 
 Select Specific Data 
 Select Conditional Data 
 Use ORDER BY Statement 
 Sort Data 
 Use Aggregate Functions 
 Calculate Data 
 Use GROUP BY Statement 
 Group Data 
 Create a Subquery with Equality 
 Create a Subquery with an Aggregate Function 
 Use ANY and ALL Statements 
 Understand SQL Joins 
 Create a Simple Join 
 Sort a Join 
 Create Outer Join 
 Create Left Outer Join 
 Create Right Outer Join 
 Create Full Outer Join 
 Use INSERT Statement 
 Understand INSERT Statement Rules 
 Insert Data using VALUES 
 Insert Data using Defaults 
 Insert Data using SELECT 
 Use UPDATE Statement 
 Update All Rows 
 Update Specific Rows 
 Update Multiple Columns 
 Use DELETE FROM Statement 
 Delete Specific Rows 
 Delete All Rows 
 View SQL in Access 2002 
 Understand SQL in Access 2002 
 Write SQL Specific Queries 
 Find Help on SQL Queries 
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Writing SQL Commands 
 

Structured Query Language (SQL) Bases 
 Structured Query Language is called SQL for short. 
 SQL consists of standard English words. 
 Like all programming languages, SQL has specific conventions and grammatical 

syntax. 
 SQL can be used by a range of users including Database Administrators, 

management personnel, application programmers and other types of end users. 
 

Understanding SQL Statements 
 SQL statement consists of reserved words and user-defined words: 

 
Reserved words are a fixed part of SQL and must be spelt exactly as required 
and cannot be split across lines. 
 
User-defined words are created by the user and represent names of various 
database objects such as relations, columns, views, etc. 

 

Understanding SQL Conventions 
 SQL is more readable if indentation and lineation are used: 
 Each clause in a statement should begin on a new line. 
 Start of a clause should line up with start of other clauses. 
 If clause has several parts, they should each appear on a separate line and be 

indented under the start of clause. 
 Upper case letters represent SQL reserved words. 
 Lower case letters represent user-defined words. 
 A vertical bar ( | ) indicates a choice among alternatives. 
 Curly braces ( { } ) indicate a required element. 
 Square brackets ( [ ] ) indicate an optional element. 
 An ellipsis ( … ) indicates optional repetition (0 or more times). 
 

Understanding SQL Syntax 
 The main elements in SQL are the statements and clauses that makeup 

statements. 
 SELECT command indicates which fields are included in the query result. 
 FROM clause indicated what table(s) the fields are retrieved from. 
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 The following is the syntax of the SELECT statement: 
 
SELECT  { * | [column_name] [, …] } 
FROM  table_name 

 
 

Writing SQL Queries 
 

Using SELECT Statement 
 Data is selected using the SELECT statement. 
 Order of the clauses cannot be changed. 

 
SELECT  [predicate] { * | [column_name] [, …] } 
FROM  table_name 
[WHERE  condition] 
[GROUP BY column_name] 
[HAVING  group_condition] 
[ORDER BY column_name] ; 

 

 SELECT command specifies which columns are to appear in the output. 
 FROM clause specifies table or tables to be used. 
 WHERE clause filters rows subject to some conditions. 
 GROUP BY clause forms groups of rows with same column value. 
 HAVING clause specifies conditions the grouped records must meet to be 

displayed. 
 ORDER BY clause specifies the order of the output. 
 Semicolon ; ends the SQL statement. 
 

 Predicate is optional, and it restricts the number of results returned. 
 There are four predicates: 

ALL   includes all records. 
DISTINCT   omits duplicate data in selected fields. 
DISTINCTROW  omits data based on entire duplicate records. 
TOPn [PERCENT] limits the records to a number or percentage of records. 

 

 Only SELECT and FROM are mandatory. 
 Use * as an abbreviation for ‘all columns’. 
 

Selecting All Data 
 Example 1:  Retrieve All Columns, All Rows 

(list full details of all staff) 
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SELECT sno, fname, lname, position, salary 
FROM staff; 
 

 Example 2:  Retrieve All data 
(list full details of all staff) 
 
SELECT * 
FROM  staff; 
 
The result table in either case is: 
sno fname lname position bno salary 
SL21 John White Manager B5 30000.00 
SG37 Ann Beech Snr Asst B3 12000.00 
SG14 David Ford Deputy B3 18000.00 
SA9 Mary How e Assistant B7 9000.00 
SG5 Susan Brand Manager B3 24000.00 
SL41 Julie  Lee Assistant B5 9000.00 

 
 

Selecting Specific Data 
 Example 3:  Retrieve Specific Columns, All Rows 

(produce a list of salaries for all staff, showing only the staff number, sno, the 
first and last names, and the salary details). 
 
SELECT sno, fname, lname, salary 
FROM staff; 
 
The result table is: 
sno fname lname salary 
SL21 John White 30000.00 
SG37 Ann Beech 12000.00 
SG14 David Ford 18000.00 
SA9 Mary How e 9000.00 
SG5 Susan Brand 24000.00 
SL41 Julie  Lee 9000.00 

 

 Example 4:  Calculated Fields 
(produce a list of monthly salaries for all staff, showing the staff number, the 
first and last names, and the salary details). 
 
SELECT sno, fname, lname, salary/12 
 
FROM staff; 
 
The result table is: 
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sno fname lname col4 
SL21 John White 2500.00 
SG37 Ann Beech 1000.00 
SG14 David Ford 1500.00 
SA9 Mary How e 750.00 
SG5 Susan Brand 2000.00 
SL41 Julie  Lee 750.00 

 

 Example 5:  Named Calculated Fields 
In the example above, the 4th column is labeled col4.  To name this column use 
AS clause: 
 
SELECT sno, fname, lname, salary/12 AS monthly_salary 
FROM staff; 
 
The result table is: 
sno fname lname monthly_salary 
SL21 John White 2500.00 
SG37 Ann Beech 1000.00 
SG14 David Ford 1500.00 
SA9 Mary How e 750.00 
SG5 Susan Brand 2000.00 
SL41 Julie  Lee 750.00 

 
 

Selecting Conditional Data 
 Example 6:  Comparison Search Condition 

(list all staff with a salary greater than 10000.00) 
 
SELECT sno, fname, lname, position, salary 
FROM staff 
WHERE salary > 10000; 
 
The result table is: 
sno fname lname position salary 
SL21 John White Manager 30000.00 
SG37 Ann Beech Snr Asst 12000.00 
SG14 David Ford Deputy 18000.00 
SG5 Susan Brand Manager 24000.00 

 

 Example 7:  Compound Comparison Search Condition (AND / OR) 
(list all staff with the position of Manager or Assistant) 
 
SELECT sno, fname, lname, position 
FROM staff 
WHERE position = ‘Manager’ OR position = ‘Assistant’; 
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The result table is: 
sno fname lname position 
SL21 John White Manager 
SA9 Mary How e Assistant 
SG5 Susan Brand Manager 
SL41 Julie  Lee Assistant 

 

 Example 8:  Pattern Match Search Condition (LIKE / NOT LIKE) 
(list all staff with any assistant position, looking for string ‘Ass’ in their position) 
 
SELECT sno, fname, lname, position, salary 
FROM staff 
WHERE position LIKE ‘%Ass%’; 
 
The result table is: 
sno fname lname position salary 
SG37 Ann Beech Snr Asst 12000.00 
SA9 Mary How e Assistant 9000.00 
SL41 Julie  Lee Assistant 9000.00 

 

 Note:  SQL has two special pattern matching symbols: 
% percent represents any sequence of zero or more characters. 
_ underscore character represents any single character. 

 

Using ORDER BY Statement 
 Data is sorted using the ORDER BY statement. 
 Data is sorted in Ascending order by default. 
 To sort data in Descending order, use DESC clause. 
 

Sorting Data 
 Example 9:  Single Column Ordering 

(list salaries for all staff, arranged in descending order of salary). 
 
SELECT  sno, fname, lname, salary 
FROM  staff 
ORDER BY salary DESC; 
 
The result table is: 
sno fname lname salary 
SL21 John White 30000.00 
SG5 Susan Brand 24000.00 
SG14 David Ford 18000.00 
SG37 Ann Beech 12000.00 
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SA9 Mary How e 9000.00 
SL41 Julie  Lee 9000.00 

 

 Example 10:  Multiple Column Ordering 
(list of all staff, arranged in ascending order of last name and position). 
 
SELECT  sno, fname, lname, position 
FROM  staff 
ORDER BY lname, position; 
 
The result table is: 
sno fname lname position 
SG37 Ann Beech Snr Asst 
SG5 Susan Brand Manager 
SG14 David Ford Deputy 
SA9 Mary How e Assistant 
SL41 Julie  Lee Assistant 
SL21 John White Manager 

 

Using Aggregate Functions 
 
There are five aggregate functions: 

 COUNT returns the number of values in a specified column. 
 SUM returns the sum of the values in a specified column. 
 AVG returns the average of the values in a specified column. 
 MIN returns the smallest value in a specified column. 
 MAX returns the largest value in a specified column. 
 

 Each function operates on a single column of a table and return single value. 
 COUNT, MIN and MAX apply to numeric and non-numeric fields. 
 SUM and AVG apply to numeric fields only. 
 COUNT(*) is a special use of COUNT that counts all rows of a table. 
 

Calculating Data 
 Example 11:  Use of COUNT(*) 

(find the total number of staff that have salary of 9000). 
 
SELECT COUNT(*) AS count 
FROM staff 
WHERE salary = 9000; 
 
The result table is: 
count 
2 
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 Example 12:  Use of COUNT and SUM 
(find the total number of Managers and the sum of their salaries). 
 
SELECT COUNT(sno) AS count, SUM(salary) AS sum 
FROM staff 
WHERE position = ‘Manager’; 
 
The result table is: 
count sum 
2 54000.00 

 

 Example 13:  Use of MIN, MAX, AVG 
(find the minimum, maximum and average staff salary). 
 
SELECT MIN(salary) AS min, MAX(salary) AS max, AVG(salary) AS avg 
FROM staff; 
 
The result table is: 
min max avg 
9000.00 30000.00 17000.00 

 

Using GROUP BY Statement 
 Data is grouped using the GROUP BY statement. 
 Each item in SELECT list must be single-valued per group. 
 All column names in SELECT list must appear in GROUP BY clause, unless the 

name is used only in an aggregate function. 
 

Grouping Data 
 Example 14:  Use of GROUP BY 

(find number of staff in each branch and their total salaries). 
 
SELECT  bno, COUNT(sno), AS count, SUM(salary) AS sum 
FROM  staff 
GROUP BY bno 
ORDER BY bno; 
 
The result table is: 
bno count sum 
B3 3 54000.00 
B5 2 39000.00 
B7 1 9000.00 

 
 

SAMPLE



Page 17 – Microsoft Access XP - Advanced Level Manual 

FOR USE AT THE LICENSED SITE(S) ONLY 
 Cheltenham Courseware Ltd. 1995-2010 www.cheltenhamcourseware.com 

Writing SQL Subqueries 
 

 Some SQL statements can have a SELECT embedded within them. 
 A subselect can be used in the WHERE clause of an outer SELECT, where it is 

called a Subquery or Nested query. 
 

Creating a Subquery with Equality 
 Example 15:  Use of Subquery with Equality 

(list the staff who work in the branch at ‘163 Main St’). 
 
SELECT sno, fname, lname, position 
FROM staff 
WHERE bno = 
  (SELECT bno 
  FROM branch 
  WHERE street = ‘163 Main St’); 
 
Note:  Inner SELECT finds branch number corresponding to branch at ‘163 Main 
St’ which is (‘B3’).  Outer SELECT then retrieves details of all staff who work at 
this branch.  The outer SELECT then becomes: 
 
SELECT sno, fname, lname, position 
FROM staff 
WHERE bno = ‘B3’; 
 
The result table is: 
sno fname lname position 
SG37 Ann Beech Snr Asst 
SG14 David Ford Deputy 
SL21 John White Manager 

 

Creating a Subquery with an Aggregate Function 
 Example 16:  Use of Subquery with Aggregate Function 

(list all staff whose salary is greater than the average salary). 
 
SELECT sno, fname, lname, position, salary 
FROM staff 
WHERE salary > 
  (SELECT AVG(salary) 
  FROM staff); 

 

 Note:  You cannot write ‘WHERE salary > AVG(salary)’.  Instead, you can use 
Subquery to find the average salary (17000), and then use outer SELECT to find 
those staff members with a salary greater than this: 

SAMPLE
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SELECT sno, fname, lname, position, salary 
FROM staff 
WHERE salary > 17000; 
 
The result table is: 
sno fname lname position salary 
SL21 John White Manager 30000.00 
SG14 David Ford Deputy 18000.00 
SG5 Susan Brand Manager 24000.00 

 

Using ANY and ALL Statements 
 ANY and ALL may be used with subqueries that produce a single column of 

numbers. 
 If Subquery is preceded by ALL, the condition will only be true if it is satisfied by 

all values produced by the Subquery. 
 If Subquery is preceded by ANY, the condition will be true if it is satisfied by any 

values produced by the Subquery. 
 

 Example 17:  Use of ANY 
(find staff whose salary is larger than the salary of at least 1 member of the 
staff at branch B3). 
 
SELECT sno, fname, lname, position, salary 
FROM staff 
WHERE salary > ANY 
  (SELECT salary 
  FROM staff 
  WHERE bno = ‘B3’); 
 

 Note:  Inner SELECT produces the set {12000, 18000, 24000} and outer 
SELECT lists those staff whose salaries are greater than any of the values in this 
set. 
 
The result table is: 
sno fname lname position salary 
SL21 John White Manager 30000.00 
SG14 David Ford Deputy 18000.00 
SG5 Susan Brand Manager 24000.00 

 

 Example 18:  Use of ALL 
(find staff whose salary is larger than the salary of every member of the staff at 
branch B3). 
 
SELECT sno, fname, lname, position, salary 
FROM staff 

SAMPLE
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WHERE salary > ALL 
  (SELECT salary 
  FROM staff 
  WHERE bno = ‘B3’); 
 
The result table is: 
sno fname lname position salary 
SL21 John White Manager 30000.00 

 
 

Writing SQL Joins 
 

Understanding SQL Joins 
 In the previous examples, subqueries have provided results from the same 

table. 
 If result columns come from more than one table, we must use a join. 
 To perform a join, you must include more than one table in the FROM clause, 

using a comma as a separator and typically including a WHERE clause to specify 
join column(s). 

 It is also possible to use an alias for a table, named in the FROM clause.  An 
alias is separated from the table name with a space. 

 

Creating a Simple Join 
 Example 19:  Use of Simple Join 

(list names of all renters who have viewed a property). 
 
SELECT r.mo, fname, lname, pno 
FROM renter r, viewing v 
WHERE r.mo = v.mo; 

 

 Note:  To obtain correct rows, include only those rows from both tables that 
have identical values in the rno columns: r.mo = v.mo.  These two columns are 
the matching columns for two tables. 
 
The result table is: 
mo fname lname pno 
CR56 Aline Stew art PG36 
CR56 Aline Stew art PA14 
CR56 Aline Stew art PG4 
CR62 Mary Tregear PA14 
CR76 John Kay PG4 

 

SAMPLE
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Sorting a Join 
 Example 20:  Sort a Join 

(for each branch, list names of staff who manage properties). 
 
SELECT  s.bno, s.sno, fname, lname, pno 
FROM  staff s, property_for_rent p 
WHERE  s.sno = p.sno 
ORDER BY s.bno, s.sno, pno; 
 
The result table is: 
bno sno fname lname pno 
B3 SG14 David Ford PG4 
B3 SG14 David Ford PG16 
B3 SG37 Ann Beech PG21 
B3 SG37 Ann Beech PG36 
B5 SL41 Julie Lee PL94 
B7 SA9 Mary How e PA14 

 
 

Creating Outer Joins 
 With an inner join, if one row of a table is unmatched, the row is omitted from 

the result table. 
 Outer join retains rows that do not satisfy the join condition. 
 Consider the following two simplified tables: 
 

BRA NCH1 
bno bcity 
B3 Glasgow  
B4 Bristol 
B2 London 

 
PROPERTY_FOR_RENT1 

pno pcity 
PA14 Aberdeen 
PL94 London 
PG4 Glasgow  

 

 Example 21:  The INNER JOIN of these two tables 
 
SELECT b.*, p.* 
FROM branch1 b, property_for_rent1 p 
WHERE b.bcity = p.pcity; 
 
OR 
 
SELECT b.*, p.* 

SAMPLE
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FROM branch1 b INNER JOIN property_for_rent1 p 
ON  b.bcity = p.pcity; 
 
The result table is: 
bno bcity pno pcity 
B3 Glasgow  PG4 Glasgow  
B2 London PL94 London 

 

 Note:  The result table has two rows where the cities are the same.  There are 
no rows corresponding to the branches in Bristol and Aberdeen. 

 

Creating Left Outer Joins 
 Example 22:  Left Outer Join 

(list branches and properties that are in the same city along with any 
unmatched branches). 
 
SELECT b.*, p.* 
FROM branch1 b LEFT JOIN property_for_rent1 p 
ON  b.bcity = p.pcity; 
 
The result table is: 
bno bcity pno pcity 
B3 Glasgow  PG4 Glasgow  
B4 Bristol NULL NULL 
B2 London PL94 London 

 

 Note:  Left outer join includes those rows of first (left) table that are unmatched 
with rows from second (right) table.  Columns from second table are filled with 
NULLs. 

 

Creating Right Outer Joins 
 Example 23:  Right Outer Join 

(list branches and properties in the same city and any unmatched properties). 
 
SELECT b.*, p.* 
FROM branch1 b RIGHT JOIN property_for_rent1 p 
ON  b.bcity = p.pcity; 
 
The result table is: 
bno bcity pno pcity 
NULL NULL PA14 Aberdeen 
B3 Glasgow  PG4 Glasgow  
B2 London PL94 London 

 

SAMPLE
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 Note:  Right outer join includes those rows of second (right) table that are 
unmatched with rows from first (left) table.  Columns from first table are filled 
with NULLs. 

 

Creating Full Outer Joins 
 Example 24:  Full Outer Join 

(list branches and properties in the same city and any unmatched branches and 
properties). 
 
SELECT b.*, p.* 
FROM branch1 b FULL JOIN property_for_rent1 p 
ON  b.bcity = p.pcity; 
 
The result table is: 
bno bcity pno pcity 
NULL NULL PA14 Aberdeen 
B3 Glasgow  PG4 Glasgow  
B4 Bristol NULL NULL 
B2 London PL94 London 

 

 Note:  Full outer join includes those rows that are unmatched in both tables.  
Unmatched columns are filled with NULLs. 

 
 

Inserting Data 
 

Using INSERT Statement 
 Data is inserted in the table using the INSERT statement. 

 
INSERT INTO table_name [ (column_list) ] 
 
VALUES  (data_value_list); 

 

 Column_list is optional. 
 If omitted, SQL assumes a list of all columns in their original order. 
 Any columns omitted must be declared as NULL when the table is created, 

unless DEFAULT is specified when creating the column. 
 

Understanding INSERT Statement Rules 
Data_value_list must match column_list as follow s: 

 Number of items in each list must be the same. 
 Order of items must correspond directly to the position of items in two lists. 

SAMPLE
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 Data type of each item in data_value_list must be compatible with data type 
of the corresponding column. 

 

Inserting Data using VALUES 
 Example 25:  INSERT … VALUES 

(insert a new record into staff table supplying data for all columns). 
 
INSERT INTO staff 
VALUES  (‘SG16’, ‘Alan’, ‘Brown’, ‘Assistant’, ‘B3’, 8300); 

 

Inserting Data using Defaults 
 Example 26:  INSERT using Defaults 

(insert a new record into staff table supplying data for all mandatory columns). 
 
INSERT INTO staff (sno, fname, lname, position, bno 
VALUES  (‘SG16’, ‘Alan’, ‘Brown’, ‘Assistant’, ‘B3’); 
 
OR 
 
INSERT INTO staff 
VALUES  (‘SG16’, ‘Alan’, ‘Brown’, ‘Assistant’, ‘B3’, NULL); 

 

Inserting Data using SELECT 
 Second form of INSERT allows multiple rows to be copied from one or more 

tables to another. 
 
INSERT INTO table_name [ (column_list) ] 
SELECT  …; 

 

 Example 27:  INSERT … SELECT 
Assume there is a table staff_prop_count that contains names of staff and the 
number of properties they manage: 
staff_prop_count(sno, fname, lname, prop_cnt). 
(populate staff_prop_count using staff and property_for_rent). 
 
INSERT INTO staff_prop_count 
(SELECT s.sno, fname, lname, COUNT(*) 
FROM staff s, property_for_rent p 
WHERE s.sno = p.sno 
GROUP BY s.sno, fname, lname); 

 
 

SAMPLE
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Updating Data 
 

Using UPDATE Statement 
 Data is updated in the table using the UPDATE statement. 

 
UPDATE table_name 
SET column_name1 = data_value1 
  [, column_name2 = data_value2 …] 
[WHERE search_condition]; 

 

 SET clause specifies names of one or more columns that are to be updated. 
 WHERE clause is optional.  If omitted, named columns are updated for all rows 

in table.  If specified, only those rows that satisfy search_condition are 
updated. 

 New data_value(s) must be compatible with the data type for the 
corresponding column. 

 

Updating All Rows 
 Example 28:  UPDATE All Rows 

(give all staff a 3% pay increase). 
 
UPDATE staff 
SET salary = salary*1.03; 

 

Updating Specific Rows 
 Example 29:  UPDATE Specific Rows 

(give all Managers a 5% pay increase). 
 
UPDATE staff 
SET salary = salary*1.05 
WHERE position = ‘Manager’; 
 
Note:  WHERE clause finds rows that contain data for Managers.  Update is 
applied only to these particular rows. 

 

Updating Multiple Columns 
 Example 30:  UPDATE Multiple Columns 

(promote David Ford (sno = ‘SG14’) to Manager and change his salary to 
18000). 
 
UPDATE staff 

SAMPLE



Page 25 – Microsoft Access XP - Advanced Level Manual 

FOR USE AT THE LICENSED SITE(S) ONLY 
 Cheltenham Courseware Ltd. 1995-2010 www.cheltenhamcourseware.com 

SET position = ‘Manager’, salary = 18000 
WHERE sno = ‘SG14’; 

 

Deleting Data 
 

Using DELETE FROM Statement 
 Data is removed from the table using the DELETE FROM statement. 
 

DELETE FROM table_name 
[WHERE  search_condition]; 

 

 Search_condition is optional.  If omitted, all rows are deleted from the table. 
 This does not delete the table. 
 If search_condition is specified, only those rows that satisfy the condition are 

deleted. 
 

Deleting Specific Rows 
 Example 31:  DELETE Specific Rows 

(delete all staff that hold a Manager position). 
 
DELETE FROM staff 
WHERE  position = ‘Manager’; 

 

Deleting All Rows 
 Example 32:  DELETE All Rows 

(delete all records from the staff table). 
 
DELETE FROM staff; 

 
 

Writing SQL Queries in Access 2002 
 

Viewing SQL in Access 2002 
 SQL is the language that Access 2002 uses to program query operations. 
 To view and/or edit SQL statements while creating a Query, switch from 

Design View to SQL View: 
 
To open the SQL View: 

 Open a Query in Design View. 
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 From the main menu, choose View > SQL View: 
 

 
 

 
To view sample SQL statement: 

 For example, open the sample Northwind.mdb database. 
 Click on the Queries button under the Objects pane of the Database window. 
 Select a query named Employee Sales by Country: 

 

 
 SAMPLE
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 Click on the Design button: 
 

 
 

 This will open the Design View for the selected query: 
 

 
 

 While in Design View, from the main menu, choose View > SQL View. 
 This will open the SQL View: 

 

 
 

 You can edit the SQL statement directly in this window. 
 

SAMPLE
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Understanding SQL in Access 2002 
 SQL statements are little different in Access that in the standard SQL. 
 Lets look at the example: 

 
SELECT  [First Name], [Last Name], Position 
FROM [Staff Data] 
WHERE Position = ‘Assistant’; 

 

 The column names that contain spaces must be enclosed in square brackets [ ]. 
 If the column name does not contain spaces, square brackets are not needed. 
 
 

Writing SQL Specific Queries 
 SQL Specific queries are queries that can be created only using SQL statements. 
 
There are three SQL Specific queries: 

 Union queries that combine corresponding fields from two or more tables into 
one field in the query results. 

 Pass-Through queries that send commands directly to ODBC databases. 
 Data Definition queries that create or edit Access tables. 
 
To write SQL Specific query: 

 Click on the New button while in the Queries page of the Database window: 
 

 
 SAMPLE
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 In the New Query dialog box, select Design View and click OK: 
 

 
 

 In the Show Table dialog box, click Close without adding any table: 
 

 
 

 From the main menu, choose Query > SQL Specific > then select the type of 
query you want to create, Union, Pass-Through or Data Definition: SAMPLE
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Finding Help on SQL Queries 
 As always, if you need more help, Access 2002 has more information on SQL 

queries. 
 From the main menu, choose Help > Microsoft Access Help: 

 

 
 
OR press the F1 key 
OR click on the Help [?] toolbar button. 

 

 In the Contents page, navigate to Queries > SQL Queries to list all subjects 
on this issue: 

SAMPLE
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Review Questions 
 
How would you: 

 Understand SQL Statements? 
 Understand SQL Conventions? 
 Understand SQL Syntax? 
 Use SELECT Statement? 
 Select All Data? 
 Select Specific Data? 
 Select Conditional Data? 
 Use ORDER BY Statement? 
 Sort Data? 
 Use Aggregate Functions? 
 Calculate Data? 
 Use GROUP BY Statement? 
 Group Data? 
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 Create a Subquery with Equality? 
 Create a Subquery with an Aggregate Function? 
 Use ANY and ALL Statements? 
 Understand SQL Joins? 
 Create a Simple Join? 
 Sort a Join? 
 Create an Outer Join? 
 Create a Left Outer Join? 
 Create a Right Outer Join? 
 Create a Full Outer Join? 
 Use INSERT Statement? 
 Understand INSERT Statement Rules? 
 Insert Data using VALUES? 
 Insert Data using Defaults? 
 Insert Data using SELECT? 
 Use UPDATE Statement? 
 Update All Rows? 
 Update Specific Rows? 
 Update Multiple Columns? 
 Use DELETE FROM Statement? 
 Delete Specific Rows? 
 Delete All Rows? 
 View SQL in Access 2002? 
 Understand SQL in Access 2002? 
 Write SQL Specific Queries? 
 Find Help on SQL Queries? 
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Working with Macros 
 
When you have completed this learning module you will have seen how to: 

 Understand Macros 
 Use the Macro Window Toolbar 
 Create New Macros 
 Run a Macro 
 Step Through a Macro 
 Modify a Macro 
 Add Conditions to Macros 
 Use the Expression Builder to Create Conditions 
 Run Macros with Conditions 
 Attach Macros to a Form 
 Attach Macros to a Report 
 Filter Records 
 Comment Macros 
 Print Macro Definitions 
 View Macro Definitions 
 
 

Automating Tasks 
 

Understanding Macros 
 Macros present a way of programming Access 2002 to perform a variety of tasks 

and actions. 
 Macros are easy to create - you simply select from the list of predefined actions 

and their arguments. 
 Each action performs a specific operation. 
 Each action can have arguments, which specify additional information for that 

action. 
 Macros are best for performing simple tasks, like opening and closing forms, 

running reports, and displaying custom toolbars. 
 Macros are individual Access objects listed in the Macros page in the Database 

window: 
SAMPLE
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 Once macros are created, you can attach them to an Event property of any 
object in your database. 

 Note:  Access macros differ from other macros in Office XP and other 
applications, because it does not record the keystrokes. 

 
There are two cases when you must use macros: 

 When assigning specific actions to a key combination to be used globally, in the 
entire database. 

 When assigning startup actions to the database, such as opening a switchboard 
form at startup. 

 
 

Introducing the Macro Window Toolbar 
 

 
 

SAMPLE
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Using the Macro Window Toolbar 
 Macro Names button adds the Macro Name column to the macro sheet: 

 

 
 
OR from the main menu, choose View > Macro Names: 
 

 
 
Macro Name column is added to the macro sheet: 
 

 
 

 

 Conditions button adds the Condition column to the macro sheet: 
 

 
 
OR from the main menu, choose View > Conditions. 
 
Condition column is added to the macro sheet: 
 

 
 

 Insert Rows button inserts one or more blank rows in the grid above the 
selected row: 
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OR from the main menu, choose Insert > Rows. 
 

 Delete Rows button deletes the selected row or rows: 
 

 
 
OR from the main menu, choose Edit > Delete Rows. 
 

 Run button runs the macro: 
 

 
 
OR from the main menu, choose Run > Run. 
 

 Single Step button runs the macro one action at a time, displaying 
intermediate information: 
 

 
 
OR from the main menu, choose Run > Single Step. 

 

Creating Macros 
 

Creating New Macros 
 While in the Macros page of the Database window, click on the New button: 

 
SAMPLE
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 The Macro window opens, displaying the blank macro sheet. 
 Under the Action column, you will see the drop-down list which contains a list of 

predefined actions for you to choose from: 
 

 
 

 The Comment column contains optional comments used for documenting 
macros. 

 Once you select an Action, the pane on the bottom area displays the associated 
Action Arguments: 

SAMPLE
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 Depending on the selected action, some arguments are required and some are 
optional. 

 For example, for the Close action, you can select an Object Type, such as 
Form: 
 

 
 

 Once the Object Type is selected, you can select an Object Name.  Access will 
list all available Forms in the current database: 

SAMPLE
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 The last argument is the Save option (required).  Here, you can select what 
type of actions Access should perform at the end: 
 

 
 

 Note:  The information pane at the bottom-right area of the Macro window 
displays information about the part of the macro sheet that is currently active.  
If you need more information, press the F1 key for help. 
 

SAMPLE
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 Close the Macro window and click Yes to save changes for your new macro: 
 

 
 

 In the Save As dialog box, enter the name in the Macro Name field, then click 
OK: 
 

 
 

 The new macro is now available in the Macros tab of the Database window: 
 

 
 
 

Testing and Debugging Macros 
 

Running a Macro 
 Once you have created a macro, you will have to run it and see if it works. 

SAMPLE
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 You can run the whole macro at once, or you can run step-by-step through the 
macro. 

 If you get an error while running a macro, make sure you run through the 
macro step-by-step to find where the error occurs, and fix it. 

 
To run a macro: 

 Select the macro name from the Macros page of the Database window. 
 Click Run button: 

 

 
 
OR double-click the macro name 
 
OR right-click the macro name and choose Run from the popup menu: 
 

 
 

SAMPLE
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Stepping Through a Macro 
 If you have received an error while running a macro, you will have to step 

through the macro in order to find the error and fix it. 
 
To use the Single Step method to run a macro: 

 Select the macro name from the Macros page of the Database window. 
 Click Design button to open the Macro window: 

 

 
 

 While in the Macro window, click on the Single Step button: 
 

 
 

 This will open the Macro Single Step dialog box: 
 

 
 

SAMPLE
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 The Step button moves to the next action, if there are more actions in the 
macro.  This is the default option. 

 The Halt button stops macro execution. 
 The Continue button stops the Single Step mode and runs the rest of the macro 

without stopping. 
 
 

Modifying Macros 
 

Modifying a Macro 
 Select the name of the macro you want to modify from the Macros page of the 

Database window. 
 Click Design button to open the Macro window. 
 Use the Insert Rows toolbar button or the Insert menu command to add 

actions. 
 Use the Delete Rows toolbar button or the Edit menu command to delete 

actions. 
 Use the Cut, Copy, and Paste operations to edit a macro. 
 Use the Undo button to reverse the recent changes. 
 When you have finished editing the macro, Save it again. 
 Run and test your newly saved macro to make sure it works properly. 
 
 

Conditional Programming in Macros 
 

Adding Conditions to Macros 
 By adding conditions to macros, you can specify if and when actions will happen. 
 Conditions mean that if the condition is true, then the action(s) will be 

performed.  If the condition is not true, the macro will skip to the next action – 
but only if there is one. SAMPLE
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 Macro conditions are added in the Condition column on the macro sheet: 
 

 
 

 By default, the condition only applies to the action on the same row in the 
macro sheet. 

 If the condition is not met, the next action (i.e. the next row) will be executed. 
 To extend the condition to the next action, you must enter the ellipsis (…) in the 

Condition column of the next row: 
 

 
 

 When debugging a macro, you can temporarily disable an action by entering 
False in the Condition column: 
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Using the Expression Builder to create Conditions 
 Right-click inside the Condition field where you want to create a condition, and 

select Build from the popup menu: 
 

 
 

 In the Expression Builder dialog box, create the logical expression (for 
example if the Total Pages number is greater than 0) and click OK: SAMPLE



Page 46 – Microsoft Access XP - Advanced Level Manual 

FOR USE AT THE LICENSED SITE(S) ONLY 
 Cheltenham Courseware Ltd. 1995-2010 www.cheltenhamcourseware.com 

 

 
 

 The new expression will be displayed in the Condition field: 
 

 
 

Running Macros with Conditions 
 When running macros with conditions, Access evaluates each condition and does 

each of the following. 
 If condition is TRUE, Access runs the action on that row first, then runs all 

following actions that have an ellipsis (…) in the Condition column.  Access then 
runs any additional actions that have blank conditions until it encounters 
another condition, comes across a macro name in the Macro Name column, or 
reaches the end of the macro. 

SAMPLE
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 If a condition is FALSE, Access ignores the action on that row and any 
subsequent actions that have an ellipsis (…) in the Condition column.  Access 
then moves to the next condition, if there is one: 
 

 
 
Note:  The MsgBox action has a condition [CurrentRecord]=0, meaning if no 
records are returned for the selected letter, display a message.  Then Access 
goes to the next action with an ellipsis (…) ShowAllRecords that will show all 
records.  Then Access continues to the next action with an ellipsis (…) SetValue 
that will press in the All button. 

 

Adding Macros to Forms 
 

Attaching Macros to a Form 
 First select the form in the Forms page of the Database window and click on 

the Design button: 
 SAMPLE
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To attach the macro to a form event: 

 From the main menu, choose Edit > Select Form 
OR press the Ctrl + R key combination. 

 The Form is selected: 
 

 
 
To attach the macro to a section of the form: 

SAMPLE
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 Click the section selector (for example, Detail section): 
 

 
 
To attach the macro to a control in the form: 

 Select the control (for example, Exit Microsoft Access button): 
 

 
 
To attach the macro to the selected form property: 

 From the main menu, choose View > Properties 
OR press the F4 key 

SAMPLE
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OR right-click on the selection and select Properties from the popup menu 
(available for section or control objects only). 

 Click the Event tab to view a list of events that can occur for the selected 
object. 

 Select the event you want to run the macro (for example, On Exit). 
 Choose the Macro name from the drop-down list of available macros (for 

example, Close): 
 

 
 

 Save and close the form design. 
 
 

Adding Macros to Reports 
 

Attaching Macros to a Report 
 Select the form in the Reports tab of the Database window and click on the 

Design button: SAMPLE
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To attach the macro to a report event: 

 From the main menu, choose Edit > Select Report 
OR press the Ctrl + R key combination. 

 The Report is selected: 
 

 
 

To attach the macro to a section of the report: 
SAMPLE
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 Click the section selector (for example, Page Header section): 
 

 
 
To attach the macro to the selected form property: 

 From the main menu, choose View > Properties 
OR press the F4 key 
OR right-click on the selection and select Properties from the popup menu 
(available for the section or control objects only). 

 Click the Event tab to view a list of events that can occur for the selected 
object. 

 Select the event you want to run the macro (for example, On Format). 
 Choose the Macro name from the drop-down list of available macros (for 

example, Sales Totals by Amount): 
 

 
 

 Save and close the report design. 
 
 

SAMPLE
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Filtering Data 
 

Filtering Records 
 The Northwind sample database contains a macro that alphabetically filters the 

records in the Customer Phone List form. 
 Open the Northwind database by selecting Help > Sample Databases > 

Northwind Sample Database from the main menu. 
 In the Main Switchboard window, click on the Display Database Window 

button: 
 

 
 

 In the Database window, click on the Macros tab, then select the Customer 
Phone List macro and click on the Design button: 

SAMPLE
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 This will open the macro sheet: 
 

 
 

 In the Comment column, you can see that this macro is attached to the 
Customer Phone List form.  In order to see how the macro works, we should run 
it first. 

 In order to run the macro, we have to open the form attached to the macro. 
 Go back to the Database window, click on the Forms tab, and select 

Customer Phone List: 

SAMPLE
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 Double-click on the form name to open it: 
 

 
 

 As you can see, the form has Alphabet buttons that will filter data when pressed.  
Only the company names that start with a specified letter of the alphabet will be 
displayed. 

 Click on the Design button to see the underlined programming for this form: 
 

SAMPLE
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 The row of Alphabetic buttons are actually an Option Group control named 
CompanyNameFilters, which returns a value depending which button is 
selected. 

 If you open the Properties for this control, you will see that the macro 
Customer Phone List.Alpha Button is attached to the After Update event.  
This means that the macro will run when the user clicks one of the buttons in 
the option group. 
 

 Go back to the Customer Phone List macro sheet to see how this is done: 
 

 
 

 The Alpha Buttons macro applies a filter to the list, based on which button is 
pressed. 

 For example, if the A button is pressed, the macro will filter for company names 
that start with  SAMPLE
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 Pressing on the A button will result in this company list: 
 

 
 

 Now go back to the Customer Phone List macro sheet and scroll down to the 
last rows.  In the GoToControl action row, the stated condition is that if the 
current record count is greater than 0, the records are displayed and the macro 
stops.  The ellipsis (…) in the StopMacro action row carries over the condition 
from the row above it: 
 

 
 

 However, if no records are returned by the filter (based on the condition if the 
current record count equal to 0), the message will be displayed in the MsgBox 
action.  When the user clicks OK to close the message window, all records are 
displayed on the screen, as the ellipsis (…) in the ShowAllRecord action row 
carries over the condition from the row above it.  Furthermore, the next action 
row containing ellipsis (…) SetValue, will press in the All button in the form: 
 

 
 
 

Documenting Macros 
 

SAMPLE
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Commenting Macros 
 To make programming and future updates easier, make sure you comment 

macros using the Comment column in the macro sheet: 
 

 
 

Printing Macro Definitions 
 In the Macros page of the Database window, select the macro name. 
 From the main menu, choose File > Print 

OR press the Ctrl + P key combination. 
 In the Print Macro Definition dialog box, select what info you want to print 

and click OK: 
 

 
 

 Properties include the container, date created, date of last update, owner, and 
user. 

 Actions and Arguments include all the actions with their conditions, as well as 
values for all arguments. 

 Permissions by User and Group include user permissions and group 
permissions. 

 

SAMPLE
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Viewing Macro Definitions 
 In the Macros page of the Database window, select the macro name. 
 From the main menu, choose File > Print Preview and make the same 

selections as for the Print: 
 

 
 
 

Review Questions 
 
How would you: 

 Understand Macros? 
 Use the Macro Window Toolbar? 
 Create New Macros? 
 Run a Macro? 
 Step Through a Macro? 
 Modify a Macro? 
 Add Conditions to Macros? 
 Use the Expression Builder to Create Conditions? 
 Run Macros with Conditions? 
 Attach Macros to a Form? 
 Attach Macros to a Report? 
 Filter Records? 
 Comment Macros? 

SAMPLE
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 Print Macro Definitions? 
 View Macro Definitions? 
 
 
 

SAMPLE
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Programming Access Using Visual Basic 
 
When you have completed this learning module you will have seen how to: 

 Use Visual Basic Modules 
 Convert Macros to Visual Basic Code 
 Understand Modules 
 Create Modules 
 Understand Module Declarations 
 Understand Procedures 
 Use Naming Rules 
 Declare Variables 
 Set Variable Scope 
 Declare Constants 
 Use Methods 
 Use Arguments 
 Customize the Visual Basic Editor Window 
 Set the Visual Basic Editor Options 
 Use Microsoft Visual Basic Help 
 Get Visual Basic Syntax Help 
 
 

Using Macros versus Visual Basic 
 

 In this manual, we will cover only the basics of Visual Basic programming 
regarding its use in Access 2002. 

 If you want to learn more about Visual Basic, refer to one of the numerous 
manuals and books on this subject. 

 

Using Visual Basic Modules 
 In the previous chapter, we have covered the use of Macros.  Another way to 

program Access is writing Visual Basic modules. 
 Certain procedures cannot be created in Macros, you must use Visual Basic to 

write them. 
 Examples of Visual Basic usages: 

- Error handling 
- Repetitive looping 
- Custom functions 
- Optimized performance, etc 

 

SAMPLE
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Converting Macros to Visual Basic Code 
 There are two methods for converting Macros to Visual Basic (VB) code: 
 Converting from the Macros page of the Database window – this is used when 

you want to make VB code available to the whole database. 
 Converting from the Form or Report Design view – this is used when you want 

to store VB code with a form or report. 
 
To convert a Macro from the Database Window: 

 Click on the Macros tab in the Database window. 
 Select a macro you want to convert to VB. 
 From the main menu, choose Tools > Macro > Convert Macros to Visual 

Basic 
 
OR from the main menu, choose File > Save As and in the Save As dialog 
box, select Module under the As filed.  Click OK to continue: 
 

 
 

 This will open up the Convert macro: macro_name dialog box: 
 

 
 

 Check the Add error handling to generated functions and Include macro 
comments options and click Convert. 

 The Convert macros to Visual Basic message box shows the conversion is 
finished. 

 This will create Converted Macro – macro_name module, listed under the 
Modules folder in the Visual Basic Editor window.  Click on the module to see 
the code: 
 

SAMPLE
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 Scroll to the end of the code window to view the whole Visual Basic code: 
 

 
 

 The Function statement represents the global module that is available to the 
entire database. 

SAMPLE



Page 64 – Microsoft Access XP - Advanced Level Manual 

FOR USE AT THE LICENSED SITE(S) ONLY 
 Cheltenham Courseware Ltd. 1995-2010 www.cheltenhamcourseware.com 

 The DoCmd statement performs macro action in a Visual Basic procedure. 
 Apostrophe (‘) marks the comment line. 

 
 Newly created module is also listed in the Modules tab of the Database window: 

 

 
 
To convert Form’s Macro from the Design View: 

 Click on the Forms tab in the Database window. 
 Select a form whose macro you want to convert to VB. 
 Click on the Design view button. 
 From the main menu, choose Tools > Macro > Convert Form’s Macros to 

Visual Basic. 
 This will open up the Convert form macros: macro_name dialog box: 

 

 
 

 Uncheck Add error handling to generated functions and check Include 
macro comments options and click Convert. 

 The Convert macros to Visual Basic message box shows the conversion is 
finished. 

 

 Click on the Code toolbar button to open the Visual Basic Editor window with 
the converted macros code: 
 

SAMPLE
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 Scroll to the end of the code window to view the whole Visual Basic code: 
 

 
 

 The Sub statement represents the local code, stored with a form. 
 The DoCmd statement performs macro action in a Visual Basic procedure. 
 The Apostrophe (‘) marks the comment line. 
 
To convert Report’s Macro from the Design View: 

SAMPLE
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 Click on the Reports tab in the Database window. 
 Select a report whose macro you want to convert to VB. 
 Click on the Design view button. 
 From the main menu, choose Tools > Macro > Convert Report’s Macros to 

Visual Basic. 
 This will open up the Convert report macros: macro_name dialog box: 

 

 
 

 Uncheck Add error handling to generated functions and check the Include 
macro comments option and click Convert. 

 The Convert macros to Visual Basic message box shows the conversion is 
finished. 

 
 

Understanding Visual Basic Concepts 
 

Understanding Modules 
 The Visual Basic module consists of declarations and procedures. 
 Modules are used to create event procedures that execute when an event 

occurs. 
 

 There are two types of modules: 
1. Module objects listed in the Modules page of the Database window. 
2. Form and Report modules stored together with a form or report containing 
procedures and functions associated with a single form or report. 

 

Creating Modules 
 Click on the Modules tab in the Database window. SAMPLE
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 Click on the New button: 
 

 
 The new module, named Module1, opens up in the Visual Basic Editor 

window: 
 

 
 

 A newly created module has two or more sections: 
Declarations section 
Procedure section(s) 
 

 If you do not see the Option Explicit declaration, choose Tools > Options 
from the Visual Basic Editor window main menu. 

 In the Options dialog box, click on the Editor tab and check the Require 
Variable Declaration option.  Click OK to continue: 

SAMPLE
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Understanding Module Declarations 
 Declarations are listed in the first section of a module. 
 They set requirements and defaults on the module-level. 

 
 There are two default module-level declarations: 
 The Option Compare declaration specifies the default comparison method for 

string data. 
This declaration requires an argument: 
- Binary sorts string data based on the internal binary representation of 
characters. 
- Text sorts in a case-insensitive text sort order. 
- Database sorts in the same order as the database. 

 The Option Explicit declaration forces the declaration of variables used in the 
module. 

 

Understanding Procedures 
 Procedures consist of statements and methods. 
 A statement is a complete instruction to Visual basic and consists of keywords, 

operations, variables, constants, and expressions. 
 

 There are three types of statements: 
 Declaration statements used to name variables, constants or procedures. 

SAMPLE
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 Assignment statements used to give a value or an expression to a variable or a 
constant. 

 Executable statements used to trigger actions or jump to another location in 
the procedure. 

 

There are two types of procedures: 
 
 A sub procedure is program code that does not return a value.  It usually runs 

as a separate program called by an event in a form or report. 
 Example of a sub procedure: 

 
Sub sub_name (parameters) 
 
DoCmd.command_name 
 
End Sub 

 

 A function procedure is program code that returns a value as a result of a 
calculation or comparison. 

 Example of a function procedure: 
 
Function function_name (parameters) As type 
 calculation 
End Function 

 

Using Naming Rules 
 In any programming, writing clear code is one of the most important practices.  

This helps you and others understand and maintain your code. 
 In Visual Basic, there are several naming rules and practices: 
 The first character must be a letter. 
 The name has a maximum of 255 characters. 
 Avoid the use of special characters and spaces, periods, exclamation marks, etc. 
 Avoid the use of Visual Basic keywords. 
 Avoid the use of same names for multiple variables in same procedures. 
 Add prefixes to names that can indicate what type of item or variable they are: 

- con used to indicate a constant 
- int used to indicate an integer variable 
- dte used to indicate a date variable 
- str used to indicate a string variable 
- rst used to indicate a recordset 
- frm used to indicate a form 

 

SAMPLE
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Declaring Variables 
 Variables are items with unique names that contain data that can be changed 

during procedure execution. 
 You can specify the data type for each variable, or let Access assign the default 

Variant type. 
 A Variant type variable can contain string, date, time, Boolean, or numeric 

values. 
 The Dim statement is used to declare variables: 

 
Dim strName As String 
Dim intAge As Integer, dteBirthday As Date, undeclared 

 

 You can declare several variables in the same statement, separated by commas. 
 In the above example, we have used prefixes to descriptively name the 

variables in order to include their data type. 
 The last variable has no data type declaration, so the type is Variant. 
 

Setting Variable Scope 
 Scope of a variable indicates the variable availability to procedures. 

 
 There are three levels of variable scope: 

 
Procedure level is set when the variable is declared with a Dim statement in 
the procedure. 
 
Private module level is set when the variable is declared with a Private 
statement in the declarations module section.  The variable is available only to 
procedures in that module. 
 
Public module level is set when the variable is declared with a Public 
statement in the declarations module section.  The variable is available to all 
procedures in the application. 

 

Declaring Constants 
 Constants are items with unique names within which data cannot be changed 

during procedure execution. 
 A constant data type can be a string or number value, another constant, or an 

expression. 
 The Const statement is used to declare constants and give them a value: 

 
Const conYear As Integer = 1990 
Const conTitle As String = “President” 

 

SAMPLE
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 You can declare several constants in the same statement separated by commas. 
 In the above example, we have used prefix con to descriptively name the 

constants instead of their data types. 
 You must assign a constant a value at the time of declaration. 
 

Using Methods 
 Methods are actions that database objects can perform, or procedures that 

apply to database objects. 
 Access 2002 modules can use nearly 160 methods that apply to different 

database objects. 
 Some examples of methods are: 

- Opening or closing a form. 
- Sounding a beep when specific event occurs. 
- Going to a specific field in a form. 
- Filtering records for a report. 
- Printing multiple copies of a report, etc. 
 

 Methods have specific syntax that indicates the object and the action: 
 
SetFocus Forms![Customer Phone List]![Company Name].SetFocus 
 

 In the example above, the method moves the cursor to the Company Name 
field in the Customer Phone List form. 

 

Using Arguments 
 Arguments are used in the sub or function procedure calls. 
 They are optional, depending on the procedure. 
 There are two ways you can list arguments: in a procedure order, or by name. 
 For example, this is the sub procedure with argument list: 

 
Sub GetArguments (strName As String, dteBirthday As Date, intAge As Integer) 
 

 When you run the procedure, you can list the arguments in the same order as 
the procedure: 
 
GetArguments “John”, #11/12/1967#, 36 
 

 Or, you can list the arguments using their names – in any order: 
 
GetArguments dteBirthday:=#11/12/1967#, intAge:=36, strName:=”John” 

 
 

SAMPLE
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Using the Visual Basic Editor Window 
 
 

 
 
 

Customizing the Visual Basic Editor Window 
 Once you open the Visual Basic Editor window, you can change its look. 
 From the main menu, choose View > then select the elements you want to see 

in the editor window: 
 SAMPLE
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 In the Code view, the Object list box displays a list of all controls in the form or 
report: 
 

 
 

 In the Code view, the Procedure list box displays a list of all procedures in the 
module object: 
 

 
 

 

Setting the Visual Basic Editor Options 
 Once you open the Visual Basic Editor window, you can change its features. 

SAMPLE



Page 74 – Microsoft Access XP - Advanced Level Manual 

FOR USE AT THE LICENSED SITE(S) ONLY 
 Cheltenham Courseware Ltd. 1995-2010 www.cheltenhamcourseware.com 

 From the main menu, choose Tools > Options. 
 This opens up the Options dialog box: 

 

 
 

 The Code Settings group controls the code editing. 
 Auto Syntax Check option checks for syntax errors as you type the code. 
 Require Variable Declaration option includes the Option Explicit declaration in 

new modules. 
 Auto List Members option displays a list of keywords as you type the code. 
 Auto Quick Info option displays syntax when you type a method or procedure 

name. 
 Auto Data Tips option displays the current value of a variable when you rest 

your mouse pointer on the name. 
 Auto Indent option indents a line of code to match the previous line. 
 Tab Width option sets the number of characters for TAB key. 
 The Window Settings group controls the editor window behaviors. 
 Drag-and-Drop Text Editing option allows drag-and-drop editing in a module. 
 Default to Full Module view option shows all procedures in the module by 

default. 
 Procedure Separator option displays a horizontal line between procedures. 
 

 Click the Editor Format tab to specify the appearance of the different types of 
text in the editor window: 
 

SAMPLE
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 Click the General tab to set Form Grid Settings, Error Trapping and Compile 
options: 
 

 
 SAMPLE
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 Click the Docking tab to allow docking for editor windows: 
 

 
 
 

Getting Help with Visual Basic 
 

Using Microsoft Visual Basic Help 
 Open the Visual Basic Editor window. 
 From the main menu, choose Help > Microsoft Visual Basic Help 

OR press the F1 key 
OR click on the Microsoft Visual Basic Help [?] button on the toolbar: 
 

 
 

 If you get the following message, you must install the Microsoft Visual Basic 
Help first.  Click on the Yes button, and follow the installation instructions: 
 

 
 

SAMPLE
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 The Microsoft Visual Basic Help window opens up.  Here you can find 
extensive reference for various Visual Basic topics: 
 

 
 

Getting Visual Basic Syntax Help 
 While you are editing statements in the Visual Basic Editor window, you can 

get syntax help from the Edit menu: 
 SAMPLE



Page 78 – Microsoft Access XP - Advanced Level Manual 

FOR USE AT THE LICENSED SITE(S) ONLY 
 Cheltenham Courseware Ltd. 1995-2010 www.cheltenhamcourseware.com 

 
 
OR right-click inside the statement and choose desired help from the popup 
menu: 
 

 
 

 List Properties/Methods lists all properties and methods available for selected 
statement: 
 

 
 

SAMPLE
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 List Constants lists all intrinsic constants that are valid for a specific item in the 
argument list. 
 

 Quick Info displays the complete syntax with the current item highlighted in 
bold: 
 

 
 

 Parameter Info displays the complete syntax with the current parameter 
highlighted in bold: 
 

 
 

 Complete Word automatically completes the word when you begin typing. 
 
 

Review Questions 
 
How would you: 

 Use Visual Basic Modules? 
 Convert Macros to Visual Basic Code? 
 Understand Modules? 
 Create Modules? 
 Understand Module Declarations? 
 Understand Procedures? 
 Use Naming Rules? 
 Declare Variables? 
 Set Variable Scope? 
 Declare Constants? 
 Use Methods? 
 Use Arguments? 
 Customize the Visual Basic Editor Window? 
 Set the Visual Basic Editor Options? 
 Use Microsoft Visual Basic Help? 
 Get Visual Basic Syntax Help? 
 
 
 

SAMPLE
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Using Data Access Pages 
 
When you have completed this learning module you will have seen how to: 

 Use Data Access Pages 
 Create pages using the AutoPage 
 Create pages using the Page Wizard 
 Create pages using an Existing HTML Document 
 Create pages using the Design View 
 Choose a Theme 
 Add Text 
 Add Controls 
 Format Text and Labels 
 Align Content 
 Size Content 
 Add Images 
 Add Backgrounds 
 Sort Data 
 Summarize Data 
 Add a New Record 
 Delete a Record 
 Customize Navigation Bar 
 Protect Fields 
 
 

Creating Data Access Pages 
 

Using Data Access Pages 
 Data access pages allow you to connect Access database to the Internet. 
 With data access pages you can share database data and allow viewing and/or 

editing of dynamic data at your website. 
 To display data access pages, the user must use Internet Explorer 5.5 or later 

and have a Microsoft Office XP license. 
 There are several ways to create data access pages using: 

AutoPage 
Page Wizard 
Existing HTML Document 
Design View 

 

Creating pages using the AutoPage 
 The quickest way to create data access pages is to use the AutoPage feature. 
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 AutoPage automatically adds all the fields from selected table or query. 
 Data is displayed in a form-like style. 
 
To create a data access page using AutoPage: 

 In the Database window, click on the Pages tab, then click on the New button: 
 

 
 

 In the New Data Access Page select AutoPage: Columnar: 
 

 
 

 Choose the table or query where the object’s data comes from by selecting it 
from the drop-down list: 
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 Click OK to create a data access page: 
 

 
 

 At the bottom of the data access page, you will notice the Record Navigation 
Bar. 
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 From the main menu, choose File > Save to open the Save As Data Access 
Page dialog box: 
 

 
 

 Select the location and name the data access page and click Save. 
 The new data access page is listed in the Pages section of Database window: 

 

 
 
To view a data access page in the browser: 

 Select the data access page in the Pages page of the Database window. 
 From the main menu, choose File > Web Page Preview. 
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 The data access page opens in the browser window: 
 

 
 

Creating pages using the Page Wizard 
 Another way to create data access pages is using the Page Wizard. 
 The Page Wizard allows additional options for creating a data access page.  For 

example, you can choose fields from more than one table or query, grouping, 
selecting multiple fields for sorting, etc. 
 

 
To create a data access page using the Page Wizard: 

 In the Database window, click on the Pages tab, and then click on the New 
button. 

 In the New Data Access Page select Page Wizard and click OK to continue: 
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OR from the Pages page of Database window, double-click on Create data 
access page by using wizard: 
 

 
 

 This will open the Page Wizard dialog box. 
 Select the table or query from the Tables/Queries drop-down list: 
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 Under the Available Fields list, select one field and click [>] button to transfer 
it to the Selected Fields: 
 

 
 

 If you want to select all the fields, click on the [>>] button: 
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 If you want to remove a field from the Selected Fields list, select the field and 
click on the [<] button. 

 Repeat the same steps for other tables and/or queries from which you want to 
add fields to the data access page.  Once you have finished selecting fields, click 
Next button to continue. 
 

To group data in the data access pages: 

 This page of the wizard allows you to add grouping levels. 
 Select the field you want to group by, and click on the [>] button: 

 

 
 

 A new grouping level will be added to the data access page.  If you want to 
choose the grouping interval, click on the Grouping Options button: 
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 The Grouping Intervals dialog box allows you to choose how you want to 
group the group-level field(s).  Click OK to accept change or Cancel to close the 
dialog box: 
 

 
 

 Back in the Page Wizard, click Next to continue. 
 
To sort data in the data access pages: 

 This page of the wizard allows you to sort records. 
 Select the sorting field(s) from the drop-down lists: 
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 The default sorting order is ascending.  If you want to change the sorting order, 
click the Ascending button to change it into Descending: 
 

 
 

 Once you select all of the sorting fields, click on the Next button to continue. 
 The last page of the wizard allows you to add a title to the page and set other 

options: 
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 Open the page option takes you directly to the Page view. 
 Modify the page’s design option takes you directly to the Design view. 
 Do you want to apply a theme to your page option allows you to add 

predefined styles to the data access page. 
 Display Help on working with the page option gives you help while working 

on the page design. 
 

 Click Finish.  Depending on what you have selected, the page will be opened in 
either the Page view or the Design view.  This is a sample of the page in the 
Design view: 
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End of the preview sample 
 
 

 
 
This sample is approximately half of the full course.  Please see the table of contents at the 
beginning of this document to see the full list of topics covered in the full course. 
 
To purchase the rights to use the full training manuals at your training centre please see our 
web site at:  
 

http://www.cheltenhamcourseware.com 
 
A courseware licence allows you to make unlimited copies for use at your training centre. 
 

 
 
In addit ion you get HTML formatted versions of each 
course, included w ith our printable coursew are. 
 
Invest in a complete Computer Courseware Library, 
including Windows 7 & Office 2010 
The most cost effective courseware solution for your IT 
training needs. Get ALL our courses, and all new  courses 
released w ithin 12 months. 
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