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Course Basics 
 
 

Toolbars 
 
 

The Title Bar 
 The title bar is displayed along the top of almost all program, folder and dialog 

box windows.  It is used to display information such as the name of the 
application (or folder) and the document you are working on.  Information which 
is displayed here may vary.  The example shown illustrates the title bar for a 
program called Microsoft Word, in which a document called Document1 has 
been opened or saved: 
 

 
 
 

The Menu Bar 
 The menu bar is located under the title bar, and contains a series of drop down 

menus.  The example shown illustrates the Microsoft Word Menu Bar: 
 

 
 
 

To execute Menu commands 

 In most cases, you are asked to use the mouse to execute a series of menu 
commands (e.g., File > Save As).  What this means is that you select File from 
the main menu, followed by Save As: 
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The Tool Bar 
 The tool bar contains a series of icons, which allow you to achieve a desired 

effect as quickly as possible.  In the example shown, taken from the Microsoft 
Word Formatting toolbar, to make the selected text bold, you would click on the 
Bold icon: 
 

 
 
 

Installing the Sample Files 
 

 Use Windows Explorer to create a folder called Excel 2003 Advanced 
Samples, in the My Documents folder. 

 If you are installing the sample files from the CD-ROM, place the CD-ROM in the 
CD drive and copy the files from the 
excel_2003_advanced_usa\exercise_files to the My Documents\Excel 
2003 Advanced Samples folder. 

 If these files have been copied to your network server, then ask your 
trainer/supervisor for more information about how to copy these files to your 
PC’s hard disk. 

 

 Notes for tutors: 
The above instructions are for Windows that has not been set-up for a multi-
user environment (with individual profiles).  The instructions above may require 
modification within a Windows mutliuser environment.  Where possible pre-
install the relevant work files prior to use by students/delegates. 
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Importing Data  
 
When you have completed this learning module you will have seen how to: 

 Import data from external sources 
 Import data into Excel 
 Import text files into Excel 
 Import text using the Text Import Wizard 
 Refresh data from imported text files 
 Use Microsoft Query 
 Add a data source 
 Create a Query  
 Query data from the Web 
 Access the New Web Query dialog box 
 Create a new Web Query 
 Save a Web Query 
 Set Web Query options 
 Run a saved Web Query 
 Refresh a Web Query 
 Refresh external data without losing the formatting 
 Refresh external data automatically 
 
 

Importing Data from External Sources 
 
 

Using Database Terminology 
 In a corporate environment, data is not usually created and stored within Excel, 

but may be stored on mainframes or database servers.  Commonly used 
programs include Access, dBase, FoxPro, Paradox, Oracle, or SQL Server. 
 

 To import data from a database, it is useful to understand the following common 
database terminology: 
 
Data Sources: The data source informs the ODBC Manager about the type of 
data being used and its location. 
 
Microsoft Query: A stand-alone program supplied with Microsoft Excel.  It acts 
as an interface, allowing you to create queries that are translated into SQL 
format. 
 
ODBC: It stands for Open Database Connectivity, and is a term used to describe 
an industry standard used to connect cross-platform databases.   
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ODBC Add-in: It allows Excel to communicate with the ODBC Manager directly 
(without using the Microsoft Query as an intermediary).  It also provides the 
SQL.REQUEST worksheet function, as well as providing an Application 
Programmers Interface (API) for application developers. 
 
ODBC Driver: The ODBC Manager uses the ODBC driver as an intermediate 
step.  ODBC drivers supplied with Excel include Access, dBase, FoxPro, Paradox, 
SQL Server, Oracle, Excel Worksheets, and text files. 
 
ODBC Manager: This is a Microsoft derived technology that allows programs 
such as Excel and Microsoft Query to interface with a range of different 
databases.  When you perform a Microsoft query, an SQL statement is sent to 
the ODBC Manager.  The ODBC Manager then acts as an intermediary between 
the application and the database.  This has the advantage that the same query 
may be used to access different database servers, including SQL Server, Oracle, 
dBase or Paradox. 
 
Structured Query Language (SQL): An industry standard language used for 
database communication.  Excel queries using Microsoft Query use SQL behind 
the scenes. 

 
 

 Importing Data into Excel 
 You can import data using the following methods: 

 
Open command: From the main menu, choose File > Open to display the 
Open dialog box, and select the data file type from the File of type dropdown 
list.  You can choose from the following types of file: Access, Lotus 1-2-3, 
Quattro Pro, Microsoft Works, dBase, SYLK, Data Interchange Format (DIF), All 
Web Pages, XML, and previous versions of Excel.  The selected file will be 
translated by Excel and imported as an Excel spreadsheet. 
 
Export data into text files: From the database application where your data is 
stored, you can usually export the data you want into text files.  You can then 
import these text files using the Text Import Wizard. 
 
Microsoft Query: This program is shipped with Microsoft Excel, and is an 
excellent tool for querying an external database.  Queries allow you to specify 
the exact data you want from the external database. 
 
Web Queries: Microsoft Excel 2003 allows you to query and refresh data from 
the Internet.   
 
XML: Microsoft Excel 2003 now allows you to import XML files and map out 
individual elements to specified cells in a Worksheet.  However, this added 
feature is only available in the Professional Edition of Office 2003, and not other 

SAMPLE



Page 11 - Excel 2003 - Advanced Level Manual 

FOR USE AT THE LICENSED SITE(S) ONLY 
 Cheltenham Courseware Ltd. 1995-2010 www.cheltenhamcourseware.com 

versions of Office.  (If you are not sure which Office edition you are currently 
using, ask your instructor for assistance). 
 
Pivot Tables: Pivot Tables are useful for accessing and integrating external 
databases into Excel.  They will be covered in chapter 3 of this manual. 

 
 

Importing Text Files 

Importing text files into Excel 
 You can import text from other sources, saving the need to re-enter the data.  

To import text into Excel, it must be in a format that can be recognized by Excel. 
 
 

File formats are supported by Excel 

 Text: Text files are plain text with no formatting information except line returns.  
Usually this file type contains one record of information per line, but the means 
of identifying the fields in a record varies. 

 Text (Tab Delimited): With this text file format, tabs are used to identify fields 
in a record. 

 Formatted Text: Formatted text files make use of position to define fields; 
each field starts at a defined position on the line.  You may find this field type 
also referred to as Space Delimited, Fixed Width, or Column Delimited. 

 Comma Separated Values (CSV): Commas are used by CSV text files to 
delimit (separate) fields.  Although these files are called Comma Separated 
Values text files, commas are not always used as the delimiter.  Examples of 
other delimiters include vertical bars (|) and at signs (@). 
 
Note: If the text to be imported is not in recognized by Excel, Excel will launch 
the Text Wizard to provide assistance. 

 
 

Importing text using the Text Import Wizard 
 The Text Import Wizard is a set of dialog boxes that guide you through the 

customization of imported text. 
 From the main menu, choose File > Open to display the Open dialog box. 
 From the Files of type dropdown list, select Text Files (*.prn, *.txt, *.csv). 
 Select the file you want to open. 

SAMPLE



Page 12 - Excel 2003 - Advanced Level Manual 

FOR USE AT THE LICENSED SITE(S) ONLY 
 Cheltenham Courseware Ltd. 1995-2010 www.cheltenhamcourseware.com 

 Click Open to display the Text Import Wizard - Step 1 of 3 dialog box: 
 

 
 

 Excel will analyze the selected text file, and determine the file's data type, and 
display a preview of the data to be imported.  In the above example, Excel 
determined the file to be a Delimited file.   

 You can choose to alter the file type selection as needed.  If your file contains 
header rows that you do not want imported, you can change the Start import 
at row number to exclude the header rows.  When you change the Start 
import at row number, the preview will be updated to reflect the change. 

 When you are satisfied with the options selected, click on the Next button to 
continue to the Text Import Wizard - Step 2 of 3 dialog box.   
 
Note: You can always use the Back button to go back to the previous dialog 
box and revise the options: 
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 From this dialog box, you can set the delimiters your data contains--choose the 
type of Delimiters, select to Treat consecutive delimiters as one, and 
define the Text qualifier.  The Data preview will display the data based on 
your choices. 

 When you are satisfied with the options selected, click on the Next button to 
continue to the Text Import Wizard - Step 3 of 3 dialog box. 
 
Note: You can always use the Back button to go back to the previous dialog 
boxes and revise the options: 
 

 
 

 From this dialog box, you can determine the data format of each column by 
selecting each column in the Data preview area and selecting its Column data 
format.  If you do not want to import one of the columns, click on the column in 
the Data preview area, and select the Do not import column (skip) radio 
button in the Column data format area.   

 When you are satisfied with the options selected, click on the Finish button to 
import the text into Excel.   
 
Note: You can always use the Back button to go back to previous dialog boxes 
and revise the options.  Alternatively, you can click Cancel to close the wizard 
without importing the data: 
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Refreshing data from imported text files 
 Select the Worksheet that contains external data from a text file. 
 From the main menu, choose Data > Refresh Data 

 

OR from the External Data toolbar, click on the Refresh Data  icon to 
display the Import Text File dialog box. 
 

 Select the text f ile you w ant. 

 Click Import. 
 
 

Using Microsoft Query 
 
 

Adding a Data Source 
 Microsoft Query allows you to obtain data from an external database. You can 

use the wizard to create filters and define sort order of data from an external 
database.  Since Microsoft Query is a stand-alone program, it can be started 
independently; however, you can run Microsoft Query from within Excel.  For 
illustrations purposes, we will run a query with the NorthWind Traders database, 
which is a sample database supplied with Microsoft Access. 

 Make sure that Microsoft Query is installed. 
 From the main menu, choose Data > Import External Data > New Database 

Query to display the Choose Data Source dialog box: 
 

 
 

 Click on the Databases tab. 
 With <New Data Source> selected, click OK to display the Create New Data 

Source dialog box: 
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 In the field numbered 1, enter a name for the new data source.  In our 
example, we will enter My Data. 

 In the field numbered 2, click on the down arrow and select a driver for your 
database.  In our example, the selected driver is Microsoft Access Driver 
[*.MDB]. 

 Click Connect.  In our example, you will see the ODBC Microsoft Access 
Setup dialog box: 
 

 
 

 Click on the Select button to display the Select Database dialog box: 
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 Locate and select the database you want.  In our example, we will use the 
NorthWind Traders database.  You will normally find this in the following 
location: 
 
\Program Files\Microsoft Office\Office11\SAMPLES\Northwind.mdb 
 

 Click OK to select the database. 
 From the ODBC Microsoft Access Setup dialog box, click OK to connect to the 

database and redisplay the Create New Data Source dialog box.  (Notice that 
field 3 contains a file path): 
 

 
 

 In field 4, you can enter a default table for your data source.  In our example, 
we will leave this blank, but all the tables in our database are listed in the 
dropdown list: 
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 From the Create New Data Source dialog box, click OK to return to the 
Choose Data Source dialog box.  (Notice that the new data source, My Data, 
has been added): 
 

 
 

 To use the selected data source, click OK. 
 
 

Creating a Query 
 From the main menu, choose Data > Import External Data > New Database 

Query to display the Choose Data Source dialog box. 
 Click on the Databases tab. 
 Select the data source you want to use.  In our example, we will select My 

Data: 
 

 
 

 Click OK to display the Query Wizard - Choose Columns dialog box. 
 To add the columns you want to include in your query, locate the columns you 

want by expanding the plus icon beside each table, select the column, and click 
the right arrow button.   
 
Note: You can add all the columns in a table by selecting the table name and 
clicking on right arrow button: 
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In our example, we will add the columns in the Categories and the Products 
tables to the query. 
 

 Click Next to continue to the Query Wizard - Filter Data dialog box. 
 To add a filter to your query, select the Column you want to filter.  In the Only 

include rows where: area, select an operand from the first dropdown list and 
a column value from the second dropdown list. 
 
Note: You can add another filter by selecting the And or Or radio buttons: 
 

 
 
In our example, we only want data that has a CategoryID of 2 or 8. 

 

 Click Next to continue to the Query Wizard - Sort Order dialog box. 
 To sort your data, select the Column you want in the Sort by dropdown list and 

select the Ascending or Descending radio button. 
 
Note: You can add another two other sort criteria: 
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In our example, we will sort the data by CategoryName in Ascending order. 
 

 Click Next to continue to the Query Wizard - Finish dialog box. 
 To display the results of your query in Excel, select the Return Data to 

Microsoft Excel radio button. 
 
Note: You can save this query for future use by clicking on the Save Query 
button: 
 

 
 

 Click Finish to display the Import Data dialog box: 
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 You can determine where you want to place the data.  Make your selection and 
click OK.  In our example, the worksheet may appear as follows: 
 

 
 
 

Querying Data from the Web 
 
 

Using Web Queries 
 The Internet can provide valuable information to your spreadsheet analysis.  

Microsoft Excel 2003 has integrated a web query component that allows you to 
insert data obtained directly from a Web page into your spreadsheet.  The data 
can be refreshed as needed.  For example, you can obtain stock quotes from the 
Internet and insert the data into your spreadsheet for analysis.   

 
 

Accessing the New Web Query dialog box 
 You can access the New Web Query dialog box from Microsoft Excel or from 

your browser. 
 
 

To access the New Web Query dialog box from Excel 

 From the main menu, choose Data > Import External Data > New Web 
Query to display the New Web Query dialog box. 

 In the Address dropdown list box, enter the URL of the Web page that contains 
the data you want.  Click on the Go button to display the Web page in the 
preview area: 
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To access the New Web Query dialog box from Internet Explorer 
 In Internet Explorer, browse to the Web page that contains the data you want.   
 From the toolbar, click on the Edit icon arrow, and select Edit with Microsoft 

Excel to display the New Web Query dialog box with the Web page displayed 
in the preview area: 
 

 
 
 

Creating a new Web Query  
 Once you have previewed the Web page you want in the New Web Query 

dialog box, you can select the data you want to import.  The Web Query function 
works best with data within HTML table tags.  Importable data will be identified 
by yellow arrow icons .   
 

Note: To display the yellow arrow icons, click on the Show Icons  button, 
located at the top of the dialog box. 

 

 From the preview area of the New Web Query dialog box, locate the data you 
want to import, and click on its corresponding yellow arrow icon.  The icon will 
change to a green check mark icon  to indicate that it is selected. 
 
Note: To import the entire page, click on the yellow arrow icon in the top-left 
corner of the preview area. 

 

 When all the data you want to import is selected, click on the Import button to 
display the Import Data dialog box: 
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 From the Import Data dialog box, select the Existing worksheet radio button 
to import the data into the existing worksheet, or select the New worksheet 
radio button to import the data into a new worksheet.  (If you are importing the 
data into an existing worksheet, you can place the data in the cell or cell range 
you want.) 

 To change the properties of the data, click on the Properties button, and select 
the options you want in the External Data Range Properties dialog box: 
 

 
 

 When you are satisfied with the property options, click OK to return to the 
Import Data dialog box. 

 From the Import Data dialog box, click OK to import the data into Excel.   
 
Note: It may take a moment to run the Web Query.  You can check the query 

status by double-clicking the Refresh  button. 
 
 

SAMPLE



Page 23 - Excel 2003 - Advanced Level Manual 

FOR USE AT THE LICENSED SITE(S) ONLY 
 Cheltenham Courseware Ltd. 1995-2010 www.cheltenhamcourseware.com 

Saving a Web Query 
 By default, Web Queries are saved along with your Workbook.  (You can change 

this by deselecting the Save query definition checkbox in the External Data 
Range Properties dialog box. 

 If you want to access the query from another file, you can save the query as a 
separate file.   

 From the main menu, choose Data > Import External Data > Edit Query 
to display the Edit Query dialog box. 

 Click on the Save Query  icon to display the Save As dialog box.   
 Enter a file name in the File name dropdown list box. 
 Click Save to save the query as a text file with an .iqy file extension.   
 From the Edit Web Query dialog box, click Cancel to close the dialog box. 
 
 

Setting Web Query options 

 From the New Web Query dialog box, click on the Options  button to 
display the Web Query Options dialog box: 
 

 
 

 Set the Formatting and Import options you want. 
 Click OK to apply the options. 
 
 

Running a saved Web Query 
 You can run a previously saved Web Query or one that was preloaded with 

Microsoft Excel.  Excel includes Web Queries such as stock quotes and foreign 
exchange rates.   

 From the main menu, choose Data > Import External Data > Import Data 
to display the Select Data Source dialog box: 
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 Select the Web Query you want. 
 Click Open to display the Import Data dialog box. 
 From the Import Data dialog box, select the Existing worksheet radio button 

to import the data into the existing worksheet, or select the New worksheet 
radio button to import the data into a new worksheet. 

 Click OK to import the data. 
 
 

Refreshing a Web Query 
 Open the Worksheet that contains external data from a Web Query. 
 Select one of the cells that contain Web Query data. 
 From the main menu, choose Data > Refresh Data 

 

OR from the External Data toolbar, click on the Refresh Data  icon. 
 
 

Refreshing Data 
 
 

Refreshing external data without losing the formatting 
 Select one of the cells that contain external data. 
 From the main menu, choose Data > Import External Data > Data Range 

Properties 
 

OR from the External Data toolbar, click on the Data Range Properties  
icon to display the External Data Range Properties dialog box. 
 

 To preserve the cell formatting, select the Preserve cell formatting checkbox. 
 To keep any custom column widths, deselect the Adjust column width 

checkbox: 
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 Click OK to close the External Data Range Properties dialog box. 
To refresh the data, choose Data > Refresh Data 
 

OR from the External Data toolbar, click on the Refresh Data  icon. 
 
 

Refreshing external data automatically 
 You can set the external data to refresh automatically when you open the 

Workbook or periodically while the Workbook is open.   
 Select one of the cells that contain external data. 
 From the main menu, choose Data > Import External Data > Data Range 

Properties 
 

OR from the External Data toolbar, click on the Data Range Properties  
icon to display the External Data Range Properties dialog box. 

 

 Select the Refresh data on file open checkbox, or select the Refresh every 
checkbox, and set the time period in minutes: 
 

 
 

 Click OK. 
 
Note: To reduce file size, you can save the Workbook with the query definition 
but without the external data.  Select the Remove external data from 
worksheet before saving checkbox.  The data will be automatically refreshed 
next time you open the Workbook. 

 
 

Review Questions 
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How would you: 

 Import data from external sources? 
 Import data into Excel? 
 Import text files into Excel? 
 Import text using the Text Import Wizard? 
 Refresh data from imported text files? 
 Use Microsoft Query? 
 Add a data source? 
 Create a Query? 
 Query data from the Web? 
 Access the New Web Query dialog box? 
 Create a new Web Query? 
 Save a Web Query? 
 Set Web Query options? 
 Run a saved Web Query? 
 Refresh a Web Query? 
 Refresh external data without losing the formatting? 
 Refresh external data automatically? 
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Templates and Styles 
 
When you have completed this learning module you will have seen how to: 

 Create a template 
 Use templates 
 Create a style 
 Use styles 
 Edit a style 
 Delete a style 
 Copy styles from another Workbook 
 
 

Working with Templates 
 
 

Using Templates 
 When working with spreadsheets, you may wish to use the same layout or 

design.  Instead of re-creating the design, you can create a template. 
 Templates have the .XLT file extension, and can contain layout and formatting 

information, including text and graphics, layouts and styles, headers and 
footers, formulas, and macros. 

 When templates are used to create a new Workbook, a copy is made, leaving 
the original template file intact for further use. 

 
 

Creating a Template 
 Create a Workbook that contains all layout and formatting elements you want in 

your template. 
 From the main menu, choose File > Save As to display the Save As dialog box. 
 In the File name dropdown list box, type a template name. 
 From the Save as type dropdown list box, select Template (*.XLT) to display 

the existing templates in the default Templates folder and add the .XLT 
extension to the file name: 
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 Click Save to save the template in the Templates folder. 
 
 

 Applying Templates 
 From the main menu, choose File > New to display the New Workbook pane. 
 From the Template section of the New Workbook pane, click on the blue On 

my computer link to display the Templates dialog box: 
 

 
 

 Click on the General or the Spreadsheet Solutions tab to locate the template 
you want.  For the default template, click on the General tab and select the 
Workbook icon. 

 Click OK. 
 
Note: Excel 2003 allows you to access additional templates on the Microsoft 
Office website (Note: internet access is required to use this feature).  Simply 
click on the Templates on Office Online link in the New Workbook pane, and 
you will be directed to the Office website, where you can search for the template 
you need.  Experiment! 
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Working with Styles 
 
 

Using Styles 
 Whereas a template is a collection of layout and formatting information for a 

workbook, a style is a collection of formatting information for a cell.  Styles can 
contain formatting information, including Number, Font, Alignment, Border, 
Patterns, and Protection. 

 You can use styles to reapply pre-defined formatting to multiple cells.  When 
styles are used to format cells, you can reformat the Worksheet by modifying 
the styles.  It is possible to copy styles from one Workbook to another. 

 Excel 2003 comes with a number of pre-defined styles.  By default, all cells are 
assigned the Normal style. 

 
 

Creating a Style 
 Select the cell that contains the formatting you want in your style. 
 From the main menu, choose Format > Style to display the Style dialog box. 
 In the Style name dropdown list box, type a style name. 
 Select the attributes (Number, Alignment, Font, Border, Patterns, and 

Protection) you want to include in the new style: 
 

 
 

 Click Add to create the style 
 Click OK to closes the Style dialog box. 
 
 

Applying a Style 
 Select the cell or cell range you want to format. 
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 From the main menu, choose Format > Style to display the Style dialog box. 
 From the Style name dropdown list box, select the style you want to use: 

 

 
 

 Click OK to closes the Style dialog box. 
 
 

Editing a Style 
 From the main menu, choose Format > Style to display the Style dialog box. 
 From the Style name dropdown list box, select the style you want to edit. 
 Click on the Modify button to display the Format Cells dialog box: 

 

 
 

 Use the tabs to access the attributes you want, and make the changes needed. 
 Click OK to return to the Style dialog box. 
 Click OK to apply the changes to all cells formatted with this style. 
 
 

Deleting a Style 
 From the main menu, choose Format > Style to display the Style dialog box. 
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 From the Style name dropdown list box, select the style you want to delete. 
 Click on the Delete button. 
 Click OK to close the Style dialog box. 
 
 

Copying Styles from another Workbook 
 Open the Workbook with the styles you want to copy. 
 Switch to the Workbook that the styles will be copied to. 
 From the main menu, choose Format > Style to display the Style dialog box. 
 Click on the Merge button to display the Merge Styles dialog box: 

 

 
 

 Select the Workbook that contains the styles you want. 
 Click OK to copy the styles from the selected Workbook. 
 Click OK to close the Style dialog box. 
 
 

Review Questions 
 
How would you: 

 Create a template? 
 Use templates? 
 Create a style? 
 Use styles? 
 Edit a style? 
 Delete a style? 
 Copy styles from another Workbook? 
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Analyzing Data 
 
When you have completed this learning module you will have seen how to: 

 Use Goal Seek 
 Use a Data Table 
 Create a one-variable Data Table 
 Create a two-variable Data Table 
 Speed up calculations with Data Tables 
 Use Scenario Manager 
 Add a scenario 
 Show a scenario 
 Delete a scenario 
 Edit an existing scenario 
 Summarize scenarios 
 Use Solver 
 Install Solver 
 Change a constraint 
 Delete a constraint 
 Understand Pivot Tables 
 Create Pivot Tables 
 Drop data into Pivot Tables 
 Modify data and refresh Pivot Tables 
 Group data within Pivot Tables 
 
 

What-If Analysis 
 
 

Using What-If Analysis 
 Excel provides a number of tools to help you find answers to "What-If" type 

questions.  What-If Analysis allows you to see the effect that input value 
changes have on the result of the formulas.  For example, what happens to a 
car loan payment if you reduced the down payment or increased the interest 
rate?  

 Excel provides the following What-If Analysis tools: 
 
Goal Seek: Allows you to find the correct input to produce the desired outcome.  
Simple to use, but limited in power and flexibility. 
 
Data Tables: Allows you to see how the results are affected by changes in the 
input values displayed in a table.  Simple to use, but limited in power and 
flexibility.   

SAMPLE



Page 33 - Excel 2003 - Advanced Level Manual 

FOR USE AT THE LICENSED SITE(S) ONLY 
 Cheltenham Courseware Ltd. 1995-2010 www.cheltenhamcourseware.com 

 
Scenario Manager: Allows you to create, manipulate, and save a number of 
different scenarios that use different input variables, producing different results.  
Simple to use, but limited in power and flexibility. 
 
Solver: Allows you to find the best solution to complex problems that revolve 
around the manipulation of multiple variables and constraints.  More difficult to 
use, but very powerful and extremely flexible. 

 
 

Goal Seek 
 
 

Using Goal Seek 
 Sometime when you are analyzing a problem, you know the end result you want 

to achieve, but want to determine the input values to achieve this result.  The 
Goal Seek command will allow us to accomplish this easily. 

 Goal seeking is the means to say, "This is the final value that I want to achieve, 
what input value do I need?" 

 Excel calculates the input value needed by varying the value in the formula until 
the result is achieved. 

 
 

Applying Goal Seek 
 Build a formula using cell references for each variable of your formula.  The 

following example shows a simple calculation of the Price of car you can 
afford.  The formula in cell B3 is: =(B1+B2)/0.2 
 

 
 

 Select the cell containing the formula for which you have an end result to 
achieve.  In our example, select cell B3. 

 From the main menu, choose Tools > Goal Seek to display the Goal Seek 
dialog box.  The cell reference for the selected cell will appear in the Set cell 
text box. 

 In the To value text box, enter the end result you want to achieve.  In our 
example, we want to purchase a more expensive car; enter 30000. 

 In the By changing cell text box, enter the cell containing the input value that 
you want changed to achieve the end result.  In our example, we want to know 
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what Down payment is required.  Click on cell B1: 
 

 
 

 Click OK to run the Goal Seek. 
 When the Goal Seek is complete, the Goal Seek Status dialog box will appear, 

and the results are reflected in the Worksheet: 
 

 
 

 Click OK to accept the new values. 
 Click Cancel to close the Goal Seek Status dialog box and leave the values 

unchanged. 
 
 

Data Tables 
 
 

Using Data Tables 
 You can use Data Tables to calculate and compare the outcome of different 

inputs of a formula.  The different combinations of input values and results are 
presented in a table format for easy comparison.  Depending on your needs, you 
can change one or two variables in Data Tables. 
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Creating a one-variable Data Table 
 A one-variable Data Table allows you to see the effects of changing one 

variable (input value) of a formula.  In the following example, we will find out 
the effect the Down Payment has on the monthly Payments. 

 Begin by designing the Worksheet with your initial input values.  The input value 
that you want varied is referred to as the Input Cell.  In our example, the Input 
Cell is B3. 

 Create the Data Table by listing the substitution values of your Input Cell 
together, either in a column or in a row.  In our example, we will list the 
substitution values in range C3:C6. 

 
 Enter the formula, using the Input Cell in the formula, as follows: 

 
If your substitution values are column-oriented, enter the formula in the cell 
that is one column to the right and one cell above the first substitution value.  In 
our example, the first substitution value is in cell C3 so we will enter the formula 
in cell D2. 
 
If your substitution values are row-oriented, enter the formula in the cell that 
is one row below and one cell to the left of the first substitution value.  For 
example, if your first substitution value were in cell C3, then you would enter 
your formula in cell B4. 
 

 Select a cell range that includes the formula and all the substitution values.  In 
our example, the selected range is C2:D6: 
 

 
 

 From the main menu, choose, Data > Table to display the Table dialog box: 
 

 
 
If your Data Table is column-oriented, in the Column input cell, enter the 
cell reference for the Input Cell.  In our example, the Input Cell is B3. 
 
If your Data Table is row-oriented, in the Row input cell, enter the cell 
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reference for the Input Cell. 
 

 Click OK to create the one-variable Data Table: 
 

 
 
 

Creating a two-variable Data Table  
 A two-variable Data Table allows you to see the effects of changing  two 

variables (input values) of a formula.  In the following example, you will find the 
effects the Down Payment and the interest rate have on the monthly Payments. 

 Begin by designing the Worksheet with your initial input values.  The input 
values that you want varied are referred to as the Input Cells.  In our example, 
the Input Cells are B3 and B5. 

 Create the Data Table by entering your formula, using both Input Cells in your 
formula, in a cell that will define the top-left corner of your Data Table.  In our 
example, we will enter the formula in cell C2. 

 List the substitution values of your first Input Cell down a column to the below 
your formula.  In our example, we will list the Down Payment substitution values 
in cell range C3:C6. 

 List the substitution values of your second Input Cell across in a row to the right 
of your formula.  In our example, we will list the Interest Rate substitution 
values in cell range D2:G2. 

 Select a cell range that includes the formula and all the substitution values.  In 
our example, the selected range is C2:G6: 
 

 
 

 From the main menu, choose, Data > Table to display the Table dialog box: 
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In the Row input cell, enter the cell reference for the row Input Cell.  In our 
example, the row Input Cell is B5.   
 
In the Column input cell, enter the cell reference for the column Input Cell.  
In our example, the column Input Cell is B3. 
 

 Click OK to create the two-variable Data Table: 
 

 
 
 

Speeding up calculations with Data Tables 
 By default, Excel will recalculate Data Tables every time the Worksheet requires 

recalculation, slowing your calculations.   
 You can adjust this option, such that Data Tables are not automatically 

recalculated with the Worksheet. 
 From the main menu, choose Tools > Options to display the Options dialog 

box, and click on the Calculation tab. 
 Select the Automatic except tables radio button: 

 

 
 

 Click OK. 
 
 

Scenario Manager 
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Using Scenario Manager 
 In analyzing your data, you will frequently want to look at a number of differing 

options within your spreadsheet.  Scenario Manager allows you to change 
multiple cells in order to see the effect of the changes, and keep your scenarios 
for review later.   

 Scenarios are useful in forecasting the results of models, and can be printed in 
summary form. 

 For example, we can use Scenario Manager to see the changes in total 
expenditures depending on scenarios that affect expense items differently. 

 
 

Adding a Scenario 
 Begin by creating the initial scenario using our best guess on the percentage 

increases: 
 

 
 

 Select the cells containing values that will change with different scenarios.  In 
our example, select cell range C2:C5. 

 From the main menu, choose Tools > Scenarios to display the Scenario 
Manager dialog box.  (Notice that no scenarios have been defined): 
 

 
 

 Click on the Add button to display the Add Scenario dialog box.  In our 
example, we will create a scenario for Low Inflation, where the expected 
percentage increases are as follows: Rent - 1%, Staff - 2.5%, Energy - 10%, 
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and Other - 2%: 
 

 
 

 In the Scenario name text box, enter a name for the scenario you are about to 
create.  In this case, enter the name Low Inflation. 

 Click OK to display the Scenario Values dialog box: 
 Change the value in text box 1 to 1, change the value in text box 2 to 2.5, 

change the value in text box 3 to 10, and change the value in text box 4 to 2: 
 

 
 

 Click OK to add the scenario and return to the Scenario Manager dialog box.  
(Notice that 'Low Inflation' is now listed in the Scenarios list box): 
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 Click Close to close the Scenario Manager dialog box. 
 
 

Showing a Scenario 
 From the main menu, choose Tools > Scenarios to display the Scenario 

Manager dialog box: 
 

 
 

 From the Scenarios list box, select the scenario you want to see. 
 Click on the Show button to display the results of the scenario in the 

Worksheet: 
 

 
 

 Click Close to close the Scenario Manager dialog box. 
 
 

Deleting a Scenario  
 From the main menu, choose Tools > Scenarios to display the Scenario 

Manager dialog box. 
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 From the Scenarios list box, select the scenario you want to delete. 
 Click on the Delete button to delete the scenario. 
 Click Close to close the Scenario Manager dialog box. 
 
 

Editing an existing Scenario 
 From the main menu, choose Tools > Scenarios to display the Scenario 

Manager dialog box. 
 From the Scenarios list box, select the scenario you want to edit. 
 Click on the Edit button to display the Edit Scenario dialog box.  (Notice that 

Excel automatically adds a 'Modified' message in the Comment text area): 
 

 
 

 Click OK to display the Scenario Values dialog box: 
 

 
 

 Make the changes you want. 
 Click OK to add the scenario and return to the Scenario Manager dialog box. 
 Click Close to close the Scenario Manager dialog box. 
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Summarizing Scenarios 
 From the main menu, choose Tools > Scenarios to display the Scenario 

Manager dialog box. 
 Click on the Summary button to display the Scenario Summary dialog box: 

 

 
 

 Select the Scenario summary radio button. 
 In the Result cells text box, enter the cell or range of the values you want to 

see in the summary.  In our example, we will enter cell D6 to display the total 
estimated cost for next year. 

 Click OK to display the summary in a new Worksheet: 
 

 
 
 

Solver 
 
 

Using Solver 
 Solver is the most versatile What-if Analysis tool.  It can handle many different 

variables, and where possible, Solver will produce the optimum answer. 
 

 In order to understand Solver, you will need to know the following terms: 
 
Target Cell: The cell that will be set to a value, maximum or minimum.  Often 
this cell is where you specify the maximum cost of a project. 
 
Adjustable Cell: The cells that Solver will change the contents of to achieve the 
desired objective. 
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Constraints: Contains the restrictions that Excel must observe. 
 

 For example, we can use Solver to figure out the optimal combination of cars we 
should purchase based on budget and other constraints. 

 
 

Installing Solver 
 By default, Solver is not installed with the basic Excel installation.  If Solver is 

installed, it is listed under the Tools menu.  If Solver is not listed, you can 
install it easily. 

 From the main menu, choose Tools > Add-Ins to display the Add-Ins dialog 
box: 
 

 
 

 Select the Solver Add-in checkbox. 
 Click OK to install. 
 
 

Applying Solver 
 Begin by constructing a Worksheet with the data you want Solver to use.  In 

the following example, we have a budget of $500,000 to purchase as many new 
cars as possible for the new company car fleet.  We need a mix of small, 
medium, and large cars: 
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 Select the Target Cell.  In our example, select cell D8. 
 From the main menu, choose Tools > Solver to display the Solver 

Parameters dialog box.  (Notice that the Set Target Cell text box contains cell 
reference $D$8): 
 

 
 

 In the Equal To area, set the Max, Min, or Value of constraint by selecting the 
appropriate radio button, and entering the value into the text box.  In our 
example, we will select Value of and enter 500000 in the text box to set the 
budget constraint. 

 In the By Changing Cells area, select the cell(s) that we want to change to 
meet our target.  In our example, we will be changing the numbers of cars in 
each class; select cell range C4:C6. 
 
Note: If you are not sure which cells to select, click on the Guess button, and 
Excel will suggest a range based on your worksheet. 
 

 In the Subject to the Constraints area, click on the Add button to display the 
Add Constraint dialog box. 

 In the Cell Reference text box, select the cell that the constraint will be applied 
to.  In the dropdown list, select the operand you want.  In the Constraint text 
box, enter a value or cell reference.  For our example, to enter the budget 
constraint of $500,000, we will use $D$8 as the cell reference, select the <= 
(less than or equal to) operand, and enter 500000 as the constrained value: 
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 Click OK to return to the Solver Parameters dialog box 
 
OR click Add to add another constraint. 
 

 When you are satisfied with your Solver Parameters, click Solve.  After a 
short time you will see the Solver Results dialog box: 
 

 
 

 Select the Keep Solver Solution or Restore Original Values radio button. 
 Click OK to apply your choice.  In our example, the worksheet will appear as 

follows: (You may notice that the solution suggests the purchase of part of a 
car.  You can create another constraint to force Excel to solve for whole number 
only): 
 

 
 
 

Changing a Constraint 
 From the Solver Parameters dialog box, select a constraint you want to 

modify. 
 Click on the Change button to display the Change Constraint dialog box: 
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 Make the changes you want. 
 Click OK to return to the Solver Parameters. 
 
 

Deleting a Constraint 
 From the Solver Parameters dialog box, select a constraint you want to delete. 
 Click on the Delete button. 
 
 

Using Pivot Tables 
 
 

Understanding Pivot Tables 
 As the name suggests, a Pivot Table is simply a table of data, but has the 

advantage of allowing you to summarize fields in different dimensions.  They 
seem difficult at first, but the best way to get used to them is to use a pivot 
table and experiment! 

 The example below uses a table containing information relating to sales for a 
company that is selling training courses.  By using a Pivot Table we could easily 
extract and summarize information from this table. 

 
 

 Creating Pivot Tables 
 Open the workbook containing the data from which you wish to create your 

pivot table: 
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 Click within the body of the data and then click on the Data drop down menu 
and select the PivotTable and PivotChart Report command.  This will display 
a wizard. 

 In step one of the PivotTable and PivotChart Wizard, you can specify where the 
data is located and what type of report you wish to create.  In this case accept 
the default offered: 
 

 
 

 Click on the Next button to continue.  This will display the next page of the 
wizard. 

 Step two of the wizard allows you to specify the exact data that you wish to use.  
Again accept the default offered: 
 

 
 

 Clicking on the Finish button will create your pivot table. 
 
 

Dropping data into Pivot Tables 
 Now examine the Pivot Table you have just created.  (As you can see in the  

illustration below, the Pivot Table toolbar is displayed by default): 
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 As you can see in the illustration above, the Pivot Table Field List pane is also 
launched automatically when you create your Pivot Table. 

 To begin creating your Pivot Table, simply drag and drop items from the Pivot 
Table Field List pane to the table.  The following example will illustrate this 
feature: 

 From within the Pivot Table task pane, click on the Sales Person field, and drag 
it into the part of the Pivot Table labeled ‘Drop Row Fields Here’. 

 From within the Pivot Table task pane, click on the Customer field, and drag it 
into the part of the Pivot Table labeled ‘Drop Column Fields Here’. 

 From within the Pivot Table task pane, click on the Total Value field, and drag 
it into the part of the Pivot Table labeled ‘Drop Data Items Here’. 
 
When you have finished, the table should be as illustrated.  As you can see a 
very easy way of extracting and summarizing data!: 
 

 
 
 

Modifying data and refreshing Pivot Tables 
 Following on from our previous example, you will notice that the Pivot Table was 

created on a new worksheet, within your Excel worksheet. 
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 In this example, the Pivot Table is located on the Sheet1 Worksheet, while the 
original Worksheet that the table is based on is located in the Pivot Table Data 
Worksheet. 

 Click on the Pivot Table Data Worksheet tab: 
 

 
 

 Make some changes, such as in this case change the value within cell D4, which 
we have changed from 1 to 10: 
 

 
 

 Click on the Sheet1 tab, which contains the Pivot Table, and you will notice that 
the Pivot Table has not been updated to take account of your changed data: 
 

 
 

 If you click on the Refresh Data icon  (within the Pivot Table toolbar), you 
will see the data change, as illustrated: 
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Grouping data within Pivot Tables 
 Following on from the previous example, let's say that Lou and Sue are working 

together as a team, and we want to group their sales together. 
 First we need to click on cell A5 (the cell containing the text Lou). 
 While depressing the Ctrl key we then need to click on cell A8 (the cell 

containing the text Sue). 
 When you release the Ctrl key, both cells should remain selected. 
 Right click over the selected cells and from the popup menu displayed select the 

Group and Show Detail command.  From the submenu displayed select 
Group: 
 

 
 

 The screen will then change to display the grouped results, as illustrated: 
 

 
 
 

Review Questions 
 
How would you: 

 Use Goal Seek? 
 Use a Data Table? 
 Create a one-variable Data Table? 
 Create a two-variable Data Table? 
 Speed up calculations with Data Tables? 
 Use Scenario Manager? 
 Add a scenario? 
 Show a scenario? 
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 Delete a scenario? 
 Edit an existing scenario? 
 Summarize scenarios? 
 Use Solver? 
 Install Solver? 
 Change a constraint? 
 Delete a constraint? 
 Understand Pivot Tables? 
 Create Pivot Tables? 
 Drop data into Pivot Tables? 
 Modify data and refresh Pivot Tables? 
 Group data within Pivot Tables? 
 

SAMPLE



Page 52 - Excel 2003 - Advanced Level Manual 

FOR USE AT THE LICENSED SITE(S) ONLY 
 Cheltenham Courseware Ltd. 1995-2010 www.cheltenhamcourseware.com 

Macros and Custom Controls 
 
When you have completed this learning module you will have seen how to: 

 Record a Macro 
 Assign a shortcut key to your Macro 
 Run a Macro using the main menu 
 Run a Macro using a shortcut key 
 Run a Macro using a button 
 Work with buttons 
 Create a new button 
 Rename a button 
 Format buttons 
 Link an existing Macro to a button 
 Delete a button 
 
 

Working with Macros 
 
 

Using Macros 
 A Macro is a series of instructions that enables Excel 2003 to perform 

commands or actions for you.  They are useful for complex or repetitive tasks 
that you perform regularly. 

 Macros do not necessarily involve programming.  The easiest way to create a 
new Macro is to have Excel record your actions and then store these actions as a 
Macro.  Actions can be any combination of Excel commands. 

 Macros are very flexible since they can be played back or modified at any time. 
 
 

Recording a Macro 
 From the main menu, choose Tools > Macro > Record New Macro to display 

the Record Macro dialog box: 
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 In the Macro name text box, enter a name for the Macro. 
 In the Description text area, Excel provides a default description of the Macro.  

Edit the description as required. 
 To begin recording, click OK. 
 Start performing the actions you want the Macro to include.  Excel will record 

the actions.   
 When you finish performing the actions, choose Tools > Macro > Stop 

Recording 
 
OR click Stop Recording on the Stop Recording toolbar: 
 

 
 
 

Assigning a shortcut key to your Macro 
 From the main menu, choose Tools > Macro > Macros to display the Macro 

dialog box: 
 

 
 

 Select the Macro you want to affect. 
 Click on the Options button to display the Macro Options dialog box: 

 

SAMPLE



Page 54 - Excel 2003 - Advanced Level Manual 

FOR USE AT THE LICENSED SITE(S) ONLY 
 Cheltenham Courseware Ltd. 1995-2010 www.cheltenhamcourseware.com 

 
 

 Type a letter into the Ctrl+ text box.  This key combination will be used to 
invoke the Macro.  In the above example, the key combination is Ctrl + m. 

 Click OK to return to the Macro dialog box. 
 Click Cancel to close the Macro dialog box. 
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End of the preview sample 
 
 

 
 
This sample is approximately half of the full course.  Please see the table of contents at the 
beginning of this document to see the full list of topics covered in the full course. 
 
To purchase the rights to use the full training manuals at your training centre please see our 
web site at:  
 

http://www.cheltenhamcourseware.com 
 
A courseware licence allows you to make unlimited copies for use at your training centre. 
 

 
 
In addit ion you get HTML formatted versions of each 
course, included w ith our printable coursew are. 
 
Invest in a complete Computer Courseware Library, 
including Windows 7 & Office 2010 
The most cost effective courseware solution for your IT 
training needs. Get ALL our courses, and all new  courses 
released w ithin 12 months. 
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